Bsp1

Ume-Lebern Sourcecode Documentation
Bsp1 Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | ColoredCube | This class represens a color coded cube. It is used to encode positions inside a cubic volume texture in the color channels of this texture.
Public class | MainWindow | This class represents the main window.
Public class | Progress | This class represents a progress bar
Public class | RenderData | This class is responsible for loading a data set
Public class | Renderer | This class manages all rendering operations.
Public class | RenderingForm | This class is used to select a filename for a high res image to be saved
Public class | UnsafeBitmap | This class is a wrapper around a normal Bitmap Class It writes much faster by streaming...

Structures

 | Structure | Description
Public structure | DensityLevels | Structure for Storing Density Levels
Public structure | PixelData | This structure represents a Pixel Color
Public structure | TextureData | Contains RGBA Values for creating the transfer texture.

Enumerations

 | Enumeration | Description
Public enumeration | RenderMethodEnum | Enumeration used to determine how the data set should be rendered.
Public enumeration | SlicingPlaneEnum | Enumeration for possible Slicing Planes, used to determine where and how a slice should be drawn.

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.


ColoredCube Class

ColoredCube Class
See Also Example Members
[image]

This class represens a color coded cube. It is used to encode positions inside a cubic volume texture in the color channels of this texture.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Class ColoredCube
C#
public class ColoredCube
C++
ref class ColoredCube
J#
public class ColoredCube
JScript
public class ColoredCube

Remarks

This class represens a color coded cube. It is used to encode positions inside a cubic volume texture in the color channels of this texture.

Inheritance Hierarchy

System.Object
Bsp1.ColoredCube

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ColoredCube Members
Bsp1 Namespace


ColoredCube Members

ColoredCube Members
See Also Example Constructors Fields Properties Methods Events
[image]

This class represens a color coded cube. It is used to encode positions inside a cubic volume texture in the color channels of this texture.

The following tables list the members exposed by ColoredCube.

Public Constructors

 | Name | Description
Public method | ColoredCube | Main Constructor of the ColoredCube Class.
Top

Public Fields

 | Name | Description
Public field | mData | Reference to the RenderData object.
Public field | mParent | Reference to the parent Window.
Top

Private Fields

 | Name | Description
Private field | mColoredEffect | Shader for rendering the color coded cubes.
Private field | mDevice | Reference to the Render Device.
Private field | mGradDep | Declares how much the rendered Opacity is dependent from the gradient at this point.
Private field | mIntensityEffect | MIP Shader.
Private field | mkA | Ambient Coefficient used for Raytracing.
Private field | mkD | Diffuse Coefficient used for Raytracing.
Private field | mkS | Specular Coefficient used for Raytracing.
Private field | mn | Specular Exponent used for Raytracing.
Private field | mQuadBuffer | Reference to the Vertex Buffer used for rendering the slices.
Private field | mQuatEffect | Slicing Shader.
Private field | mRayEffect | Raytracing Shader.
Private field | mRenderMethod | Declares the Render Method, one out of RenderMethodEnum.
Private field | mSize | Stores the size of the cube.
Private field | mStepsize | Size of a sampling step when doing depth compositing.
Private field | mTranferTextureSize | Size of the transfer Texture.
Private field | mTransferTex | Stores the transfer function.
Private field | mVertexBuffer | Reference to the Vertex Buffer used for rendering the cube.
Private field | mVertexDecl | Reference to the Vertex Declaration.
Top

Public Properties

 | Name | Description
Public property | Ambient | Ambient Coeff Getter and Setter.
Public property | Diffuse | Diffuse Coeff Getter and Setter.
Public property | GradientDependency | Gradient Dependency Getter and Setter.
Public property | RenderMethod | RenderMethod Getter and Setter.
Public property | SpecCoeff | Specular EXPONENT(!) Getter and Setter.
Public property | Specular | Specular Coeff Getter and Setter.
Public property | StepSize | Stepsize Getter and Setter.
Top

Public Methods

 | Name | Description
Public method | Dispose | disposes most MDX Stuff.
Public method | Draw | This methods renders the Data Set. First, the color coded Cubes are rendered and stored in textures. After that, dependent on the selected render method, the data set is rendered by Raytracing of as a Slice.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | LoadData | Loads a data set from a file. Simply calls the mData.OpenFile() method.
Public method | OnCreateDevice | Sets the mDevice member to the newly created Device.
Public method | OnCreateVertexBuffer | This method is called every time a Vertex Buffer is created and sets all vertices needed for rendering a color coded cube or a slice.
Public method | SetSlicingPlane | Creates a slicing plane from the given SlicingPlaneEnum Plane and a position on this axis. Also sets the VertexBuffer.
Public method | SetTransferTexture | Creates a Transfer Texture from the given Density Hashtable.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Public Events

 | Name | Description
Public event | OnDataChanged | Event Handler, called if anything changes and needs to be re-rendered.
Top

See Also

ColoredCube Class


ColoredCube Constructor

ColoredCube Constructor
See Also Example
[image]

Main Constructor of the ColoredCube Class.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal device As Device, _
ByVal size As Vector3, _
ByVal color As Color _
)
C#
public ColoredCube(
Device device,
Vector3 size,
Color color
)
C++
public:
ColoredCube(
Device device,
Vector3 size,
Color color
) sealed
J#
public ColoredCube(
Device device,
Vector3 size,
Color color
)
JScript
public function ColoredCube(
device : Device,
size : Vector3,
color : Color
)

See Also

ColoredCube Class


Fields

ColoredCube Fields
[image]

Public Fields

 | Name | Description
Public field | mData | Reference to the RenderData object.
Public field | mParent | Reference to the parent Window.
Top

Private Fields

 | Name | Description
Private field | mColoredEffect | Shader for rendering the color coded cubes.
Private field | mDevice | Reference to the Render Device.
Private field | mGradDep | Declares how much the rendered Opacity is dependent from the gradient at this point.
Private field | mIntensityEffect | MIP Shader.
Private field | mkA | Ambient Coefficient used for Raytracing.
Private field | mkD | Diffuse Coefficient used for Raytracing.
Private field | mkS | Specular Coefficient used for Raytracing.
Private field | mn | Specular Exponent used for Raytracing.
Private field | mQuadBuffer | Reference to the Vertex Buffer used for rendering the slices.
Private field | mQuatEffect | Slicing Shader.
Private field | mRayEffect | Raytracing Shader.
Private field | mRenderMethod | Declares the Render Method, one out of RenderMethodEnum.
Private field | mSize | Stores the size of the cube.
Private field | mStepsize | Size of a sampling step when doing depth compositing.
Private field | mTranferTextureSize | Size of the transfer Texture.
Private field | mTransferTex | Stores the transfer function.
Private field | mVertexBuffer | Reference to the Vertex Buffer used for rendering the cube.
Private field | mVertexDecl | Reference to the Vertex Declaration.
Top

See Also

ColoredCube Class


mColoredEffect Field

ColoredCube.mColoredEffect Field
[image]

Shader for rendering the color coded cubes.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mColoredEffect As Effect
C#
private Effect mColoredEffect;
C++
private:
Effect mColoredEffect sealed ;
J#
private Effect mColoredEffect
JScript
private mColoredEffect : Effect;

See Also

ColoredCube Class


mData Field

ColoredCube.mData Field
[image]

Reference to the RenderData object.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public mData As RenderData
C#
public RenderData mData;
C++
public:
RenderData mData sealed ;
J#
public RenderData mData
JScript
public mData : RenderData;

See Also

ColoredCube Class


mDevice Field

ColoredCube.mDevice Field
[image]

Reference to the Render Device.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mDevice As Device
C#
private Device mDevice;
C++
private:
Device mDevice sealed ;
J#
private Device mDevice
JScript
private mDevice : Device;

See Also

ColoredCube Class


mGradDep Field

ColoredCube.mGradDep Field
[image]

Declares how much the rendered Opacity is dependent from the gradient at this point.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mGradDep As Single
C#
private float mGradDep;
C++
private:
float mGradDep sealed ;
J#
private float mGradDep
JScript
private mGradDep : float;

See Also

ColoredCube Class


mIntensityEffect Field

ColoredCube.mIntensityEffect Field
[image]

MIP Shader.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mIntensityEffect As Effect
C#
private Effect mIntensityEffect;
C++
private:
Effect mIntensityEffect sealed ;
J#
private Effect mIntensityEffect
JScript
private mIntensityEffect : Effect;

See Also

ColoredCube Class


mkA Field

ColoredCube.mkA Field
[image]

Ambient Coefficient used for Raytracing.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mkA As Single
C#
private float mkA;
C++
private:
float mkA sealed ;
J#
private float mkA
JScript
private mkA : float;

See Also

ColoredCube Class


mkD Field

ColoredCube.mkD Field
[image]

Diffuse Coefficient used for Raytracing.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mkD As Single
C#
private float mkD;
C++
private:
float mkD sealed ;
J#
private float mkD
JScript
private mkD : float;

See Also

ColoredCube Class


mkS Field

ColoredCube.mkS Field
[image]

Specular Coefficient used for Raytracing.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mkS As Single
C#
private float mkS;
C++
private:
float mkS sealed ;
J#
private float mkS
JScript
private mkS : float;

See Also

ColoredCube Class


mn Field

ColoredCube.mn Field
[image]

Specular Exponent used for Raytracing.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mn As Integer
C#
private int mn;
C++
private:
int mn sealed ;
J#
private int mn
JScript
private mn : int;

See Also

ColoredCube Class


mParent Field

ColoredCube.mParent Field
[image]

Reference to the parent Window.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public mParent As MainWindow
C#
public MainWindow mParent;
C++
public:
MainWindow mParent sealed ;
J#
public MainWindow mParent
JScript
public mParent : MainWindow;

See Also

ColoredCube Class


mQuadBuffer Field

ColoredCube.mQuadBuffer Field
[image]

Reference to the Vertex Buffer used for rendering the slices.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mQuadBuffer As VertexBuffer
C#
private VertexBuffer mQuadBuffer;
C++
private:
VertexBuffer mQuadBuffer sealed ;
J#
private VertexBuffer mQuadBuffer
JScript
private mQuadBuffer : VertexBuffer;

See Also

ColoredCube Class


mQuatEffect Field

ColoredCube.mQuatEffect Field
[image]

Slicing Shader.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mQuatEffect As Effect
C#
private Effect mQuatEffect;
C++
private:
Effect mQuatEffect sealed ;
J#
private Effect mQuatEffect
JScript
private mQuatEffect : Effect;

See Also

ColoredCube Class


mRayEffect Field

ColoredCube.mRayEffect Field
[image]

Raytracing Shader.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mRayEffect As Effect
C#
private Effect mRayEffect;
C++
private:
Effect mRayEffect sealed ;
J#
private Effect mRayEffect
JScript
private mRayEffect : Effect;

See Also

ColoredCube Class


mRenderMethod Field

ColoredCube.mRenderMethod Field
[image]

Declares the Render Method, one out of RenderMethodEnum.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mRenderMethod As RenderMethodEnum
C#
private RenderMethodEnum mRenderMethod;
C++
private:
RenderMethodEnum mRenderMethod sealed ;
J#
private RenderMethodEnum mRenderMethod
JScript
private mRenderMethod : RenderMethodEnum;

See Also

ColoredCube Class


mSize Field

ColoredCube.mSize Field
[image]

Stores the size of the cube.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mSize As Vector3
C#
private Vector3 mSize;
C++
private:
Vector3 mSize sealed ;
J#
private Vector3 mSize
JScript
private mSize : Vector3;

See Also

ColoredCube Class


mStepsize Field

ColoredCube.mStepsize Field
[image]

Size of a sampling step when doing depth compositing.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mStepsize As Integer
C#
private int mStepsize;
C++
private:
int mStepsize sealed ;
J#
private int mStepsize
JScript
private mStepsize : int;

See Also

ColoredCube Class


mTranferTextureSize Field

ColoredCube.mTranferTextureSize Field
[image]

Size of the transfer Texture.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mTranferTextureSize As Integer
C#
private int mTranferTextureSize;
C++
private:
int mTranferTextureSize sealed ;
J#
private int mTranferTextureSize
JScript
private mTranferTextureSize : int;

See Also

ColoredCube Class


mTransferTex Field

ColoredCube.mTransferTex Field
[image]

Stores the transfer function.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mTransferTex As Texture
C#
private Texture mTransferTex;
C++
private:
Texture mTransferTex sealed ;
J#
private Texture mTransferTex
JScript
private mTransferTex : Texture;

See Also

ColoredCube Class


mVertexBuffer Field

ColoredCube.mVertexBuffer Field
[image]

Reference to the Vertex Buffer used for rendering the cube.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mVertexBuffer As VertexBuffer
C#
private VertexBuffer mVertexBuffer;
C++
private:
VertexBuffer mVertexBuffer sealed ;
J#
private VertexBuffer mVertexBuffer
JScript
private mVertexBuffer : VertexBuffer;

See Also

ColoredCube Class


mVertexDecl Field

ColoredCube.mVertexDecl Field
[image]

Reference to the Vertex Declaration.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mVertexDecl As VertexDeclaration
C#
private VertexDeclaration mVertexDecl;
C++
private:
VertexDeclaration mVertexDecl sealed ;
J#
private VertexDeclaration mVertexDecl
JScript
private mVertexDecl : VertexDeclaration;

See Also

ColoredCube Class


Properties

ColoredCube Properties
[image]

Public Properties

 | Name | Description
Public property | Ambient | Ambient Coeff Getter and Setter.
Public property | Diffuse | Diffuse Coeff Getter and Setter.
Public property | GradientDependency | Gradient Dependency Getter and Setter.
Public property | RenderMethod | RenderMethod Getter and Setter.
Public property | SpecCoeff | Specular EXPONENT(!) Getter and Setter.
Public property | Specular | Specular Coeff Getter and Setter.
Public property | StepSize | Stepsize Getter and Setter.
Top

See Also

ColoredCube Class


Ambient Property

ColoredCube.Ambient Property
[image]

Ambient Coeff Getter and Setter.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Property Ambient As Single
C#
public float Ambient { get; set; }
C++
public property float Ambient sealed {
float get();
void set(float value);
}
J#
/** property */
public float get_Ambient();

/** property */
public void set_Ambient(float value);
JScript
public function get Ambient() : float

public function set Ambient(value : float);

See Also

ColoredCube Class


Diffuse Property

ColoredCube.Diffuse Property
[image]

Diffuse Coeff Getter and Setter.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Property Diffuse As Single
C#
public float Diffuse { get; set; }
C++
public property float Diffuse sealed {
float get();
void set(float value);
}
J#
/** property */
public float get_Diffuse();

/** property */
public void set_Diffuse(float value);
JScript
public function get Diffuse() : float

public function set Diffuse(value : float);

See Also

ColoredCube Class


GradientDependency Property

ColoredCube.GradientDependency Property
[image]

Gradient Dependency Getter and Setter.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Property GradientDependency As Single
C#
public float GradientDependency { get; set; }
C++
public property float GradientDependency sealed {
float get();
void set(float value);
}
J#
/** property */
public float get_GradientDependency();

/** property */
public void set_GradientDependency(float value);
JScript
public function get GradientDependency() : float

public function set GradientDependency(value : float);

See Also

ColoredCube Class


RenderMethod Property

ColoredCube.RenderMethod Property
[image]

RenderMethod Getter and Setter.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Property RenderMethod As RenderMethodEnum
C#
public RenderMethodEnum RenderMethod { get; set; }
C++
public property RenderMethodEnum RenderMethod sealed {
RenderMethodEnum get();
void set(RenderMethodEnum value);
}
J#
/** property */
public RenderMethodEnum get_RenderMethod();

/** property */
public void set_RenderMethod(RenderMethodEnum value);
JScript
public function get RenderMethod() : RenderMethodEnum

public function set RenderMethod(value : RenderMethodEnum);

See Also

ColoredCube Class


SpecCoeff Property

ColoredCube.SpecCoeff Property
[image]

Specular EXPONENT(!) Getter and Setter.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Property SpecCoeff As Integer
C#
public int SpecCoeff { get; set; }
C++
public property int SpecCoeff sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_SpecCoeff();

/** property */
public void set_SpecCoeff(int value);
JScript
public function get SpecCoeff() : int

public function set SpecCoeff(value : int);

See Also

ColoredCube Class


Specular Property

ColoredCube.Specular Property
[image]

Specular Coeff Getter and Setter.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Property Specular As Single
C#
public float Specular { get; set; }
C++
public property float Specular sealed {
float get();
void set(float value);
}
J#
/** property */
public float get_Specular();

/** property */
public void set_Specular(float value);
JScript
public function get Specular() : float

public function set Specular(value : float);

See Also

ColoredCube Class


StepSize Property

ColoredCube.StepSize Property
[image]

Stepsize Getter and Setter.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Property StepSize As Integer
C#
public int StepSize { get; set; }
C++
public property int StepSize sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_StepSize();

/** property */
public void set_StepSize(int value);
JScript
public function get StepSize() : int

public function set StepSize(value : int);

See Also

ColoredCube Class


Methods

ColoredCube Methods
[image]

Public Methods

 | Name | Description
Public method | Dispose | disposes most MDX Stuff.
Public method | Draw | This methods renders the Data Set. First, the color coded Cubes are rendered and stored in textures. After that, dependent on the selected render method, the data set is rendered by Raytracing of as a Slice.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | LoadData | Loads a data set from a file. Simply calls the mData.OpenFile() method.
Public method | OnCreateDevice | Sets the mDevice member to the newly created Device.
Public method | OnCreateVertexBuffer | This method is called every time a Vertex Buffer is created and sets all vertices needed for rendering a color coded cube or a slice.
Public method | SetSlicingPlane | Creates a slicing plane from the given SlicingPlaneEnum Plane and a position on this axis. Also sets the VertexBuffer.
Public method | SetTransferTexture | Creates a Transfer Texture from the given Density Hashtable.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ColoredCube Class


Dispose Method

ColoredCube.Dispose Method
[image]

disposes most MDX Stuff.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub Dispose( _
ByVal disposing As Boolean _
)
C#
public void Dispose(
bool disposing
)
C++
public:
void Dispose(
bool disposing
) sealed
J#
public void Dispose(
bool disposing
)
JScript
public function Dispose(
disposing : bool
)

See Also

ColoredCube Class


Draw Method

ColoredCube.Draw Method
[image]

This methods renders the Data Set. First, the color coded Cubes are rendered and stored in textures. After that, dependent on the selected render method, the data set is rendered by Raytracing of as a Slice.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub Draw()
C#
public void Draw()
C++
public:
void Draw() sealed
J#
public void Draw()
JScript
public function Draw()

See Also

ColoredCube Class


LoadData Method

ColoredCube.LoadData Method
[image]

Loads a data set from a file. Simply calls the mData.OpenFile() method.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub LoadData( _
ByVal filename As String _
)
C#
public void LoadData(
string filename
)
C++
public:
void LoadData(
String filename
) sealed
J#
public void LoadData(
string filename
)
JScript
public function LoadData(
filename : String
)

See Also

ColoredCube Class


OnCreateDevice Method

ColoredCube.OnCreateDevice Method
[image]

Sets the mDevice member to the newly created Device.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub OnCreateDevice( _
ByVal device As Device _
)
C#
public void OnCreateDevice(
Device device
)
C++
public:
void OnCreateDevice(
Device device
) sealed
J#
public void OnCreateDevice(
Device device
)
JScript
public function OnCreateDevice(
device : Device
)

See Also

ColoredCube Class


OnCreateVertexBuffer Method

ColoredCube.OnCreateVertexBuffer Method
[image]

This method is called every time a Vertex Buffer is created and sets all vertices needed for rendering a color coded cube or a slice.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub OnCreateVertexBuffer( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
C#
public void OnCreateVertexBuffer(
object sender,
EventArgs e
)
C++
public:
void OnCreateVertexBuffer(
Object sender,
EventArgs e
) sealed
J#
public void OnCreateVertexBuffer(
object sender,
EventArgs e
)
JScript
public function OnCreateVertexBuffer(
sender : Object,
e : EventArgs
)

See Also

ColoredCube Class


SetSlicingPlane Method

ColoredCube.SetSlicingPlane Method
[image]

Creates a slicing plane from the given SlicingPlaneEnum Plane and a position on this axis. Also sets the VertexBuffer.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub SetSlicingPlane( _
ByVal SliceValue As Single, _
ByVal Plane As SlicingPlaneEnum _
)
C#
public void SetSlicingPlane(
float SliceValue,
SlicingPlaneEnum Plane
)
C++
public:
void SetSlicingPlane(
float SliceValue,
SlicingPlaneEnum Plane
) sealed
J#
public void SetSlicingPlane(
float SliceValue,
SlicingPlaneEnum Plane
)
JScript
public function SetSlicingPlane(
SliceValue : float,
Plane : SlicingPlaneEnum
)

See Also

ColoredCube Class


SetTransferTexture Method

ColoredCube.SetTransferTexture Method
[image]

Creates a Transfer Texture from the given Density Hashtable.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub SetTransferTexture( _
ByVal Density As Hashtable _
)
C#
public void SetTransferTexture(
Hashtable Density
)
C++
public:
void SetTransferTexture(
Hashtable Density
) sealed
J#
public void SetTransferTexture(
Hashtable Density
)
JScript
public function SetTransferTexture(
Density : Hashtable
)

See Also

ColoredCube Class


Events

ColoredCube Events
[image]

Public Events

 | Name | Description
Public event | OnDataChanged | Event Handler, called if anything changes and needs to be re-rendered.
Top

See Also

ColoredCube Class


OnDataChanged Event

ColoredCube.OnDataChanged Event
[image]

Event Handler, called if anything changes and needs to be re-rendered.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Event OnDataChanged As EventHandler
C#
public event EventHandler OnDataChanged
C++
public:
virtual event EventHandler OnDataChanged {
void add(EventHandler value) sealed ;
void remove(EventHandler value) sealed ;
}
J#
/** event */
public final void add_OnDataChanged(EventHandler value);

/** event */
public final void remove_OnDataChanged(EventHandler value);
JScript
JScript suports the use of events, but not the declaration of new ones.

See Also

ColoredCube Class


DensityLevels Structure

DensityLevels Structure
See Also Example Members
[image]

Structure for Storing Density Levels

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Structure DensityLevels
C#
public struct DensityLevels
C++
value class DensityLevels
J#
public final class DensityLevels extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Remarks

Structure for Storing Density Levels

Inheritance Hierarchy

System.Object
Bsp1.DensityLevels

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DensityLevels Members


DensityLevels Members

DensityLevels Members
See Also Example Constructors Fields Methods
[image]

Structure for Storing Density Levels

The following tables list the members exposed by DensityLevels.

Public Constructors

 | Name | Description
Public method | DensityLevels | standard constructor
Top

Public Fields

 | Name | Description
Public field | Alpha | Alpha Value of this Level
Public field | Color | Color of this Level
Public field | Density | Density of this Level
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

See Also

DensityLevels Structure


DensityLevels Constructor

DensityLevels Constructor
[image]

standard constructor

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal density As Short, _
ByVal alpha As Short, _
ByVal color As PixelData _
)
C#
public DensityLevels(
short density,
short alpha,
PixelData color
)
C++
public:
DensityLevels(
short density,
short alpha,
PixelData color
) sealed
J#
public DensityLevels(
short density,
short alpha,
PixelData color
)
JScript
public function DensityLevels(
density : short,
alpha : short,
color : PixelData
)

See Also

DensityLevels Structure


Fields

DensityLevels Fields
[image]

Public Fields

 | Name | Description
Public field | Alpha | Alpha Value of this Level
Public field | Color | Color of this Level
Public field | Density | Density of this Level
Top

See Also

DensityLevels Structure


Alpha Field

DensityLevels.Alpha Field
[image]

Alpha Value of this Level

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Alpha As Short
C#
public short Alpha;
C++
public:
short Alpha sealed ;
J#
public short Alpha
JScript
public Alpha : short;

See Also

DensityLevels Structure


Color Field

DensityLevels.Color Field
[image]

Color of this Level

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Color As PixelData
C#
public PixelData Color;
C++
public:
PixelData Color sealed ;
J#
public PixelData Color
JScript
public Color : PixelData;

See Also

DensityLevels Structure


Density Field

DensityLevels.Density Field
[image]

Density of this Level

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Density As Short
C#
public short Density;
C++
public:
short Density sealed ;
J#
public short Density
JScript
public Density : short;

See Also

DensityLevels Structure


MainWindow Class

MainWindow Class
See Also Example Members
[image]

This class represents the main window.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Class MainWindow
Inherits Form
C#
public class MainWindow : Form
C++
ref class MainWindow : Form
J#
public class MainWindow extends Form
JScript
public class MainWindow extends Form

Remarks

This class represents the main window.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Bsp1.MainWindow

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

MainWindow Members


MainWindow Members

MainWindow Members
See Also Example Constructors Fields Properties Methods Events Explicit Inteface Implementations
[image]

This class represents the main window.

The following tables list the members exposed by MainWindow.

Public Constructors

 | Name | Description
Public method | MainWindow | Initializes a new instance of the MainWindow class.
Top

Public Fields

 | Name | Description
Public field | D3DPanel |
 | mRenderer | reference to the render class.
Top

Private Fields

 | Name | Description
Private field | components | Erforderliche Designervariable.
Private field | fileToolStripMenuItem |
Private field | gbRaycast |
Private field | gBSlicing |
Private field | label1 |
Private field | label2 |
Private field | label3 |
Private field | label4 |
Private field | label5 |
Private field | label6 |
Private field | menuStrip1 |
Private field | mMouseDownLeft | If left mouse button is pressed.
Private field | mMouseDownMiddle | If middle mouse button is pressed.
Private field | mMouseDownRight | If right mouse button is pressed.
Private field | mOldMouse | Last known mouse position.
Private field | mRot | last mouse position change when rotating the object.
Private field | mRotLight | last mouse position change when rotating the light source.
Private field | openToolStripMenuItem |
Private field | opnFileDlg |
Private field | rbMaxIntensity |
Private field | rbRaycasting |
Private field | rbSlicing |
Private field | rbXAxis |
Private field | rbYAxis |
Private field | rbZAxis |
Private field | rednerHighResToolStripMenuItem |
Private field | tbCoeff |
Private field | tbGradDep |
Private field | tbkA |
Private field | tbkD |
Private field | tbkS |
Private field | tbSlicing |
Private field | tbStepSize |
Private field | uiHistogram1 |
Top

Public Properties

 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control)
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control)
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl)
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control)
Public property | AutoScale | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView. (inherited from Control)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl)
Public property | AutoSize | (inherited from Form)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form)
Public property | AutoValidate | (inherited from Form)
Public property | BackColor | (inherited from Form)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control)
Public property | BindingContext | (inherited from ContainerControl)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control)
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control)
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form)
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control)
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control)
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form)
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control)
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control)
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control)
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control)
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form)
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control)
Public property | Height | Gets or sets the height of the control. (inherited from Control)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl)
Public property | Icon | Gets or sets the icon for the form. (inherited from Form)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control)
Public property | Location | (inherited from Form)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form)
Public property | Margin | (inherited from Form)
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form)
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form)
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form)
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form)
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form)
Public property | Name | Gets or sets the name of the control. (inherited from Control)
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form)
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form)
Public property | Padding | Gets or sets padding within the control. (inherited from Control)
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control)
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control)
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control)
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control)
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form)
Public property | Site | Gets or sets the site of the control. (inherited from Control)
Public property | Size | Gets or sets the size of the form. (inherited from Form)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form)
Public property | TabStop | (inherited from Form)
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control)
Public property | Text | (inherited from Form)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl)
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control)
Public property | Width | Gets or sets the width of the control. (inherited from Control)
Public property | WindowState | Gets or sets the form's window state. (inherited from Form)
Public property | WindowTarget | (inherited from Control)
Top

Protected Properties

 | Name | Description
Family property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (inherited from ContainerControl)
Family property | CanRaiseEvents | Determines if events can be raised on the control. (inherited from Control)
Family property | CreateParams | (inherited from Form)
Family property | DefaultCursor | Gets or sets the default cursor for the control. (inherited from Control)
Family property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (inherited from Form)
Family property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (inherited from Control)
Family property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (inherited from Control)
Family property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (inherited from Control)
Family property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (inherited from Control)
Family property | DefaultSize | (inherited from Form)
Family property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (inherited from Component)
Family property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (inherited from Control)
Family property | Events | Gets the list of event handlers that are attached to this Component. (inherited from Component)
Family property | FontHeight | Gets or sets the height of the font of the control. (inherited from Control)
Family property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (inherited from ScrollableControl)
Family property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (inherited from Form)
Family property | RenderRightToLeft | (inherited from Control)
Family property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (inherited from Control)
Family property | ScaleChildren | Gets a value that determines the scaling of child controls. (inherited from Control)
Family property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (inherited from Control)
Family property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (inherited from Control)
Family property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (inherited from Form)
Family property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (inherited from ScrollableControl)
Top

Public Methods

 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form)
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form)
Public method | BeginInvoke | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control)
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control)
Public method | Close | Closes the form. (inherited from Form)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control)
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Overloaded. Releases the resources used by the form.
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (inherited from Control)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control)
Public method | Focus | Sets input focus to the control. (inherited from Control)
Public method | GetChildAtPoint | Overloaded. Retrieves the child control at a specified location. (inherited from Control)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Hide | Conceals the control from the user. (inherited from Control)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | Invalidate | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control. (inherited from Control)
Public method | Invoke | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle. (inherited from Control)
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl)
Public method | PerformLayout | Overloaded. Forces the control to apply layout logic to child controls. (inherited from Control)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control)
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form)
Public method | ResetBackColor | (inherited from Control)
Public method | ResetBindings | (inherited from Control)
Public method | ResetCursor | (inherited from Control)
Public method | ResetFont | (inherited from Control)
Public method | ResetForeColor | (inherited from Control)
Public method | ResetImeMode | (inherited from Control)
Public method | ResetRightToLeft | (inherited from Control)
Public method | ResetText | Resets the Text property to its default value. (inherited from Control)
Public method | ResumeLayout | Overloaded. Resumes the usual layout logic. (inherited from Control)
Public method | Scale | Overloaded. Scales the control and any child controls. (inherited from Control)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl)
Public method | Select | Overloaded. Activates the form and selects a child control. (inherited from Form)
Public method | SelectNextControl | Activates the next control. (inherited from Control)
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl)
Public method | SetBounds | Overloaded. Sets the bounds of the control. (inherited from Control)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form)
Public method | Show | Overloaded. Displays the form. (inherited from Form)
Public method | ShowDialog | Overloaded. Shows the form as a modal dialog box. (inherited from Form)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control)
Public method | ToString | (inherited from Form)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control)
Public method | Validate | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl)
Public method | ValidateChildren | Overloaded. Validates all selectable child controls in the form. (inherited from Form)
Top

Protected Methods

 | Name | Description
Family method | AccessibilityNotifyClients | Overloaded. Notifies the accessibility client applications of AccessibleEvents. (inherited from Control)
Family method | ActivateMdiChild | Activates the MDI child of a form. (inherited from Form)
Family method | AdjustFormScrollbars | (inherited from Form)
Family method | ApplyAutoScaling | Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (inherited from Form)
Family method | CenterToParent | Centers the position of the form within the bounds of the parent form. (inherited from Form)
Family method | CenterToScreen | Centers the form on the current screen. (inherited from Form)
Family method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (inherited from Control)
Family method | CreateControlsInstance | (inherited from Form)
Family method | CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (inherited from Form)
Family method | DefWndProc | (inherited from Form)
Family method | DestroyHandle | Destroys the handle associated with the control. (inherited from Control)
Family method | Dispose | Overloaded. Releases the resources used by the form.
Family method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (inherited from Component)
Family method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (inherited from Control)
Family method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (inherited from Control)
Family method | GetScaledBounds | (inherited from Form)
Family method | GetScrollState | Determines whether the specified flag has been set. (inherited from ScrollableControl)
Family method | GetService | Returns an object that represents a service provided by the Component or by its Container. (inherited from Component)
Family method | GetStyle | Retrieves the value of the specified control style bit for the control. (inherited from Control)
Family method | GetTopLevel | Determines if the control is a top-level control. (inherited from Control)
Family method | InitLayout | Called after the control has been added to another container. (inherited from Control)
Family method | InvokeGotFocus | Raises the GotFocus event for the specified control. (inherited from Control)
Family method | InvokeLostFocus | Raises the LostFocus event for the specified control. (inherited from Control)
Family method | InvokeOnClick | Raises the Click event for the specified control. (inherited from Control)
Family method | InvokePaint | Raises the Paint event for the specified control. (inherited from Control)
Family method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (inherited from Control)
Family method | IsInputChar | Determines if a character is an input character that the control recognizes. (inherited from Control)
Family method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (inherited from Control)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (inherited from Control)
Family method | OnActivated | Raises the Activated event. (inherited from Form)
Family method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (inherited from Control)
Family method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (inherited from ContainerControl)
Family method | OnBackColorChanged | Raises the BackColorChanged event. (inherited from Control)
Family method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (inherited from Form)
Family method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (inherited from Form)
Family method | OnBindingContextChanged | Raises the BindingContextChanged event. (inherited from Control)
Family method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (inherited from Control)
Family method | OnChangeUICues | Raises the ChangeUICues event. (inherited from Control)
Family method | OnClick | Raises the Click event. (inherited from Control)
Family method | OnClientSizeChanged | Raises the ClientSizeChanged event. (inherited from Control)
Family method | OnClosed | Raises the Closed event. (inherited from Form)
Family method | OnClosing | Raises the Closing event. (inherited from Form)
Family method | OnContextMenuChanged | Raises the ContextMenuChanged event. (inherited from Control)
Family method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (inherited from Control)
Family method | OnControlAdded | Raises the ControlAdded event. (inherited from Control)
Family method | OnControlRemoved | Raises the ControlRemoved event. (inherited from Control)
Family method | OnCreateControl | Raises the CreateControl event. (inherited from Form)
Family method | OnCursorChanged | Raises the CursorChanged event. (inherited from Control)
Family method | OnDeactivate | Raises the Deactivate event. (inherited from Form)
Family method | OnDockChanged | Raises the DockChanged event. (inherited from Control)
Family method | OnDoubleClick | Raises the DoubleClick event. (inherited from Control)
Family method | OnDragDrop | Raises the DragDrop event. (inherited from Control)
Family method | OnDragEnter | Raises the DragEnter event. (inherited from Control)
Family method | OnDragLeave | Raises the DragLeave event. (inherited from Control)
Family method | OnDragOver | Raises the DragOver event. (inherited from Control)
Family method | OnEnabledChanged | (inherited from Form)
Family method | OnEnter | Raises the Enter event. (inherited from Form)
Family method | OnFontChanged | (inherited from Form)
Family method | OnForeColorChanged | Raises the ForeColorChanged event. (inherited from Control)
Family method | OnFormClosed | Raises the FormClosed event. (inherited from Form)
Family method | OnFormClosing | Raises the FormClosing event. (inherited from Form)
Family method | OnGiveFeedback | Raises the GiveFeedback event. (inherited from Control)
Family method | OnGotFocus | Raises the GotFocus event. (inherited from Control)
Family method | OnHandleCreated | (inherited from Form)
Family method | OnHandleDestroyed | (inherited from Form)
Family method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (inherited from Form)
Family method | OnHelpRequested | Raises the HelpRequested event. (inherited from Control)
Family method | OnImeModeChanged | Raises the ImeModeChanged event. (inherited from Control)
Family method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (inherited from Form)
Family method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (inherited from Form)
Family method | OnInvalidated | Raises the Invalidated event. (inherited from Control)
Family method | OnKeyDown | Overridden. event handler
Family method | OnKeyPress | Raises the KeyPress event. (inherited from Control)
Family method | OnKeyUp | Raises the KeyUp event. (inherited from Control)
Family method | OnLayout | (inherited from Form)
Family method | OnLeave | Raises the Leave event. (inherited from Control)
Family method | OnLoad | Raises the Load event. (inherited from Form)
Family method | OnLocationChanged | Raises the LocationChanged event. (inherited from Control)
Family method | OnLostFocus | Raises the LostFocus event. (inherited from Control)
Family method | OnMarginChanged | Raises the MarginChanged event. (inherited from Control)
Family method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (inherited from Form)
Family method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (inherited from Form)
Family method | OnMdiChildActivate | Raises the MdiChildActivate event. (inherited from Form)
Family method | OnMenuComplete | Raises the MenuComplete event. (inherited from Form)
Family method | OnMenuStart | Raises the MenuStart event. (inherited from Form)
Family method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (inherited from Form)
Family method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (inherited from Control)
Family method | OnMouseClick | Raises the MouseClick event. (inherited from Control)
Family method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (inherited from Control)
Family method | OnMouseDown | Raises the MouseDown event. (inherited from Control)
Family method | OnMouseEnter | Raises the MouseEnter event. (inherited from Control)
Family method | OnMouseHover | Raises the MouseHover event. (inherited from Control)
Family method | OnMouseLeave | Raises the MouseLeave event. (inherited from Control)
Family method | OnMouseMove | Raises the MouseMove event. (inherited from Control)
Family method | OnMouseUp | Raises the MouseUp event. (inherited from Control)
Family method | OnMouseWheel | Raises the MouseWheel event. (inherited from ScrollableControl)
Family method | OnMove | Raises the Move event. (inherited from Control)
Family method | OnNotifyMessage | Notifies the control of Windows messages. (inherited from Control)
Family method | OnPaddingChanged | (inherited from ScrollableControl)
Family method | OnPaint | (inherited from Form)
Family method | OnPaintBackground | (inherited from ScrollableControl)
Family method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (inherited from Control)
Family method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (inherited from Control)
Family method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (inherited from Control)
Family method | OnParentChanged | (inherited from ContainerControl)
Family method | OnParentCursorChanged | Raises the CursorChanged event. (inherited from Control)
Family method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (inherited from Control)
Family method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (inherited from Control)
Family method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (inherited from Control)
Family method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (inherited from Control)
Family method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (inherited from Control)
Family method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (inherited from Control)
Family method | OnPrint | Raises the Paint event. (inherited from Control)
Family method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (inherited from Control)
Family method | OnRegionChanged | Raises the RegionChanged event. (inherited from Control)
Family method | OnResize | (inherited from Form)
Family method | OnResizeBegin | Raises the ResizeBegin event. (inherited from Form)
Family method | OnResizeEnd | Raises the ResizeEnd event. (inherited from Form)
Family method | OnRightToLeftChanged | (inherited from ScrollableControl)
Family method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (inherited from Form)
Family method | OnScroll | Raises the Scroll event. (inherited from ScrollableControl)
Family method | OnShown | Raises the Shown event. (inherited from Form)
Family method | OnSizeChanged | Raises the SizeChanged event. (inherited from Control)
Family method | OnStyleChanged | (inherited from Form)
Family method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (inherited from Control)
Family method | OnTabIndexChanged | Raises the TabIndexChanged event. (inherited from Control)
Family method | OnTabStopChanged | Raises the TabStopChanged event. (inherited from Control)
Family method | OnTextChanged | (inherited from Form)
Family method | OnValidated | Raises the Validated event. (inherited from Control)
Family method | OnValidating | Raises the Validating event. (inherited from Control)
Family method | OnVisibleChanged | Raises the VisibleChanged event. (inherited from Form)
Family method | ProcessCmdKey | Processes a command key. (inherited from Form)
Family method | ProcessDialogChar | (inherited from Form)
Family method | ProcessDialogKey | Processes a dialog key. (inherited from Form)
Family method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (inherited from Control)
Family method | ProcessKeyMessage | Processes a keyboard message. (inherited from Control)
Family method | ProcessKeyPreview | (inherited from Form)
Family method | ProcessMnemonic | (inherited from Form)
Family method | ProcessTabKey | (inherited from Form)
Family method | RaiseDragEvent | Raises the appropriate drag event. (inherited from Control)
Family method | RaiseKeyEvent | Raises the appropriate key event. (inherited from Control)
Family method | RaiseMouseEvent | Raises the appropriate mouse event. (inherited from Control)
Family method | RaisePaintEvent | Raises the appropriate paint event. (inherited from Control)
Family method | RecreateHandle | Forces the re-creation of the handle for the control. (inherited from Control)
Family method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (inherited from Control)
Family method | RtlTranslateAlignment | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text. (inherited from Control)
Family method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (inherited from Control)
Family method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (inherited from Control)
Family method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (inherited from Control)
Family method | ScaleControl | (inherited from Form)
Family method | ScaleCore | Base function that performs scaling of the form. (inherited from Form)
Family method | ScrollToControl | Calculates the scroll offset to the specified child control. (inherited from ScrollableControl)
Family method | Select | Overloaded. Activates the form and selects a child control. (inherited from Form)
Family method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (inherited from Control)
Family method | SetBoundsCore | (inherited from Form)
Family method | SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (inherited from Form)
Family method | SetDisplayRectLocation | Positions the display window to the specified value. (inherited from ScrollableControl)
Family method | SetScrollState | Sets the specified scroll state flag. (inherited from ScrollableControl)
Family method | SetStyle | Sets the specified style bit to the specified value. (inherited from Control)
Family method | SetTopLevel | Sets the control as the top-level control. (inherited from Control)
Family method | SetVisibleCore | (inherited from Form)
Family method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (inherited from Control)
Family method | UpdateBounds | Overloaded. Updates the bounds of the control. (inherited from Control)
Family method | UpdateDefaultButton | Updates which button is the default button. (inherited from Form)
Family method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (inherited from Control)
Family method | UpdateZOrder | Updates the control in its parent's z-order. (inherited from Control)
Family method | WndProc | (inherited from Form)
Top

Private Methods

 | Name | Description
Private method | D3DOnMouseDown | event handler
Private method | D3DOnMouseMove | event handler
Private method | D3DOnMouseUp | event handler
Private method | HistoChanged | event handler: if the histogram was changed, update the transfer texture.
Private method | InitializeComponent | Erforderliche Methode für die Designerunterstützung. Der Inhalt der Methode darf nicht mit dem Code-Editor geändert werden.
Private method | openToolStripMenuItem_Click | event handler: Opens a file dialog to select a data set.
Private method | opnFileDlg_FileOk | event handler: if valid file selected, load the data.
Private method | rbMaxIntensity_CheckedChanged | event handler
Private method | rbRaycasting_CheckedChanged | event handler: Saves a high-res image.
Private method | rbSlicing_CheckedChanged | event handler
Private method | rbXAxis_CheckedChanged | event handler
Private method | rbYAxis_CheckedChanged | event handler
Private method | rbZAxis_CheckedChanged | event handler
Private method | rbZAxis_CheckedChanged_1 | event handler
Private method | rednerHighResToolStripMenuItem_Click | event handler: select file to save a high-res image.
Private method | saveImage_FileOk | event handler: Saves a high-res image if path correct.
Private method | tbCoeff_Scroll | event handler
Private method | tbGradDep_Scroll | event handler
Private method | tbkA_Scroll | event handler
Private method | tbkD_Scroll | event handler
Private method | tbkS_Scroll | event handler
Private method | tbSlicing_Scroll | event handler
Private method | tbStepSize_Scroll | event handler
Top

Public Events

 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form)
Public event | AutoSizeChanged | (inherited from Form)
Public event | AutoValidateChanged | (inherited from Form)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control)
Public event | Click | Occurs when the control is clicked. (inherited from Control)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control)
Public event | Closed | Occurs when the form is closed. (inherited from Form)
Public event | Closing | Occurs when the form is closing. (inherited from Form)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control)
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control)
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form)
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component)
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control)
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control)
Public event | Enter | Occurs when the control is entered. (inherited from Control)
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control)
Public event | FormClosed | Occurs after the form is closed. (inherited from Form)
Public event | FormClosing | Occurs before the form is closed. (inherited from Form)
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control)
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control)
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form)
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form)
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control)
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control)
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control)
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control)
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form)
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control)
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control)
Public event | MarginChanged | (inherited from Form)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form)
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form)
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control)
Public event | Move | Occurs when the control is moved. (inherited from Control)
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control)
Public event | Paint | Occurs when the control is redrawn. (inherited from Control)
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control)
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control)
Public event | Resize | Occurs when the control is resized. (inherited from Control)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl)
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form)
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control)
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control)
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form)
Public event | TabStopChanged | (inherited from Form)
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control)
Public event | Validated | Occurs when the control is finished validating. (inherited from Control)
Public event | Validating | Occurs when the control is validating. (inherited from Control)
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control)
Top

Explicit Interface Implementations

Name | Description
System#Windows#Forms#IContainerControl#ActivateControl | Activates a specified control. (inherited from ContainerControl)
System#Windows#Forms#IDropTarget#OnDragDrop | Raises the DragDrop event. (inherited from Control)
System#Windows#Forms#IDropTarget#OnDragEnter | Raises the DragEnter event. (inherited from Control)
System#Windows#Forms#IDropTarget#OnDragLeave | Raises the DragLeave event. (inherited from Control)
System#Windows#Forms#IDropTarget#OnDragOver | Raises the DragOver event. (inherited from Control)
System#Windows#Forms#ISupportOleDropSource#OnGiveFeedback | (inherited from Control)
System#Windows#Forms#ISupportOleDropSource#OnQueryContinueDrag | (inherited from Control)
System#Windows#Forms#Layout#IArrangedElement#PerformLayout | (inherited from Control)
System#Windows#Forms#Layout#IArrangedElement#SetBounds | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleControl#FreezeEvents | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleControl#GetControlInfo | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleControl#OnAmbientPropertyChange | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleControl#OnMnemonic | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#ContextSensitiveHelp | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#EnableModeless | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#GetWindow | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#OnDocWindowActivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#OnFrameWindowActivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#ResizeBorder | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#TranslateAccelerator | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#ContextSensitiveHelp | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#GetWindow | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#InPlaceDeactivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#ReactivateAndUndo | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#SetObjectRects | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#UIDeactivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#Advise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#Close | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#DoVerb | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#EnumAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#EnumVerbs | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetClientSite | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetClipboardData | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetMiscStatus | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetMoniker | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetUserClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetUserType | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#InitFromData | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#IsUpToDate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#OleUpdate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetClientSite | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetColorScheme | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetHostNames | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetMoniker | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#Unadvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleWindow#ContextSensitiveHelp | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleWindow#GetWindow | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersist#GetClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistPropertyBag#GetClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistPropertyBag#InitNew | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistPropertyBag#Load | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistPropertyBag#Save | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#GetClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#HandsOffStorage | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#InitNew | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#IsDirty | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#Load | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#Save | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#SaveCompleted | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#GetClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#GetSizeMax | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#InitNew | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#IsDirty | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#Load | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#Save | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IQuickActivate#GetContentExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IQuickActivate#QuickActivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IQuickActivate#SetContentExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#Draw | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#Freeze | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#GetAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#GetColorSet | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#SetAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#Unfreeze | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#Draw | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#Freeze | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#GetAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#GetColorSet | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#GetExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#SetAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#Unfreeze | (inherited from Control)
Top

See Also

MainWindow Class


MainWindow Constructor

MainWindow Constructor
[image]

Initializes a new instance of the MainWindow class.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public MainWindow()
C++
public:
MainWindow() sealed
J#
public MainWindow()
JScript
public function MainWindow()

See Also

MainWindow Class


Fields

MainWindow Fields
[image]

Public Fields

 | Name | Description
Public field | D3DPanel |
 | mRenderer | reference to the render class.
Top

Private Fields

 | Name | Description
Private field | components | Erforderliche Designervariable.
Private field | fileToolStripMenuItem |
Private field | gbRaycast |
Private field | gBSlicing |
Private field | label1 |
Private field | label2 |
Private field | label3 |
Private field | label4 |
Private field | label5 |
Private field | label6 |
Private field | menuStrip1 |
Private field | mMouseDownLeft | If left mouse button is pressed.
Private field | mMouseDownMiddle | If middle mouse button is pressed.
Private field | mMouseDownRight | If right mouse button is pressed.
Private field | mOldMouse | Last known mouse position.
Private field | mRot | last mouse position change when rotating the object.
Private field | mRotLight | last mouse position change when rotating the light source.
Private field | openToolStripMenuItem |
Private field | opnFileDlg |
Private field | rbMaxIntensity |
Private field | rbRaycasting |
Private field | rbSlicing |
Private field | rbXAxis |
Private field | rbYAxis |
Private field | rbZAxis |
Private field | rednerHighResToolStripMenuItem |
Private field | tbCoeff |
Private field | tbGradDep |
Private field | tbkA |
Private field | tbkD |
Private field | tbkS |
Private field | tbSlicing |
Private field | tbStepSize |
Private field | uiHistogram1 |
Top

See Also

MainWindow Class


components Field

MainWindow.components Field
[image]

Erforderliche Designervariable.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private components As IContainer
C#
private IContainer components;
C++
private:
IContainer components sealed ;
J#
private IContainer components
JScript
private components : IContainer;

See Also

MainWindow Class


D3DPanel Field

MainWindow.D3DPanel Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public D3DPanel As Panel
C#
public Panel D3DPanel;
C++
public:
Panel D3DPanel sealed ;
J#
public Panel D3DPanel
JScript
public D3DPanel : Panel;

See Also

MainWindow Class


fileToolStripMenuItem Field

MainWindow.fileToolStripMenuItem Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private fileToolStripMenuItem As ToolStripMenuItem
C#
private ToolStripMenuItem fileToolStripMenuItem;
C++
private:
ToolStripMenuItem fileToolStripMenuItem sealed ;
J#
private ToolStripMenuItem fileToolStripMenuItem
JScript
private fileToolStripMenuItem : ToolStripMenuItem;

See Also

MainWindow Class


gbRaycast Field

MainWindow.gbRaycast Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private gbRaycast As GroupBox
C#
private GroupBox gbRaycast;
C++
private:
GroupBox gbRaycast sealed ;
J#
private GroupBox gbRaycast
JScript
private gbRaycast : GroupBox;

See Also

MainWindow Class


gBSlicing Field

MainWindow.gBSlicing Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private gBSlicing As GroupBox
C#
private GroupBox gBSlicing;
C++
private:
GroupBox gBSlicing sealed ;
J#
private GroupBox gBSlicing
JScript
private gBSlicing : GroupBox;

See Also

MainWindow Class


label1 Field

MainWindow.label1 Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private label1 As Label
C#
private Label label1;
C++
private:
Label label1 sealed ;
J#
private Label label1
JScript
private label1 : Label;

See Also

MainWindow Class


label2 Field

MainWindow.label2 Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private label2 As Label
C#
private Label label2;
C++
private:
Label label2 sealed ;
J#
private Label label2
JScript
private label2 : Label;

See Also

MainWindow Class


label3 Field

MainWindow.label3 Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private label3 As Label
C#
private Label label3;
C++
private:
Label label3 sealed ;
J#
private Label label3
JScript
private label3 : Label;

See Also

MainWindow Class


label4 Field

MainWindow.label4 Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private label4 As Label
C#
private Label label4;
C++
private:
Label label4 sealed ;
J#
private Label label4
JScript
private label4 : Label;

See Also

MainWindow Class


label5 Field

MainWindow.label5 Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private label5 As Label
C#
private Label label5;
C++
private:
Label label5 sealed ;
J#
private Label label5
JScript
private label5 : Label;

See Also

MainWindow Class


label6 Field

MainWindow.label6 Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private label6 As Label
C#
private Label label6;
C++
private:
Label label6 sealed ;
J#
private Label label6
JScript
private label6 : Label;

See Also

MainWindow Class


menuStrip1 Field

MainWindow.menuStrip1 Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private menuStrip1 As MenuStrip
C#
private MenuStrip menuStrip1;
C++
private:
MenuStrip menuStrip1 sealed ;
J#
private MenuStrip menuStrip1
JScript
private menuStrip1 : MenuStrip;

See Also

MainWindow Class


mMouseDownLeft Field

MainWindow.mMouseDownLeft Field
[image]

If left mouse button is pressed.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mMouseDownLeft As Boolean
C#
private bool mMouseDownLeft;
C++
private:
bool mMouseDownLeft sealed ;
J#
private bool mMouseDownLeft
JScript
private mMouseDownLeft : bool;

See Also

MainWindow Class


mMouseDownMiddle Field

MainWindow.mMouseDownMiddle Field
[image]

If middle mouse button is pressed.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mMouseDownMiddle As Boolean
C#
private bool mMouseDownMiddle;
C++
private:
bool mMouseDownMiddle sealed ;
J#
private bool mMouseDownMiddle
JScript
private mMouseDownMiddle : bool;

See Also

MainWindow Class


mMouseDownRight Field

MainWindow.mMouseDownRight Field
[image]

If right mouse button is pressed.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mMouseDownRight As Boolean
C#
private bool mMouseDownRight;
C++
private:
bool mMouseDownRight sealed ;
J#
private bool mMouseDownRight
JScript
private mMouseDownRight : bool;

See Also

MainWindow Class


mOldMouse Field

MainWindow.mOldMouse Field
[image]

Last known mouse position.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mOldMouse As Point
C#
private Point mOldMouse;
C++
private:
Point mOldMouse sealed ;
J#
private Point mOldMouse
JScript
private mOldMouse : Point;

See Also

MainWindow Class


mRenderer Field

MainWindow.mRenderer Field
[image]

reference to the render class.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Shared mRenderer As Renderer
C#
public static Renderer mRenderer;
C++
public:
static Renderer mRenderer;
J#
public static Renderer mRenderer
JScript
public static mRenderer : Renderer;

See Also

MainWindow Class


mRot Field

MainWindow.mRot Field
[image]

last mouse position change when rotating the object.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mRot As Vector2
C#
private Vector2 mRot;
C++
private:
Vector2 mRot sealed ;
J#
private Vector2 mRot
JScript
private mRot : Vector2;

See Also

MainWindow Class


mRotLight Field

MainWindow.mRotLight Field
[image]

last mouse position change when rotating the light source.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mRotLight As Vector2
C#
private Vector2 mRotLight;
C++
private:
Vector2 mRotLight sealed ;
J#
private Vector2 mRotLight
JScript
private mRotLight : Vector2;

See Also

MainWindow Class


openToolStripMenuItem Field

MainWindow.openToolStripMenuItem Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private openToolStripMenuItem As ToolStripMenuItem
C#
private ToolStripMenuItem openToolStripMenuItem;
C++
private:
ToolStripMenuItem openToolStripMenuItem sealed ;
J#
private ToolStripMenuItem openToolStripMenuItem
JScript
private openToolStripMenuItem : ToolStripMenuItem;

See Also

MainWindow Class


opnFileDlg Field

MainWindow.opnFileDlg Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private opnFileDlg As OpenFileDialog
C#
private OpenFileDialog opnFileDlg;
C++
private:
OpenFileDialog opnFileDlg sealed ;
J#
private OpenFileDialog opnFileDlg
JScript
private opnFileDlg : OpenFileDialog;

See Also

MainWindow Class


rbMaxIntensity Field

MainWindow.rbMaxIntensity Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private rbMaxIntensity As RadioButton
C#
private RadioButton rbMaxIntensity;
C++
private:
RadioButton rbMaxIntensity sealed ;
J#
private RadioButton rbMaxIntensity
JScript
private rbMaxIntensity : RadioButton;

See Also

MainWindow Class


rbRaycasting Field

MainWindow.rbRaycasting Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private rbRaycasting As RadioButton
C#
private RadioButton rbRaycasting;
C++
private:
RadioButton rbRaycasting sealed ;
J#
private RadioButton rbRaycasting
JScript
private rbRaycasting : RadioButton;

See Also

MainWindow Class


rbSlicing Field

MainWindow.rbSlicing Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private rbSlicing As RadioButton
C#
private RadioButton rbSlicing;
C++
private:
RadioButton rbSlicing sealed ;
J#
private RadioButton rbSlicing
JScript
private rbSlicing : RadioButton;

See Also

MainWindow Class


rbXAxis Field

MainWindow.rbXAxis Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private rbXAxis As RadioButton
C#
private RadioButton rbXAxis;
C++
private:
RadioButton rbXAxis sealed ;
J#
private RadioButton rbXAxis
JScript
private rbXAxis : RadioButton;

See Also

MainWindow Class


rbYAxis Field

MainWindow.rbYAxis Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private rbYAxis As RadioButton
C#
private RadioButton rbYAxis;
C++
private:
RadioButton rbYAxis sealed ;
J#
private RadioButton rbYAxis
JScript
private rbYAxis : RadioButton;

See Also

MainWindow Class


rbZAxis Field

MainWindow.rbZAxis Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private rbZAxis As RadioButton
C#
private RadioButton rbZAxis;
C++
private:
RadioButton rbZAxis sealed ;
J#
private RadioButton rbZAxis
JScript
private rbZAxis : RadioButton;

See Also

MainWindow Class


rednerHighResToolStripMenuItem Field

MainWindow.rednerHighResToolStripMenuItem Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private rednerHighResToolStripMenuItem As ToolStripMenuItem
C#
private ToolStripMenuItem rednerHighResToolStripMenuItem;
C++
private:
ToolStripMenuItem rednerHighResToolStripMenuItem sealed ;
J#
private ToolStripMenuItem rednerHighResToolStripMenuItem
JScript
private rednerHighResToolStripMenuItem : ToolStripMenuItem;

See Also

MainWindow Class


tbCoeff Field

MainWindow.tbCoeff Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private tbCoeff As TrackBar
C#
private TrackBar tbCoeff;
C++
private:
TrackBar tbCoeff sealed ;
J#
private TrackBar tbCoeff
JScript
private tbCoeff : TrackBar;

See Also

MainWindow Class


tbGradDep Field

MainWindow.tbGradDep Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private tbGradDep As TrackBar
C#
private TrackBar tbGradDep;
C++
private:
TrackBar tbGradDep sealed ;
J#
private TrackBar tbGradDep
JScript
private tbGradDep : TrackBar;

See Also

MainWindow Class


tbkA Field

MainWindow.tbkA Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private tbkA As TrackBar
C#
private TrackBar tbkA;
C++
private:
TrackBar tbkA sealed ;
J#
private TrackBar tbkA
JScript
private tbkA : TrackBar;

See Also

MainWindow Class


tbkD Field

MainWindow.tbkD Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private tbkD As TrackBar
C#
private TrackBar tbkD;
C++
private:
TrackBar tbkD sealed ;
J#
private TrackBar tbkD
JScript
private tbkD : TrackBar;

See Also

MainWindow Class


tbkS Field

MainWindow.tbkS Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private tbkS As TrackBar
C#
private TrackBar tbkS;
C++
private:
TrackBar tbkS sealed ;
J#
private TrackBar tbkS
JScript
private tbkS : TrackBar;

See Also

MainWindow Class


tbSlicing Field

MainWindow.tbSlicing Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private tbSlicing As TrackBar
C#
private TrackBar tbSlicing;
C++
private:
TrackBar tbSlicing sealed ;
J#
private TrackBar tbSlicing
JScript
private tbSlicing : TrackBar;

See Also

MainWindow Class


tbStepSize Field

MainWindow.tbStepSize Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private tbStepSize As TrackBar
C#
private TrackBar tbStepSize;
C++
private:
TrackBar tbStepSize sealed ;
J#
private TrackBar tbStepSize
JScript
private tbStepSize : TrackBar;

See Also

MainWindow Class


uiHistogram1 Field

MainWindow.uiHistogram1 Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private uiHistogram1 As UIHistogram
C#
private UIHistogram uiHistogram1;
C++
private:
UIHistogram uiHistogram1 sealed ;
J#
private UIHistogram uiHistogram1
JScript
private uiHistogram1 : UIHistogram;

See Also

MainWindow Class


Methods

MainWindow Methods
[image]

Public Methods

 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form)
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form)
Public method | BeginInvoke | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control)
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control)
Public method | Close | Closes the form. (inherited from Form)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control)
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Overloaded. Releases the resources used by the form.
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (inherited from Control)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control)
Public method | Focus | Sets input focus to the control. (inherited from Control)
Public method | GetChildAtPoint | Overloaded. Retrieves the child control at a specified location. (inherited from Control)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Hide | Conceals the control from the user. (inherited from Control)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | Invalidate | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control. (inherited from Control)
Public method | Invoke | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle. (inherited from Control)
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl)
Public method | PerformLayout | Overloaded. Forces the control to apply layout logic to child controls. (inherited from Control)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control)
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form)
Public method | ResetBackColor | (inherited from Control)
Public method | ResetBindings | (inherited from Control)
Public method | ResetCursor | (inherited from Control)
Public method | ResetFont | (inherited from Control)
Public method | ResetForeColor | (inherited from Control)
Public method | ResetImeMode | (inherited from Control)
Public method | ResetRightToLeft | (inherited from Control)
Public method | ResetText | Resets the Text property to its default value. (inherited from Control)
Public method | ResumeLayout | Overloaded. Resumes the usual layout logic. (inherited from Control)
Public method | Scale | Overloaded. Scales the control and any child controls. (inherited from Control)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl)
Public method | Select | Overloaded. Activates the form and selects a child control. (inherited from Form)
Public method | SelectNextControl | Activates the next control. (inherited from Control)
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl)
Public method | SetBounds | Overloaded. Sets the bounds of the control. (inherited from Control)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form)
Public method | Show | Overloaded. Displays the form. (inherited from Form)
Public method | ShowDialog | Overloaded. Shows the form as a modal dialog box. (inherited from Form)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control)
Public method | ToString | (inherited from Form)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control)
Public method | Validate | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl)
Public method | ValidateChildren | Overloaded. Validates all selectable child controls in the form. (inherited from Form)
Top

Protected Methods

 | Name | Description
Family method | AccessibilityNotifyClients | Overloaded. Notifies the accessibility client applications of AccessibleEvents. (inherited from Control)
Family method | ActivateMdiChild | Activates the MDI child of a form. (inherited from Form)
Family method | AdjustFormScrollbars | (inherited from Form)
Family method | ApplyAutoScaling | Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (inherited from Form)
Family method | CenterToParent | Centers the position of the form within the bounds of the parent form. (inherited from Form)
Family method | CenterToScreen | Centers the form on the current screen. (inherited from Form)
Family method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (inherited from Control)
Family method | CreateControlsInstance | (inherited from Form)
Family method | CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (inherited from Form)
Family method | DefWndProc | (inherited from Form)
Family method | DestroyHandle | Destroys the handle associated with the control. (inherited from Control)
Family method | Dispose | Overloaded. Releases the resources used by the form.
Family method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (inherited from Component)
Family method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (inherited from Control)
Family method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (inherited from Control)
Family method | GetScaledBounds | (inherited from Form)
Family method | GetScrollState | Determines whether the specified flag has been set. (inherited from ScrollableControl)
Family method | GetService | Returns an object that represents a service provided by the Component or by its Container. (inherited from Component)
Family method | GetStyle | Retrieves the value of the specified control style bit for the control. (inherited from Control)
Family method | GetTopLevel | Determines if the control is a top-level control. (inherited from Control)
Family method | InitLayout | Called after the control has been added to another container. (inherited from Control)
Family method | InvokeGotFocus | Raises the GotFocus event for the specified control. (inherited from Control)
Family method | InvokeLostFocus | Raises the LostFocus event for the specified control. (inherited from Control)
Family method | InvokeOnClick | Raises the Click event for the specified control. (inherited from Control)
Family method | InvokePaint | Raises the Paint event for the specified control. (inherited from Control)
Family method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (inherited from Control)
Family method | IsInputChar | Determines if a character is an input character that the control recognizes. (inherited from Control)
Family method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (inherited from Control)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (inherited from Control)
Family method | OnActivated | Raises the Activated event. (inherited from Form)
Family method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (inherited from Control)
Family method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (inherited from ContainerControl)
Family method | OnBackColorChanged | Raises the BackColorChanged event. (inherited from Control)
Family method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (inherited from Form)
Family method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (inherited from Form)
Family method | OnBindingContextChanged | Raises the BindingContextChanged event. (inherited from Control)
Family method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (inherited from Control)
Family method | OnChangeUICues | Raises the ChangeUICues event. (inherited from Control)
Family method | OnClick | Raises the Click event. (inherited from Control)
Family method | OnClientSizeChanged | Raises the ClientSizeChanged event. (inherited from Control)
Family method | OnClosed | Raises the Closed event. (inherited from Form)
Family method | OnClosing | Raises the Closing event. (inherited from Form)
Family method | OnContextMenuChanged | Raises the ContextMenuChanged event. (inherited from Control)
Family method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (inherited from Control)
Family method | OnControlAdded | Raises the ControlAdded event. (inherited from Control)
Family method | OnControlRemoved | Raises the ControlRemoved event. (inherited from Control)
Family method | OnCreateControl | Raises the CreateControl event. (inherited from Form)
Family method | OnCursorChanged | Raises the CursorChanged event. (inherited from Control)
Family method | OnDeactivate | Raises the Deactivate event. (inherited from Form)
Family method | OnDockChanged | Raises the DockChanged event. (inherited from Control)
Family method | OnDoubleClick | Raises the DoubleClick event. (inherited from Control)
Family method | OnDragDrop | Raises the DragDrop event. (inherited from Control)
Family method | OnDragEnter | Raises the DragEnter event. (inherited from Control)
Family method | OnDragLeave | Raises the DragLeave event. (inherited from Control)
Family method | OnDragOver | Raises the DragOver event. (inherited from Control)
Family method | OnEnabledChanged | (inherited from Form)
Family method | OnEnter | Raises the Enter event. (inherited from Form)
Family method | OnFontChanged | (inherited from Form)
Family method | OnForeColorChanged | Raises the ForeColorChanged event. (inherited from Control)
Family method | OnFormClosed | Raises the FormClosed event. (inherited from Form)
Family method | OnFormClosing | Raises the FormClosing event. (inherited from Form)
Family method | OnGiveFeedback | Raises the GiveFeedback event. (inherited from Control)
Family method | OnGotFocus | Raises the GotFocus event. (inherited from Control)
Family method | OnHandleCreated | (inherited from Form)
Family method | OnHandleDestroyed | (inherited from Form)
Family method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (inherited from Form)
Family method | OnHelpRequested | Raises the HelpRequested event. (inherited from Control)
Family method | OnImeModeChanged | Raises the ImeModeChanged event. (inherited from Control)
Family method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (inherited from Form)
Family method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (inherited from Form)
Family method | OnInvalidated | Raises the Invalidated event. (inherited from Control)
Family method | OnKeyDown | Overridden. event handler
Family method | OnKeyPress | Raises the KeyPress event. (inherited from Control)
Family method | OnKeyUp | Raises the KeyUp event. (inherited from Control)
Family method | OnLayout | (inherited from Form)
Family method | OnLeave | Raises the Leave event. (inherited from Control)
Family method | OnLoad | Raises the Load event. (inherited from Form)
Family method | OnLocationChanged | Raises the LocationChanged event. (inherited from Control)
Family method | OnLostFocus | Raises the LostFocus event. (inherited from Control)
Family method | OnMarginChanged | Raises the MarginChanged event. (inherited from Control)
Family method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (inherited from Form)
Family method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (inherited from Form)
Family method | OnMdiChildActivate | Raises the MdiChildActivate event. (inherited from Form)
Family method | OnMenuComplete | Raises the MenuComplete event. (inherited from Form)
Family method | OnMenuStart | Raises the MenuStart event. (inherited from Form)
Family method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (inherited from Form)
Family method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (inherited from Control)
Family method | OnMouseClick | Raises the MouseClick event. (inherited from Control)
Family method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (inherited from Control)
Family method | OnMouseDown | Raises the MouseDown event. (inherited from Control)
Family method | OnMouseEnter | Raises the MouseEnter event. (inherited from Control)
Family method | OnMouseHover | Raises the MouseHover event. (inherited from Control)
Family method | OnMouseLeave | Raises the MouseLeave event. (inherited from Control)
Family method | OnMouseMove | Raises the MouseMove event. (inherited from Control)
Family method | OnMouseUp | Raises the MouseUp event. (inherited from Control)
Family method | OnMouseWheel | Raises the MouseWheel event. (inherited from ScrollableControl)
Family method | OnMove | Raises the Move event. (inherited from Control)
Family method | OnNotifyMessage | Notifies the control of Windows messages. (inherited from Control)
Family method | OnPaddingChanged | (inherited from ScrollableControl)
Family method | OnPaint | (inherited from Form)
Family method | OnPaintBackground | (inherited from ScrollableControl)
Family method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (inherited from Control)
Family method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (inherited from Control)
Family method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (inherited from Control)
Family method | OnParentChanged | (inherited from ContainerControl)
Family method | OnParentCursorChanged | Raises the CursorChanged event. (inherited from Control)
Family method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (inherited from Control)
Family method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (inherited from Control)
Family method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (inherited from Control)
Family method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (inherited from Control)
Family method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (inherited from Control)
Family method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (inherited from Control)
Family method | OnPrint | Raises the Paint event. (inherited from Control)
Family method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (inherited from Control)
Family method | OnRegionChanged | Raises the RegionChanged event. (inherited from Control)
Family method | OnResize | (inherited from Form)
Family method | OnResizeBegin | Raises the ResizeBegin event. (inherited from Form)
Family method | OnResizeEnd | Raises the ResizeEnd event. (inherited from Form)
Family method | OnRightToLeftChanged | (inherited from ScrollableControl)
Family method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (inherited from Form)
Family method | OnScroll | Raises the Scroll event. (inherited from ScrollableControl)
Family method | OnShown | Raises the Shown event. (inherited from Form)
Family method | OnSizeChanged | Raises the SizeChanged event. (inherited from Control)
Family method | OnStyleChanged | (inherited from Form)
Family method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (inherited from Control)
Family method | OnTabIndexChanged | Raises the TabIndexChanged event. (inherited from Control)
Family method | OnTabStopChanged | Raises the TabStopChanged event. (inherited from Control)
Family method | OnTextChanged | (inherited from Form)
Family method | OnValidated | Raises the Validated event. (inherited from Control)
Family method | OnValidating | Raises the Validating event. (inherited from Control)
Family method | OnVisibleChanged | Raises the VisibleChanged event. (inherited from Form)
Family method | ProcessCmdKey | Processes a command key. (inherited from Form)
Family method | ProcessDialogChar | (inherited from Form)
Family method | ProcessDialogKey | Processes a dialog key. (inherited from Form)
Family method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (inherited from Control)
Family method | ProcessKeyMessage | Processes a keyboard message. (inherited from Control)
Family method | ProcessKeyPreview | (inherited from Form)
Family method | ProcessMnemonic | (inherited from Form)
Family method | ProcessTabKey | (inherited from Form)
Family method | RaiseDragEvent | Raises the appropriate drag event. (inherited from Control)
Family method | RaiseKeyEvent | Raises the appropriate key event. (inherited from Control)
Family method | RaiseMouseEvent | Raises the appropriate mouse event. (inherited from Control)
Family method | RaisePaintEvent | Raises the appropriate paint event. (inherited from Control)
Family method | RecreateHandle | Forces the re-creation of the handle for the control. (inherited from Control)
Family method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (inherited from Control)
Family method | RtlTranslateAlignment | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text. (inherited from Control)
Family method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (inherited from Control)
Family method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (inherited from Control)
Family method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (inherited from Control)
Family method | ScaleControl | (inherited from Form)
Family method | ScaleCore | Base function that performs scaling of the form. (inherited from Form)
Family method | ScrollToControl | Calculates the scroll offset to the specified child control. (inherited from ScrollableControl)
Family method | Select | Overloaded. Activates the form and selects a child control. (inherited from Form)
Family method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (inherited from Control)
Family method | SetBoundsCore | (inherited from Form)
Family method | SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (inherited from Form)
Family method | SetDisplayRectLocation | Positions the display window to the specified value. (inherited from ScrollableControl)
Family method | SetScrollState | Sets the specified scroll state flag. (inherited from ScrollableControl)
Family method | SetStyle | Sets the specified style bit to the specified value. (inherited from Control)
Family method | SetTopLevel | Sets the control as the top-level control. (inherited from Control)
Family method | SetVisibleCore | (inherited from Form)
Family method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (inherited from Control)
Family method | UpdateBounds | Overloaded. Updates the bounds of the control. (inherited from Control)
Family method | UpdateDefaultButton | Updates which button is the default button. (inherited from Form)
Family method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (inherited from Control)
Family method | UpdateZOrder | Updates the control in its parent's z-order. (inherited from Control)
Family method | WndProc | (inherited from Form)
Top

Private Methods

 | Name | Description
Private method | D3DOnMouseDown | event handler
Private method | D3DOnMouseMove | event handler
Private method | D3DOnMouseUp | event handler
Private method | HistoChanged | event handler: if the histogram was changed, update the transfer texture.
Private method | InitializeComponent | Erforderliche Methode für die Designerunterstützung. Der Inhalt der Methode darf nicht mit dem Code-Editor geändert werden.
Private method | openToolStripMenuItem_Click | event handler: Opens a file dialog to select a data set.
Private method | opnFileDlg_FileOk | event handler: if valid file selected, load the data.
Private method | rbMaxIntensity_CheckedChanged | event handler
Private method | rbRaycasting_CheckedChanged | event handler: Saves a high-res image.
Private method | rbSlicing_CheckedChanged | event handler
Private method | rbXAxis_CheckedChanged | event handler
Private method | rbYAxis_CheckedChanged | event handler
Private method | rbZAxis_CheckedChanged | event handler
Private method | rbZAxis_CheckedChanged_1 | event handler
Private method | rednerHighResToolStripMenuItem_Click | event handler: select file to save a high-res image.
Private method | saveImage_FileOk | event handler: Saves a high-res image if path correct.
Private method | tbCoeff_Scroll | event handler
Private method | tbGradDep_Scroll | event handler
Private method | tbkA_Scroll | event handler
Private method | tbkD_Scroll | event handler
Private method | tbkS_Scroll | event handler
Private method | tbSlicing_Scroll | event handler
Private method | tbStepSize_Scroll | event handler
Top

Explicit Interface Implementations

Name | Description
System#Windows#Forms#IContainerControl#ActivateControl | Activates a specified control. (inherited from ContainerControl)
System#Windows#Forms#IDropTarget#OnDragDrop | Raises the DragDrop event. (inherited from Control)
System#Windows#Forms#IDropTarget#OnDragEnter | Raises the DragEnter event. (inherited from Control)
System#Windows#Forms#IDropTarget#OnDragLeave | Raises the DragLeave event. (inherited from Control)
System#Windows#Forms#IDropTarget#OnDragOver | Raises the DragOver event. (inherited from Control)
System#Windows#Forms#ISupportOleDropSource#OnGiveFeedback | (inherited from Control)
System#Windows#Forms#ISupportOleDropSource#OnQueryContinueDrag | (inherited from Control)
System#Windows#Forms#Layout#IArrangedElement#PerformLayout | (inherited from Control)
System#Windows#Forms#Layout#IArrangedElement#SetBounds | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleControl#FreezeEvents | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleControl#GetControlInfo | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleControl#OnAmbientPropertyChange | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleControl#OnMnemonic | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#ContextSensitiveHelp | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#EnableModeless | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#GetWindow | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#OnDocWindowActivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#OnFrameWindowActivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#ResizeBorder | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#TranslateAccelerator | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#ContextSensitiveHelp | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#GetWindow | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#InPlaceDeactivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#ReactivateAndUndo | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#SetObjectRects | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#UIDeactivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#Advise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#Close | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#DoVerb | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#EnumAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#EnumVerbs | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetClientSite | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetClipboardData | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetMiscStatus | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetMoniker | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetUserClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetUserType | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#InitFromData | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#IsUpToDate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#OleUpdate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetClientSite | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetColorScheme | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetHostNames | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetMoniker | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#Unadvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleWindow#ContextSensitiveHelp | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleWindow#GetWindow | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersist#GetClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistPropertyBag#GetClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistPropertyBag#InitNew | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistPropertyBag#Load | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistPropertyBag#Save | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#GetClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#HandsOffStorage | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#InitNew | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#IsDirty | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#Load | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#Save | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#SaveCompleted | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#GetClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#GetSizeMax | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#InitNew | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#IsDirty | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#Load | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#Save | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IQuickActivate#GetContentExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IQuickActivate#QuickActivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IQuickActivate#SetContentExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#Draw | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#Freeze | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#GetAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#GetColorSet | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#SetAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#Unfreeze | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#Draw | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#Freeze | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#GetAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#GetColorSet | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#GetExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#SetAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#Unfreeze | (inherited from Control)
Top

See Also

MainWindow Class


D3DOnMouseDown Method

MainWindow.D3DOnMouseDown Method
[image]

event handler

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private Sub D3DOnMouseDown( _
ByVal sender As Object, _
ByVal e As MouseEventArgs _
)
C#
private void D3DOnMouseDown(
object sender,
MouseEventArgs e
)
C++
private:
void D3DOnMouseDown(
Object sender,
MouseEventArgs e
) sealed
J#
private void D3DOnMouseDown(
object sender,
MouseEventArgs e
)
JScript
private function D3DOnMouseDown(
sender : Object,
e : MouseEventArgs
)

See Also

MainWindow Class


D3DOnMouseMove Method

MainWindow.D3DOnMouseMove Method
[image]

event handler

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private Sub D3DOnMouseMove( _
ByVal sender As Object, _
ByVal e As MouseEventArgs _
)
C#
private void D3DOnMouseMove(
object sender,
MouseEventArgs e
)
C++
private:
void D3DOnMouseMove(
Object sender,
MouseEventArgs e
) sealed
J#
private void D3DOnMouseMove(
object sender,
MouseEventArgs e
)
JScript
private function D3DOnMouseMove(
sender : Object,
e : MouseEventArgs
)

See Also

MainWindow Class


D3DOnMouseUp Method

MainWindow.D3DOnMouseUp Method
[image]

event handler

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private Sub D3DOnMouseUp( _
ByVal sender As Object, _
ByVal e As MouseEventArgs _
)
C#
private void D3DOnMouseUp(
object sender,
MouseEventArgs e
)
C++
private:
void D3DOnMouseUp(
Object sender,
MouseEventArgs e
) sealed
J#
private void D3DOnMouseUp(
object sender,
MouseEventArgs e
)
JScript
private function D3DOnMouseUp(
sender : Object,
e : MouseEventArgs
)

See Also

MainWindow Class


Dispose Method

MainWindow.Dispose Method

Releases the resources used by the form.

Overload List

 | Name | Description
Family method | Dispose (Boolean) | Overridden. Verwendete Ressourcen bereinigen.
Public method | Dispose | Releases all resources used by the Component. (inherited from Component)

See Also

MainWindow Class


Dispose Method (Boolean)

MainWindow.Dispose Method (Boolean)
See Also Example
[image]

Verwendete Ressourcen bereinigen.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

Parameters

disposing
True, wenn verwaltete Ressourcen gelöscht werden sollen; andernfalls False.

See Also

MainWindow Class
Bsp1 Namespace
MainWindow.Dispose Overload List


HistoChanged Method

MainWindow.HistoChanged Method
[image]

event handler: if the histogram was changed, update the transfer texture.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private Sub HistoChanged( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
C#
private void HistoChanged(
object sender,
EventArgs e
)
C++
private:
void HistoChanged(
Object sender,
EventArgs e
) sealed
J#
private void HistoChanged(
object sender,
EventArgs e
)
JScript
private function HistoChanged(
sender : Object,
e : EventArgs
)

See Also

MainWindow Class


InitializeComponent Method

MainWindow.InitializeComponent Method
[image]

Erforderliche Methode für die Designerunterstützung. Der Inhalt der Methode darf nicht mit dem Code-Editor geändert werden.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private Sub InitializeComponent()
C#
private void InitializeComponent()
C++
private:
void InitializeComponent() sealed
J#
private void InitializeComponent()
JScript
private function InitializeComponent()

See Also

MainWindow Class


OnKeyDown Method

MainWindow.OnKeyDown Method
[image]

event handler

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnKeyDown( _
ByVal e As KeyEventArgs _
)
C#
protected override void OnKeyDown(
KeyEventArgs e
)
C++
protected:
virtual void OnKeyDown(
KeyEventArgs e
) override
J#
protected override void OnKeyDown(
KeyEventArgs e
)
JScript
protected override function OnKeyDown(
e : KeyEventArgs
)

See Also

MainWindow Class


openToolStripMenuItem_Click Method

MainWindow.openToolStripMenuItem_Click Method
[image]

event handler: Opens a file dialog to select a data set.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private Sub openToolStripMenuItem_Click( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
C#
private void openToolStripMenuItem_Click(
object sender,
EventArgs e
)
C++
private:
void openToolStripMenuItem_Click(
Object sender,
EventArgs e
) sealed
J#
private void openToolStripMenuItem_Click(
object sender,
EventArgs e
)
JScript
private function openToolStripMenuItem_Click(
sender : Object,
e : EventArgs
)

See Also

MainWindow Class


opnFileDlg_FileOk Method

MainWindow.opnFileDlg_FileOk Method
[image]

event handler: if valid file selected, load the data.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private Sub opnFileDlg_FileOk( _
ByVal sender As Object, _
ByVal e As CancelEventArgs _
)
C#
private void opnFileDlg_FileOk(
object sender,
CancelEventArgs e
)
C++
private:
void opnFileDlg_FileOk(
Object sender,
CancelEventArgs e
) sealed
J#
private void opnFileDlg_FileOk(
object sender,
CancelEventArgs e
)
JScript
private function opnFileDlg_FileOk(
sender : Object,
e : CancelEventArgs
)

See Also

MainWindow Class


rbMaxIntensity_CheckedChanged Method

MainWindow.rbMaxIntensity_CheckedChanged Method
[image]

event handler

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private Sub rbMaxIntensity_CheckedChanged( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
C#
private void rbMaxIntensity_CheckedChanged(
object sender,
EventArgs e
)
C++
private:
void rbMaxIntensity_CheckedChanged(
Object sender,
EventArgs e
) sealed
J#
private void rbMaxIntensity_CheckedChanged(
object sender,
EventArgs e
)
JScript
private function rbMaxIntensity_CheckedChanged(
sender : Object,
e : EventArgs
)

See Also

MainWindow Class


rbRaycasting_CheckedChanged Method

MainWindow.rbRaycasting_CheckedChanged Method
[image]

event handler: Saves a high-res image.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private Sub rbRaycasting_CheckedChanged( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
C#
private void rbRaycasting_CheckedChanged(
object sender,
EventArgs e
)
C++
private:
void rbRaycasting_CheckedChanged(
Object sender,
EventArgs e
) sealed
J#
private void rbRaycasting_CheckedChanged(
object sender,
EventArgs e
)
JScript
private function rbRaycasting_CheckedChanged(
sender : Object,
e : EventArgs
)

See Also

MainWindow Class


rbSlicing_CheckedChanged Method

MainWindow.rbSlicing_CheckedChanged Method
[image]

event handler

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private Sub rbSlicing_CheckedChanged( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
C#
private void rbSlicing_CheckedChanged(
object sender,
EventArgs e
)
C++
private:
void rbSlicing_CheckedChanged(
Object sender,
EventArgs e
) sealed
J#
private void rbSlicing_CheckedChanged(
object sender,
EventArgs e
)
JScript
private function rbSlicing_CheckedChanged(
sender : Object,
e : EventArgs
)

See Also

MainWindow Class


rbXAxis_CheckedChanged Method

MainWindow.rbXAxis_CheckedChanged Method
[image]

event handler

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private Sub rbXAxis_CheckedChanged( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
C#
private void rbXAxis_CheckedChanged(
object sender,
EventArgs e
)
C++
private:
void rbXAxis_CheckedChanged(
Object sender,
EventArgs e
) sealed
J#
private void rbXAxis_CheckedChanged(
object sender,
EventArgs e
)
JScript
private function rbXAxis_CheckedChanged(
sender : Object,
e : EventArgs
)

See Also

MainWindow Class


rbYAxis_CheckedChanged Method

MainWindow.rbYAxis_CheckedChanged Method
[image]

event handler

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private Sub rbYAxis_CheckedChanged( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
C#
private void rbYAxis_CheckedChanged(
object sender,
EventArgs e
)
C++
private:
void rbYAxis_CheckedChanged(
Object sender,
EventArgs e
) sealed
J#
private void rbYAxis_CheckedChanged(
object sender,
EventArgs e
)
JScript
private function rbYAxis_CheckedChanged(
sender : Object,
e : EventArgs
)

See Also

MainWindow Class


rbZAxis_CheckedChanged Method

MainWindow.rbZAxis_CheckedChanged Method
[image]

event handler

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private Sub rbZAxis_CheckedChanged( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
C#
private void rbZAxis_CheckedChanged(
object sender,
EventArgs e
)
C++
private:
void rbZAxis_CheckedChanged(
Object sender,
EventArgs e
) sealed
J#
private void rbZAxis_CheckedChanged(
object sender,
EventArgs e
)
JScript
private function rbZAxis_CheckedChanged(
sender : Object,
e : EventArgs
)

See Also

MainWindow Class


rbZAxis_CheckedChanged_1 Method

MainWindow.rbZAxis_CheckedChanged_1 Method
[image]

event handler

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private Sub rbZAxis_CheckedChanged_1( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
C#
private void rbZAxis_CheckedChanged_1(
object sender,
EventArgs e
)
C++
private:
void rbZAxis_CheckedChanged_1(
Object sender,
EventArgs e
) sealed
J#
private void rbZAxis_CheckedChanged_1(
object sender,
EventArgs e
)
JScript
private function rbZAxis_CheckedChanged_1(
sender : Object,
e : EventArgs
)

See Also

MainWindow Class


rednerHighResToolStripMenuItem_Click Method

MainWindow.rednerHighResToolStripMenuItem_Click Method
[image]

event handler: select file to save a high-res image.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private Sub rednerHighResToolStripMenuItem_Click( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
C#
private void rednerHighResToolStripMenuItem_Click(
object sender,
EventArgs e
)
C++
private:
void rednerHighResToolStripMenuItem_Click(
Object sender,
EventArgs e
) sealed
J#
private void rednerHighResToolStripMenuItem_Click(
object sender,
EventArgs e
)
JScript
private function rednerHighResToolStripMenuItem_Click(
sender : Object,
e : EventArgs
)

See Also

MainWindow Class


saveImage_FileOk Method

MainWindow.saveImage_FileOk Method
[image]

event handler: Saves a high-res image if path correct.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private Sub saveImage_FileOk( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
C#
private void saveImage_FileOk(
object sender,
EventArgs e
)
C++
private:
void saveImage_FileOk(
Object sender,
EventArgs e
) sealed
J#
private void saveImage_FileOk(
object sender,
EventArgs e
)
JScript
private function saveImage_FileOk(
sender : Object,
e : EventArgs
)

See Also

MainWindow Class


tbCoeff_Scroll Method

MainWindow.tbCoeff_Scroll Method
[image]

event handler

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private Sub tbCoeff_Scroll( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
C#
private void tbCoeff_Scroll(
object sender,
EventArgs e
)
C++
private:
void tbCoeff_Scroll(
Object sender,
EventArgs e
) sealed
J#
private void tbCoeff_Scroll(
object sender,
EventArgs e
)
JScript
private function tbCoeff_Scroll(
sender : Object,
e : EventArgs
)

See Also

MainWindow Class


tbGradDep_Scroll Method

MainWindow.tbGradDep_Scroll Method
[image]

event handler

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private Sub tbGradDep_Scroll( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
C#
private void tbGradDep_Scroll(
object sender,
EventArgs e
)
C++
private:
void tbGradDep_Scroll(
Object sender,
EventArgs e
) sealed
J#
private void tbGradDep_Scroll(
object sender,
EventArgs e
)
JScript
private function tbGradDep_Scroll(
sender : Object,
e : EventArgs
)

See Also

MainWindow Class


tbkA_Scroll Method

MainWindow.tbkA_Scroll Method
[image]

event handler

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private Sub tbkA_Scroll( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
C#
private void tbkA_Scroll(
object sender,
EventArgs e
)
C++
private:
void tbkA_Scroll(
Object sender,
EventArgs e
) sealed
J#
private void tbkA_Scroll(
object sender,
EventArgs e
)
JScript
private function tbkA_Scroll(
sender : Object,
e : EventArgs
)

See Also

MainWindow Class


tbkD_Scroll Method

MainWindow.tbkD_Scroll Method
[image]

event handler

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private Sub tbkD_Scroll( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
C#
private void tbkD_Scroll(
object sender,
EventArgs e
)
C++
private:
void tbkD_Scroll(
Object sender,
EventArgs e
) sealed
J#
private void tbkD_Scroll(
object sender,
EventArgs e
)
JScript
private function tbkD_Scroll(
sender : Object,
e : EventArgs
)

See Also

MainWindow Class


tbkS_Scroll Method

MainWindow.tbkS_Scroll Method
[image]

event handler

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private Sub tbkS_Scroll( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
C#
private void tbkS_Scroll(
object sender,
EventArgs e
)
C++
private:
void tbkS_Scroll(
Object sender,
EventArgs e
) sealed
J#
private void tbkS_Scroll(
object sender,
EventArgs e
)
JScript
private function tbkS_Scroll(
sender : Object,
e : EventArgs
)

See Also

MainWindow Class


tbSlicing_Scroll Method

MainWindow.tbSlicing_Scroll Method
[image]

event handler

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private Sub tbSlicing_Scroll( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
C#
private void tbSlicing_Scroll(
object sender,
EventArgs e
)
C++
private:
void tbSlicing_Scroll(
Object sender,
EventArgs e
) sealed
J#
private void tbSlicing_Scroll(
object sender,
EventArgs e
)
JScript
private function tbSlicing_Scroll(
sender : Object,
e : EventArgs
)

See Also

MainWindow Class


tbStepSize_Scroll Method

MainWindow.tbStepSize_Scroll Method
[image]

event handler

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private Sub tbStepSize_Scroll( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
C#
private void tbStepSize_Scroll(
object sender,
EventArgs e
)
C++
private:
void tbStepSize_Scroll(
Object sender,
EventArgs e
) sealed
J#
private void tbStepSize_Scroll(
object sender,
EventArgs e
)
JScript
private function tbStepSize_Scroll(
sender : Object,
e : EventArgs
)

See Also

MainWindow Class


PixelData Structure

PixelData Structure
See Also Example Members
[image]

This structure represents a Pixel Color

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Structure PixelData
C#
public struct PixelData
C++
value class PixelData
J#
public final class PixelData extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Remarks

This structure represents a Pixel Color

Inheritance Hierarchy

System.Object
Bsp1.PixelData

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PixelData Members


PixelData Members

PixelData Members
See Also Example Constructors Fields Methods
[image]

This structure represents a Pixel Color

The following tables list the members exposed by PixelData.

Public Constructors

 | Name | Description
Public method | PixelData | default constructor
Top

Public Fields

 | Name | Description
Public field | blue | Blue
Public field | green | Green
Public field | red | Red
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

See Also

PixelData Structure


PixelData Constructor

PixelData Constructor
[image]

default constructor

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal r As Byte, _
ByVal g As Byte, _
ByVal b As Byte _
)
C#
public PixelData(
byte r,
byte g,
byte b
)
C++
public:
PixelData(
char r,
char g,
char b
) sealed
J#
public PixelData(
byte r,
byte g,
byte b
)
JScript
public function PixelData(
r : Byte,
g : Byte,
b : Byte
)

See Also

PixelData Structure


Fields

PixelData Fields
[image]

Public Fields

 | Name | Description
Public field | blue | Blue
Public field | green | Green
Public field | red | Red
Top

See Also

PixelData Structure


blue Field

PixelData.blue Field
[image]

Blue

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public blue As Byte
C#
public byte blue;
C++
public:
char blue sealed ;
J#
public byte blue
JScript
public blue : Byte;

See Also

PixelData Structure


green Field

PixelData.green Field
[image]

Green

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public green As Byte
C#
public byte green;
C++
public:
char green sealed ;
J#
public byte green
JScript
public green : Byte;

See Also

PixelData Structure


red Field

PixelData.red Field
[image]

Red

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public red As Byte
C#
public byte red;
C++
public:
char red sealed ;
J#
public byte red
JScript
public red : Byte;

See Also

PixelData Structure


Progress Class

Progress Class
See Also Example Members
[image]

This class represents a progress bar

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Class Progress
Inherits Form
C#
public class Progress : Form
C++
ref class Progress : Form
J#
public class Progress extends Form
JScript
public class Progress extends Form

Remarks

This class represents a progress bar

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Bsp1.Progress

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Progress Members


Progress Members

Progress Members
See Also Example Constructors Fields Properties Methods Events Explicit Inteface Implementations
[image]

This class represents a progress bar

The following tables list the members exposed by Progress.

Public Constructors

 | Name | Description
Public method | Progress | default constructor
Top

Private Fields

 | Name | Description
Private field | components | Erforderliche Designervariable.
Private field | pbDisplay |
Top

Public Properties

 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control)
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control)
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl)
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control)
Public property | AutoScale | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView. (inherited from Control)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl)
Public property | AutoSize | (inherited from Form)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form)
Public property | AutoValidate | (inherited from Form)
Public property | BackColor | (inherited from Form)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control)
Public property | BindingContext | (inherited from ContainerControl)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control)
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control)
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form)
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control)
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control)
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form)
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control)
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control)
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control)
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control)
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form)
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control)
Public property | Height | Gets or sets the height of the control. (inherited from Control)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl)
Public property | Icon | Gets or sets the icon for the form. (inherited from Form)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control)
Public property | Location | (inherited from Form)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form)
Public property | Margin | (inherited from Form)
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form)
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form)
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form)
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form)
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form)
Public property | Name | Gets or sets the name of the control. (inherited from Control)
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form)
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form)
Public property | Padding | Gets or sets padding within the control. (inherited from Control)
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control)
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control)
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control)
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control)
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form)
Public property | Site | Gets or sets the site of the control. (inherited from Control)
Public property | Size | Gets or sets the size of the form. (inherited from Form)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form)
Public property | TabStop | (inherited from Form)
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control)
Public property | Text | (inherited from Form)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl)
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control)
Public property | Width | Gets or sets the width of the control. (inherited from Control)
Public property | WindowState | Gets or sets the form's window state. (inherited from Form)
Public property | WindowTarget | (inherited from Control)
Top

Protected Properties

 | Name | Description
Family property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (inherited from ContainerControl)
Family property | CanRaiseEvents | Determines if events can be raised on the control. (inherited from Control)
Family property | CreateParams | (inherited from Form)
Family property | DefaultCursor | Gets or sets the default cursor for the control. (inherited from Control)
Family property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (inherited from Form)
Family property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (inherited from Control)
Family property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (inherited from Control)
Family property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (inherited from Control)
Family property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (inherited from Control)
Family property | DefaultSize | (inherited from Form)
Family property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (inherited from Component)
Family property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (inherited from Control)
Family property | Events | Gets the list of event handlers that are attached to this Component. (inherited from Component)
Family property | FontHeight | Gets or sets the height of the font of the control. (inherited from Control)
Family property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (inherited from ScrollableControl)
Family property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (inherited from Form)
Family property | RenderRightToLeft | (inherited from Control)
Family property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (inherited from Control)
Family property | ScaleChildren | Gets a value that determines the scaling of child controls. (inherited from Control)
Family property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (inherited from Control)
Family property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (inherited from Control)
Family property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (inherited from Form)
Family property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (inherited from ScrollableControl)
Top

Public Methods

 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form)
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form)
Public method | BeginInvoke | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control)
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control)
Public method | Close | Closes the form. (inherited from Form)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control)
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Overloaded. Releases the resources used by the form.
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (inherited from Control)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control)
Public method | Focus | Sets input focus to the control. (inherited from Control)
Public method | GetChildAtPoint | Overloaded. Retrieves the child control at a specified location. (inherited from Control)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Hide | Conceals the control from the user. (inherited from Control)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | Invalidate | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control. (inherited from Control)
Public method | Invoke | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle. (inherited from Control)
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl)
Public method | PerformLayout | Overloaded. Forces the control to apply layout logic to child controls. (inherited from Control)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control)
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form)
Public method | ResetBackColor | (inherited from Control)
Public method | ResetBindings | (inherited from Control)
Public method | ResetCursor | (inherited from Control)
Public method | ResetFont | (inherited from Control)
Public method | ResetForeColor | (inherited from Control)
Public method | ResetImeMode | (inherited from Control)
Public method | ResetRightToLeft | (inherited from Control)
Public method | ResetText | Resets the Text property to its default value. (inherited from Control)
Public method | ResumeLayout | Overloaded. Resumes the usual layout logic. (inherited from Control)
Public method | Scale | Overloaded. Scales the control and any child controls. (inherited from Control)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl)
Public method | Select | Overloaded. Activates the form and selects a child control. (inherited from Form)
Public method | SelectNextControl | Activates the next control. (inherited from Control)
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl)
Public method | SetBounds | Overloaded. Sets the bounds of the control. (inherited from Control)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form)
Public method | setValue | sets the progress value
Public method | Show | Overloaded. Displays the form. (inherited from Form)
Public method | ShowDialog | Overloaded. Shows the form as a modal dialog box. (inherited from Form)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control)
Public method | ToString | (inherited from Form)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control)
Public method | Validate | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl)
Public method | ValidateChildren | Overloaded. Validates all selectable child controls in the form. (inherited from Form)
Top

Protected Methods

 | Name | Description
Family method | AccessibilityNotifyClients | Overloaded. Notifies the accessibility client applications of AccessibleEvents. (inherited from Control)
Family method | ActivateMdiChild | Activates the MDI child of a form. (inherited from Form)
Family method | AdjustFormScrollbars | (inherited from Form)
Family method | ApplyAutoScaling | Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (inherited from Form)
Family method | CenterToParent | Centers the position of the form within the bounds of the parent form. (inherited from Form)
Family method | CenterToScreen | Centers the form on the current screen. (inherited from Form)
Family method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (inherited from Control)
Family method | CreateControlsInstance | (inherited from Form)
Family method | CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (inherited from Form)
Family method | DefWndProc | (inherited from Form)
Family method | DestroyHandle | Destroys the handle associated with the control. (inherited from Control)
Family method | Dispose | Overloaded. Releases the resources used by the form.
Family method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (inherited from Component)
Family method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (inherited from Control)
Family method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (inherited from Control)
Family method | GetScaledBounds | (inherited from Form)
Family method | GetScrollState | Determines whether the specified flag has been set. (inherited from ScrollableControl)
Family method | GetService | Returns an object that represents a service provided by the Component or by its Container. (inherited from Component)
Family method | GetStyle | Retrieves the value of the specified control style bit for the control. (inherited from Control)
Family method | GetTopLevel | Determines if the control is a top-level control. (inherited from Control)
Family method | InitLayout | Called after the control has been added to another container. (inherited from Control)
Family method | InvokeGotFocus | Raises the GotFocus event for the specified control. (inherited from Control)
Family method | InvokeLostFocus | Raises the LostFocus event for the specified control. (inherited from Control)
Family method | InvokeOnClick | Raises the Click event for the specified control. (inherited from Control)
Family method | InvokePaint | Raises the Paint event for the specified control. (inherited from Control)
Family method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (inherited from Control)
Family method | IsInputChar | Determines if a character is an input character that the control recognizes. (inherited from Control)
Family method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (inherited from Control)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (inherited from Control)
Family method | OnActivated | Raises the Activated event. (inherited from Form)
Family method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (inherited from Control)
Family method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (inherited from ContainerControl)
Family method | OnBackColorChanged | Raises the BackColorChanged event. (inherited from Control)
Family method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (inherited from Form)
Family method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (inherited from Form)
Family method | OnBindingContextChanged | Raises the BindingContextChanged event. (inherited from Control)
Family method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (inherited from Control)
Family method | OnChangeUICues | Raises the ChangeUICues event. (inherited from Control)
Family method | OnClick | Raises the Click event. (inherited from Control)
Family method | OnClientSizeChanged | Raises the ClientSizeChanged event. (inherited from Control)
Family method | OnClosed | Raises the Closed event. (inherited from Form)
Family method | OnClosing | Raises the Closing event. (inherited from Form)
Family method | OnContextMenuChanged | Raises the ContextMenuChanged event. (inherited from Control)
Family method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (inherited from Control)
Family method | OnControlAdded | Raises the ControlAdded event. (inherited from Control)
Family method | OnControlRemoved | Raises the ControlRemoved event. (inherited from Control)
Family method | OnCreateControl | Raises the CreateControl event. (inherited from Form)
Family method | OnCursorChanged | Raises the CursorChanged event. (inherited from Control)
Family method | OnDeactivate | Raises the Deactivate event. (inherited from Form)
Family method | OnDockChanged | Raises the DockChanged event. (inherited from Control)
Family method | OnDoubleClick | Raises the DoubleClick event. (inherited from Control)
Family method | OnDragDrop | Raises the DragDrop event. (inherited from Control)
Family method | OnDragEnter | Raises the DragEnter event. (inherited from Control)
Family method | OnDragLeave | Raises the DragLeave event. (inherited from Control)
Family method | OnDragOver | Raises the DragOver event. (inherited from Control)
Family method | OnEnabledChanged | (inherited from Form)
Family method | OnEnter | Raises the Enter event. (inherited from Form)
Family method | OnFontChanged | (inherited from Form)
Family method | OnForeColorChanged | Raises the ForeColorChanged event. (inherited from Control)
Family method | OnFormClosed | Raises the FormClosed event. (inherited from Form)
Family method | OnFormClosing | Raises the FormClosing event. (inherited from Form)
Family method | OnGiveFeedback | Raises the GiveFeedback event. (inherited from Control)
Family method | OnGotFocus | Raises the GotFocus event. (inherited from Control)
Family method | OnHandleCreated | (inherited from Form)
Family method | OnHandleDestroyed | (inherited from Form)
Family method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (inherited from Form)
Family method | OnHelpRequested | Raises the HelpRequested event. (inherited from Control)
Family method | OnImeModeChanged | Raises the ImeModeChanged event. (inherited from Control)
Family method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (inherited from Form)
Family method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (inherited from Form)
Family method | OnInvalidated | Raises the Invalidated event. (inherited from Control)
Family method | OnKeyDown | Raises the KeyDown event. (inherited from Control)
Family method | OnKeyPress | Raises the KeyPress event. (inherited from Control)
Family method | OnKeyUp | Raises the KeyUp event. (inherited from Control)
Family method | OnLayout | (inherited from Form)
Family method | OnLeave | Raises the Leave event. (inherited from Control)
Family method | OnLoad | Raises the Load event. (inherited from Form)
Family method | OnLocationChanged | Raises the LocationChanged event. (inherited from Control)
Family method | OnLostFocus | Raises the LostFocus event. (inherited from Control)
Family method | OnMarginChanged | Raises the MarginChanged event. (inherited from Control)
Family method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (inherited from Form)
Family method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (inherited from Form)
Family method | OnMdiChildActivate | Raises the MdiChildActivate event. (inherited from Form)
Family method | OnMenuComplete | Raises the MenuComplete event. (inherited from Form)
Family method | OnMenuStart | Raises the MenuStart event. (inherited from Form)
Family method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (inherited from Form)
Family method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (inherited from Control)
Family method | OnMouseClick | Raises the MouseClick event. (inherited from Control)
Family method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (inherited from Control)
Family method | OnMouseDown | Raises the MouseDown event. (inherited from Control)
Family method | OnMouseEnter | Raises the MouseEnter event. (inherited from Control)
Family method | OnMouseHover | Raises the MouseHover event. (inherited from Control)
Family method | OnMouseLeave | Raises the MouseLeave event. (inherited from Control)
Family method | OnMouseMove | Raises the MouseMove event. (inherited from Control)
Family method | OnMouseUp | Raises the MouseUp event. (inherited from Control)
Family method | OnMouseWheel | Raises the MouseWheel event. (inherited from ScrollableControl)
Family method | OnMove | Raises the Move event. (inherited from Control)
Family method | OnNotifyMessage | Notifies the control of Windows messages. (inherited from Control)
Family method | OnPaddingChanged | (inherited from ScrollableControl)
Family method | OnPaint | (inherited from Form)
Family method | OnPaintBackground | (inherited from ScrollableControl)
Family method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (inherited from Control)
Family method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (inherited from Control)
Family method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (inherited from Control)
Family method | OnParentChanged | (inherited from ContainerControl)
Family method | OnParentCursorChanged | Raises the CursorChanged event. (inherited from Control)
Family method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (inherited from Control)
Family method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (inherited from Control)
Family method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (inherited from Control)
Family method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (inherited from Control)
Family method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (inherited from Control)
Family method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (inherited from Control)
Family method | OnPrint | Raises the Paint event. (inherited from Control)
Family method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (inherited from Control)
Family method | OnRegionChanged | Raises the RegionChanged event. (inherited from Control)
Family method | OnResize | (inherited from Form)
Family method | OnResizeBegin | Raises the ResizeBegin event. (inherited from Form)
Family method | OnResizeEnd | Raises the ResizeEnd event. (inherited from Form)
Family method | OnRightToLeftChanged | (inherited from ScrollableControl)
Family method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (inherited from Form)
Family method | OnScroll | Raises the Scroll event. (inherited from ScrollableControl)
Family method | OnShown | Raises the Shown event. (inherited from Form)
Family method | OnSizeChanged | Raises the SizeChanged event. (inherited from Control)
Family method | OnStyleChanged | (inherited from Form)
Family method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (inherited from Control)
Family method | OnTabIndexChanged | Raises the TabIndexChanged event. (inherited from Control)
Family method | OnTabStopChanged | Raises the TabStopChanged event. (inherited from Control)
Family method | OnTextChanged | (inherited from Form)
Family method | OnValidated | Raises the Validated event. (inherited from Control)
Family method | OnValidating | Raises the Validating event. (inherited from Control)
Family method | OnVisibleChanged | Raises the VisibleChanged event. (inherited from Form)
Family method | ProcessCmdKey | Processes a command key. (inherited from Form)
Family method | ProcessDialogChar | (inherited from Form)
Family method | ProcessDialogKey | Processes a dialog key. (inherited from Form)
Family method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (inherited from Control)
Family method | ProcessKeyMessage | Processes a keyboard message. (inherited from Control)
Family method | ProcessKeyPreview | (inherited from Form)
Family method | ProcessMnemonic | (inherited from Form)
Family method | ProcessTabKey | (inherited from Form)
Family method | RaiseDragEvent | Raises the appropriate drag event. (inherited from Control)
Family method | RaiseKeyEvent | Raises the appropriate key event. (inherited from Control)
Family method | RaiseMouseEvent | Raises the appropriate mouse event. (inherited from Control)
Family method | RaisePaintEvent | Raises the appropriate paint event. (inherited from Control)
Family method | RecreateHandle | Forces the re-creation of the handle for the control. (inherited from Control)
Family method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (inherited from Control)
Family method | RtlTranslateAlignment | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text. (inherited from Control)
Family method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (inherited from Control)
Family method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (inherited from Control)
Family method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (inherited from Control)
Family method | ScaleControl | (inherited from Form)
Family method | ScaleCore | Base function that performs scaling of the form. (inherited from Form)
Family method | ScrollToControl | Calculates the scroll offset to the specified child control. (inherited from ScrollableControl)
Family method | Select | Overloaded. Activates the form and selects a child control. (inherited from Form)
Family method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (inherited from Control)
Family method | SetBoundsCore | (inherited from Form)
Family method | SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (inherited from Form)
Family method | SetDisplayRectLocation | Positions the display window to the specified value. (inherited from ScrollableControl)
Family method | SetScrollState | Sets the specified scroll state flag. (inherited from ScrollableControl)
Family method | SetStyle | Sets the specified style bit to the specified value. (inherited from Control)
Family method | SetTopLevel | Sets the control as the top-level control. (inherited from Control)
Family method | SetVisibleCore | (inherited from Form)
Family method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (inherited from Control)
Family method | UpdateBounds | Overloaded. Updates the bounds of the control. (inherited from Control)
Family method | UpdateDefaultButton | Updates which button is the default button. (inherited from Form)
Family method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (inherited from Control)
Family method | UpdateZOrder | Updates the control in its parent's z-order. (inherited from Control)
Family method | WndProc | (inherited from Form)
Top

Private Methods

 | Name | Description
Private method | InitializeComponent | Erforderliche Methode für die Designerunterstützung. Der Inhalt der Methode darf nicht mit dem Code-Editor geändert werden.
Top

Public Events

 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form)
Public event | AutoSizeChanged | (inherited from Form)
Public event | AutoValidateChanged | (inherited from Form)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control)
Public event | Click | Occurs when the control is clicked. (inherited from Control)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control)
Public event | Closed | Occurs when the form is closed. (inherited from Form)
Public event | Closing | Occurs when the form is closing. (inherited from Form)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control)
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control)
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form)
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component)
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control)
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control)
Public event | Enter | Occurs when the control is entered. (inherited from Control)
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control)
Public event | FormClosed | Occurs after the form is closed. (inherited from Form)
Public event | FormClosing | Occurs before the form is closed. (inherited from Form)
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control)
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control)
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form)
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form)
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control)
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control)
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control)
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control)
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form)
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control)
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control)
Public event | MarginChanged | (inherited from Form)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form)
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form)
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control)
Public event | Move | Occurs when the control is moved. (inherited from Control)
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control)
Public event | Paint | Occurs when the control is redrawn. (inherited from Control)
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control)
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control)
Public event | Resize | Occurs when the control is resized. (inherited from Control)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl)
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form)
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control)
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control)
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form)
Public event | TabStopChanged | (inherited from Form)
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control)
Public event | Validated | Occurs when the control is finished validating. (inherited from Control)
Public event | Validating | Occurs when the control is validating. (inherited from Control)
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control)
Top

Explicit Interface Implementations

Name | Description
System#Windows#Forms#IContainerControl#ActivateControl | Activates a specified control. (inherited from ContainerControl)
System#Windows#Forms#IDropTarget#OnDragDrop | Raises the DragDrop event. (inherited from Control)
System#Windows#Forms#IDropTarget#OnDragEnter | Raises the DragEnter event. (inherited from Control)
System#Windows#Forms#IDropTarget#OnDragLeave | Raises the DragLeave event. (inherited from Control)
System#Windows#Forms#IDropTarget#OnDragOver | Raises the DragOver event. (inherited from Control)
System#Windows#Forms#ISupportOleDropSource#OnGiveFeedback | (inherited from Control)
System#Windows#Forms#ISupportOleDropSource#OnQueryContinueDrag | (inherited from Control)
System#Windows#Forms#Layout#IArrangedElement#PerformLayout | (inherited from Control)
System#Windows#Forms#Layout#IArrangedElement#SetBounds | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleControl#FreezeEvents | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleControl#GetControlInfo | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleControl#OnAmbientPropertyChange | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleControl#OnMnemonic | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#ContextSensitiveHelp | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#EnableModeless | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#GetWindow | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#OnDocWindowActivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#OnFrameWindowActivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#ResizeBorder | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#TranslateAccelerator | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#ContextSensitiveHelp | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#GetWindow | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#InPlaceDeactivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#ReactivateAndUndo | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#SetObjectRects | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#UIDeactivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#Advise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#Close | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#DoVerb | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#EnumAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#EnumVerbs | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetClientSite | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetClipboardData | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetMiscStatus | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetMoniker | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetUserClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetUserType | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#InitFromData | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#IsUpToDate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#OleUpdate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetClientSite | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetColorScheme | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetHostNames | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetMoniker | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#Unadvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleWindow#ContextSensitiveHelp | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleWindow#GetWindow | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersist#GetClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistPropertyBag#GetClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistPropertyBag#InitNew | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistPropertyBag#Load | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistPropertyBag#Save | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#GetClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#HandsOffStorage | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#InitNew | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#IsDirty | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#Load | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#Save | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#SaveCompleted | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#GetClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#GetSizeMax | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#InitNew | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#IsDirty | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#Load | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#Save | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IQuickActivate#GetContentExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IQuickActivate#QuickActivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IQuickActivate#SetContentExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#Draw | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#Freeze | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#GetAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#GetColorSet | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#SetAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#Unfreeze | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#Draw | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#Freeze | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#GetAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#GetColorSet | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#GetExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#SetAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#Unfreeze | (inherited from Control)
Top

See Also

Progress Class


Progress Constructor

Progress Constructor
[image]

default constructor

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal Caption As String _
)
C#
public Progress(
string Caption
)
C++
public:
Progress(
String Caption
) sealed
J#
public Progress(
string Caption
)
JScript
public function Progress(
Caption : String
)

See Also

Progress Class


Fields

Progress Fields
[image]

Private Fields

 | Name | Description
Private field | components | Erforderliche Designervariable.
Private field | pbDisplay |
Top

See Also

Progress Class


components Field

Progress.components Field
[image]

Erforderliche Designervariable.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private components As IContainer
C#
private IContainer components;
C++
private:
IContainer components sealed ;
J#
private IContainer components
JScript
private components : IContainer;

See Also

Progress Class


pbDisplay Field

Progress.pbDisplay Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private pbDisplay As ProgressBar
C#
private ProgressBar pbDisplay;
C++
private:
ProgressBar pbDisplay sealed ;
J#
private ProgressBar pbDisplay
JScript
private pbDisplay : ProgressBar;

See Also

Progress Class


Methods

Progress Methods
[image]

Public Methods

 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form)
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form)
Public method | BeginInvoke | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control)
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control)
Public method | Close | Closes the form. (inherited from Form)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control)
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Overloaded. Releases the resources used by the form.
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (inherited from Control)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control)
Public method | Focus | Sets input focus to the control. (inherited from Control)
Public method | GetChildAtPoint | Overloaded. Retrieves the child control at a specified location. (inherited from Control)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Hide | Conceals the control from the user. (inherited from Control)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | Invalidate | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control. (inherited from Control)
Public method | Invoke | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle. (inherited from Control)
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl)
Public method | PerformLayout | Overloaded. Forces the control to apply layout logic to child controls. (inherited from Control)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control)
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form)
Public method | ResetBackColor | (inherited from Control)
Public method | ResetBindings | (inherited from Control)
Public method | ResetCursor | (inherited from Control)
Public method | ResetFont | (inherited from Control)
Public method | ResetForeColor | (inherited from Control)
Public method | ResetImeMode | (inherited from Control)
Public method | ResetRightToLeft | (inherited from Control)
Public method | ResetText | Resets the Text property to its default value. (inherited from Control)
Public method | ResumeLayout | Overloaded. Resumes the usual layout logic. (inherited from Control)
Public method | Scale | Overloaded. Scales the control and any child controls. (inherited from Control)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl)
Public method | Select | Overloaded. Activates the form and selects a child control. (inherited from Form)
Public method | SelectNextControl | Activates the next control. (inherited from Control)
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl)
Public method | SetBounds | Overloaded. Sets the bounds of the control. (inherited from Control)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form)
Public method | setValue | sets the progress value
Public method | Show | Overloaded. Displays the form. (inherited from Form)
Public method | ShowDialog | Overloaded. Shows the form as a modal dialog box. (inherited from Form)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control)
Public method | ToString | (inherited from Form)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control)
Public method | Validate | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl)
Public method | ValidateChildren | Overloaded. Validates all selectable child controls in the form. (inherited from Form)
Top

Protected Methods

 | Name | Description
Family method | AccessibilityNotifyClients | Overloaded. Notifies the accessibility client applications of AccessibleEvents. (inherited from Control)
Family method | ActivateMdiChild | Activates the MDI child of a form. (inherited from Form)
Family method | AdjustFormScrollbars | (inherited from Form)
Family method | ApplyAutoScaling | Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (inherited from Form)
Family method | CenterToParent | Centers the position of the form within the bounds of the parent form. (inherited from Form)
Family method | CenterToScreen | Centers the form on the current screen. (inherited from Form)
Family method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (inherited from Control)
Family method | CreateControlsInstance | (inherited from Form)
Family method | CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (inherited from Form)
Family method | DefWndProc | (inherited from Form)
Family method | DestroyHandle | Destroys the handle associated with the control. (inherited from Control)
Family method | Dispose | Overloaded. Releases the resources used by the form.
Family method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (inherited from Component)
Family method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (inherited from Control)
Family method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (inherited from Control)
Family method | GetScaledBounds | (inherited from Form)
Family method | GetScrollState | Determines whether the specified flag has been set. (inherited from ScrollableControl)
Family method | GetService | Returns an object that represents a service provided by the Component or by its Container. (inherited from Component)
Family method | GetStyle | Retrieves the value of the specified control style bit for the control. (inherited from Control)
Family method | GetTopLevel | Determines if the control is a top-level control. (inherited from Control)
Family method | InitLayout | Called after the control has been added to another container. (inherited from Control)
Family method | InvokeGotFocus | Raises the GotFocus event for the specified control. (inherited from Control)
Family method | InvokeLostFocus | Raises the LostFocus event for the specified control. (inherited from Control)
Family method | InvokeOnClick | Raises the Click event for the specified control. (inherited from Control)
Family method | InvokePaint | Raises the Paint event for the specified control. (inherited from Control)
Family method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (inherited from Control)
Family method | IsInputChar | Determines if a character is an input character that the control recognizes. (inherited from Control)
Family method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (inherited from Control)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (inherited from Control)
Family method | OnActivated | Raises the Activated event. (inherited from Form)
Family method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (inherited from Control)
Family method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (inherited from ContainerControl)
Family method | OnBackColorChanged | Raises the BackColorChanged event. (inherited from Control)
Family method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (inherited from Form)
Family method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (inherited from Form)
Family method | OnBindingContextChanged | Raises the BindingContextChanged event. (inherited from Control)
Family method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (inherited from Control)
Family method | OnChangeUICues | Raises the ChangeUICues event. (inherited from Control)
Family method | OnClick | Raises the Click event. (inherited from Control)
Family method | OnClientSizeChanged | Raises the ClientSizeChanged event. (inherited from Control)
Family method | OnClosed | Raises the Closed event. (inherited from Form)
Family method | OnClosing | Raises the Closing event. (inherited from Form)
Family method | OnContextMenuChanged | Raises the ContextMenuChanged event. (inherited from Control)
Family method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (inherited from Control)
Family method | OnControlAdded | Raises the ControlAdded event. (inherited from Control)
Family method | OnControlRemoved | Raises the ControlRemoved event. (inherited from Control)
Family method | OnCreateControl | Raises the CreateControl event. (inherited from Form)
Family method | OnCursorChanged | Raises the CursorChanged event. (inherited from Control)
Family method | OnDeactivate | Raises the Deactivate event. (inherited from Form)
Family method | OnDockChanged | Raises the DockChanged event. (inherited from Control)
Family method | OnDoubleClick | Raises the DoubleClick event. (inherited from Control)
Family method | OnDragDrop | Raises the DragDrop event. (inherited from Control)
Family method | OnDragEnter | Raises the DragEnter event. (inherited from Control)
Family method | OnDragLeave | Raises the DragLeave event. (inherited from Control)
Family method | OnDragOver | Raises the DragOver event. (inherited from Control)
Family method | OnEnabledChanged | (inherited from Form)
Family method | OnEnter | Raises the Enter event. (inherited from Form)
Family method | OnFontChanged | (inherited from Form)
Family method | OnForeColorChanged | Raises the ForeColorChanged event. (inherited from Control)
Family method | OnFormClosed | Raises the FormClosed event. (inherited from Form)
Family method | OnFormClosing | Raises the FormClosing event. (inherited from Form)
Family method | OnGiveFeedback | Raises the GiveFeedback event. (inherited from Control)
Family method | OnGotFocus | Raises the GotFocus event. (inherited from Control)
Family method | OnHandleCreated | (inherited from Form)
Family method | OnHandleDestroyed | (inherited from Form)
Family method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (inherited from Form)
Family method | OnHelpRequested | Raises the HelpRequested event. (inherited from Control)
Family method | OnImeModeChanged | Raises the ImeModeChanged event. (inherited from Control)
Family method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (inherited from Form)
Family method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (inherited from Form)
Family method | OnInvalidated | Raises the Invalidated event. (inherited from Control)
Family method | OnKeyDown | Raises the KeyDown event. (inherited from Control)
Family method | OnKeyPress | Raises the KeyPress event. (inherited from Control)
Family method | OnKeyUp | Raises the KeyUp event. (inherited from Control)
Family method | OnLayout | (inherited from Form)
Family method | OnLeave | Raises the Leave event. (inherited from Control)
Family method | OnLoad | Raises the Load event. (inherited from Form)
Family method | OnLocationChanged | Raises the LocationChanged event. (inherited from Control)
Family method | OnLostFocus | Raises the LostFocus event. (inherited from Control)
Family method | OnMarginChanged | Raises the MarginChanged event. (inherited from Control)
Family method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (inherited from Form)
Family method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (inherited from Form)
Family method | OnMdiChildActivate | Raises the MdiChildActivate event. (inherited from Form)
Family method | OnMenuComplete | Raises the MenuComplete event. (inherited from Form)
Family method | OnMenuStart | Raises the MenuStart event. (inherited from Form)
Family method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (inherited from Form)
Family method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (inherited from Control)
Family method | OnMouseClick | Raises the MouseClick event. (inherited from Control)
Family method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (inherited from Control)
Family method | OnMouseDown | Raises the MouseDown event. (inherited from Control)
Family method | OnMouseEnter | Raises the MouseEnter event. (inherited from Control)
Family method | OnMouseHover | Raises the MouseHover event. (inherited from Control)
Family method | OnMouseLeave | Raises the MouseLeave event. (inherited from Control)
Family method | OnMouseMove | Raises the MouseMove event. (inherited from Control)
Family method | OnMouseUp | Raises the MouseUp event. (inherited from Control)
Family method | OnMouseWheel | Raises the MouseWheel event. (inherited from ScrollableControl)
Family method | OnMove | Raises the Move event. (inherited from Control)
Family method | OnNotifyMessage | Notifies the control of Windows messages. (inherited from Control)
Family method | OnPaddingChanged | (inherited from ScrollableControl)
Family method | OnPaint | (inherited from Form)
Family method | OnPaintBackground | (inherited from ScrollableControl)
Family method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (inherited from Control)
Family method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (inherited from Control)
Family method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (inherited from Control)
Family method | OnParentChanged | (inherited from ContainerControl)
Family method | OnParentCursorChanged | Raises the CursorChanged event. (inherited from Control)
Family method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (inherited from Control)
Family method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (inherited from Control)
Family method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (inherited from Control)
Family method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (inherited from Control)
Family method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (inherited from Control)
Family method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (inherited from Control)
Family method | OnPrint | Raises the Paint event. (inherited from Control)
Family method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (inherited from Control)
Family method | OnRegionChanged | Raises the RegionChanged event. (inherited from Control)
Family method | OnResize | (inherited from Form)
Family method | OnResizeBegin | Raises the ResizeBegin event. (inherited from Form)
Family method | OnResizeEnd | Raises the ResizeEnd event. (inherited from Form)
Family method | OnRightToLeftChanged | (inherited from ScrollableControl)
Family method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (inherited from Form)
Family method | OnScroll | Raises the Scroll event. (inherited from ScrollableControl)
Family method | OnShown | Raises the Shown event. (inherited from Form)
Family method | OnSizeChanged | Raises the SizeChanged event. (inherited from Control)
Family method | OnStyleChanged | (inherited from Form)
Family method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (inherited from Control)
Family method | OnTabIndexChanged | Raises the TabIndexChanged event. (inherited from Control)
Family method | OnTabStopChanged | Raises the TabStopChanged event. (inherited from Control)
Family method | OnTextChanged | (inherited from Form)
Family method | OnValidated | Raises the Validated event. (inherited from Control)
Family method | OnValidating | Raises the Validating event. (inherited from Control)
Family method | OnVisibleChanged | Raises the VisibleChanged event. (inherited from Form)
Family method | ProcessCmdKey | Processes a command key. (inherited from Form)
Family method | ProcessDialogChar | (inherited from Form)
Family method | ProcessDialogKey | Processes a dialog key. (inherited from Form)
Family method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (inherited from Control)
Family method | ProcessKeyMessage | Processes a keyboard message. (inherited from Control)
Family method | ProcessKeyPreview | (inherited from Form)
Family method | ProcessMnemonic | (inherited from Form)
Family method | ProcessTabKey | (inherited from Form)
Family method | RaiseDragEvent | Raises the appropriate drag event. (inherited from Control)
Family method | RaiseKeyEvent | Raises the appropriate key event. (inherited from Control)
Family method | RaiseMouseEvent | Raises the appropriate mouse event. (inherited from Control)
Family method | RaisePaintEvent | Raises the appropriate paint event. (inherited from Control)
Family method | RecreateHandle | Forces the re-creation of the handle for the control. (inherited from Control)
Family method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (inherited from Control)
Family method | RtlTranslateAlignment | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text. (inherited from Control)
Family method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (inherited from Control)
Family method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (inherited from Control)
Family method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (inherited from Control)
Family method | ScaleControl | (inherited from Form)
Family method | ScaleCore | Base function that performs scaling of the form. (inherited from Form)
Family method | ScrollToControl | Calculates the scroll offset to the specified child control. (inherited from ScrollableControl)
Family method | Select | Overloaded. Activates the form and selects a child control. (inherited from Form)
Family method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (inherited from Control)
Family method | SetBoundsCore | (inherited from Form)
Family method | SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (inherited from Form)
Family method | SetDisplayRectLocation | Positions the display window to the specified value. (inherited from ScrollableControl)
Family method | SetScrollState | Sets the specified scroll state flag. (inherited from ScrollableControl)
Family method | SetStyle | Sets the specified style bit to the specified value. (inherited from Control)
Family method | SetTopLevel | Sets the control as the top-level control. (inherited from Control)
Family method | SetVisibleCore | (inherited from Form)
Family method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (inherited from Control)
Family method | UpdateBounds | Overloaded. Updates the bounds of the control. (inherited from Control)
Family method | UpdateDefaultButton | Updates which button is the default button. (inherited from Form)
Family method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (inherited from Control)
Family method | UpdateZOrder | Updates the control in its parent's z-order. (inherited from Control)
Family method | WndProc | (inherited from Form)
Top

Private Methods

 | Name | Description
Private method | InitializeComponent | Erforderliche Methode für die Designerunterstützung. Der Inhalt der Methode darf nicht mit dem Code-Editor geändert werden.
Top

Explicit Interface Implementations

Name | Description
System#Windows#Forms#IContainerControl#ActivateControl | Activates a specified control. (inherited from ContainerControl)
System#Windows#Forms#IDropTarget#OnDragDrop | Raises the DragDrop event. (inherited from Control)
System#Windows#Forms#IDropTarget#OnDragEnter | Raises the DragEnter event. (inherited from Control)
System#Windows#Forms#IDropTarget#OnDragLeave | Raises the DragLeave event. (inherited from Control)
System#Windows#Forms#IDropTarget#OnDragOver | Raises the DragOver event. (inherited from Control)
System#Windows#Forms#ISupportOleDropSource#OnGiveFeedback | (inherited from Control)
System#Windows#Forms#ISupportOleDropSource#OnQueryContinueDrag | (inherited from Control)
System#Windows#Forms#Layout#IArrangedElement#PerformLayout | (inherited from Control)
System#Windows#Forms#Layout#IArrangedElement#SetBounds | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleControl#FreezeEvents | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleControl#GetControlInfo | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleControl#OnAmbientPropertyChange | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleControl#OnMnemonic | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#ContextSensitiveHelp | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#EnableModeless | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#GetWindow | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#OnDocWindowActivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#OnFrameWindowActivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#ResizeBorder | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#TranslateAccelerator | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#ContextSensitiveHelp | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#GetWindow | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#InPlaceDeactivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#ReactivateAndUndo | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#SetObjectRects | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#UIDeactivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#Advise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#Close | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#DoVerb | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#EnumAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#EnumVerbs | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetClientSite | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetClipboardData | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetMiscStatus | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetMoniker | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetUserClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetUserType | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#InitFromData | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#IsUpToDate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#OleUpdate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetClientSite | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetColorScheme | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetHostNames | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetMoniker | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#Unadvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleWindow#ContextSensitiveHelp | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleWindow#GetWindow | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersist#GetClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistPropertyBag#GetClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistPropertyBag#InitNew | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistPropertyBag#Load | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistPropertyBag#Save | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#GetClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#HandsOffStorage | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#InitNew | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#IsDirty | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#Load | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#Save | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#SaveCompleted | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#GetClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#GetSizeMax | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#InitNew | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#IsDirty | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#Load | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#Save | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IQuickActivate#GetContentExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IQuickActivate#QuickActivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IQuickActivate#SetContentExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#Draw | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#Freeze | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#GetAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#GetColorSet | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#SetAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#Unfreeze | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#Draw | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#Freeze | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#GetAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#GetColorSet | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#GetExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#SetAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#Unfreeze | (inherited from Control)
Top

See Also

Progress Class


Dispose Method

Progress.Dispose Method

Releases the resources used by the form.

Overload List

 | Name | Description
Family method | Dispose (Boolean) | Overridden. Verwendete Ressourcen bereinigen.
Public method | Dispose | Releases all resources used by the Component. (inherited from Component)

See Also

Progress Class


Dispose Method (Boolean)

Progress.Dispose Method (Boolean)
See Also Example
[image]

Verwendete Ressourcen bereinigen.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

Parameters

disposing
True, wenn verwaltete Ressourcen gelöscht werden sollen; andernfalls False.

See Also

Progress Class
Bsp1 Namespace
Progress.Dispose Overload List


InitializeComponent Method

Progress.InitializeComponent Method
[image]

Erforderliche Methode für die Designerunterstützung. Der Inhalt der Methode darf nicht mit dem Code-Editor geändert werden.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private Sub InitializeComponent()
C#
private void InitializeComponent()
C++
private:
void InitializeComponent() sealed
J#
private void InitializeComponent()
JScript
private function InitializeComponent()

See Also

Progress Class


setValue Method

Progress.setValue Method
[image]

sets the progress value

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub setValue( _
ByVal Value As Integer _
)
C#
public void setValue(
int Value
)
C++
public:
void setValue(
int Value
) sealed
J#
public void setValue(
int Value
)
JScript
public function setValue(
Value : int
)

See Also

Progress Class


RenderData Class

RenderData Class
See Also Example Members
[image]

This class is responsible for loading a data set

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Class RenderData
C#
public class RenderData
C++
ref class RenderData
J#
public class RenderData
JScript
public class RenderData

Remarks

This class is responsible for loading a data set

Inheritance Hierarchy

System.Object
Bsp1.RenderData

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RenderData Members


RenderData Members

RenderData Members
See Also Example Constructors Fields Methods
[image]

This class is responsible for loading a data set

The following tables list the members exposed by RenderData.

Public Constructors

 | Name | Description
Public method | RenderData | Default constructor
Top

Public Fields

 | Name | Description
Public field | mData | 3D short int Array storing the read-in data set.
Public field | mDataSize | Overall size of data set in bit.
Public field | mDataSizeX | Overall size of data set in bit.
Public field | mDataSizeY | Overall size of data set in bit.
Public field | mDataSizeZ | Overall size of data set in bit.
Public field | mHistogram | Array storing histogram data
Public field | mMaxAxis | largest axis.
Public field | mMaxCount | Max Amplitude occurring in the histogram.
Public field | mMaxDataSize | Max of mDataSizeX, mDataSizeY, mDataSizeZ.
Public field | mMaxDensity | Max occurring density.
Public field | mTexture | VolumeTexture the data set is saved in.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | OpenFile | Opens a dataset file and reads the data into a volume texture.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

RenderData Class


RenderData Constructor

RenderData Constructor
[image]

Default constructor

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RenderData()
C++
public:
RenderData() sealed
J#
public RenderData()
JScript
public function RenderData()

See Also

RenderData Class


Fields

RenderData Fields
[image]

Public Fields

 | Name | Description
Public field | mData | 3D short int Array storing the read-in data set.
Public field | mDataSize | Overall size of data set in bit.
Public field | mDataSizeX | Overall size of data set in bit.
Public field | mDataSizeY | Overall size of data set in bit.
Public field | mDataSizeZ | Overall size of data set in bit.
Public field | mHistogram | Array storing histogram data
Public field | mMaxAxis | largest axis.
Public field | mMaxCount | Max Amplitude occurring in the histogram.
Public field | mMaxDataSize | Max of mDataSizeX, mDataSizeY, mDataSizeZ.
Public field | mMaxDensity | Max occurring density.
Public field | mTexture | VolumeTexture the data set is saved in.
Top

See Also

RenderData Class


mData Field

RenderData.mData Field
[image]

3D short int Array storing the read-in data set.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public mData As Short(,,)
C#
public short[,,] mData;
C++
public:
array<short>^ mData sealed ;
J#
public short[,,] mData
JScript
public mData : short[,,];

See Also

RenderData Class


mDataSize Field

RenderData.mDataSize Field
[image]

Overall size of data set in bit.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public mDataSize As Integer
C#
public int mDataSize;
C++
public:
int mDataSize sealed ;
J#
public int mDataSize
JScript
public mDataSize : int;

See Also

RenderData Class


mDataSizeX Field

RenderData.mDataSizeX Field
[image]

Overall size of data set in bit.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public mDataSizeX As Integer
C#
public int mDataSizeX;
C++
public:
int mDataSizeX sealed ;
J#
public int mDataSizeX
JScript
public mDataSizeX : int;

See Also

RenderData Class


mDataSizeY Field

RenderData.mDataSizeY Field
[image]

Overall size of data set in bit.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public mDataSizeY As Integer
C#
public int mDataSizeY;
C++
public:
int mDataSizeY sealed ;
J#
public int mDataSizeY
JScript
public mDataSizeY : int;

See Also

RenderData Class


mDataSizeZ Field

RenderData.mDataSizeZ Field
[image]

Overall size of data set in bit.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public mDataSizeZ As Integer
C#
public int mDataSizeZ;
C++
public:
int mDataSizeZ sealed ;
J#
public int mDataSizeZ
JScript
public mDataSizeZ : int;

See Also

RenderData Class


mHistogram Field

RenderData.mHistogram Field
[image]

Array storing histogram data

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public mHistogram As Integer()
C#
public int[] mHistogram;
C++
public:
array<int>^ mHistogram sealed ;
J#
public int[] mHistogram
JScript
public mHistogram : int[];

See Also

RenderData Class


mMaxAxis Field

RenderData.mMaxAxis Field
[image]

largest axis.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public mMaxAxis As Integer
C#
public int mMaxAxis;
C++
public:
int mMaxAxis sealed ;
J#
public int mMaxAxis
JScript
public mMaxAxis : int;

See Also

RenderData Class


mMaxCount Field

RenderData.mMaxCount Field
[image]

Max Amplitude occurring in the histogram.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public mMaxCount As Integer
C#
public int mMaxCount;
C++
public:
int mMaxCount sealed ;
J#
public int mMaxCount
JScript
public mMaxCount : int;

See Also

RenderData Class


mMaxDataSize Field

RenderData.mMaxDataSize Field
[image]

Max of mDataSizeX, mDataSizeY, mDataSizeZ.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public mMaxDataSize As Integer
C#
public int mMaxDataSize;
C++
public:
int mMaxDataSize sealed ;
J#
public int mMaxDataSize
JScript
public mMaxDataSize : int;

See Also

RenderData Class


mMaxDensity Field

RenderData.mMaxDensity Field
[image]

Max occurring density.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public mMaxDensity As Integer
C#
public int mMaxDensity;
C++
public:
int mMaxDensity sealed ;
J#
public int mMaxDensity
JScript
public mMaxDensity : int;

See Also

RenderData Class


mTexture Field

RenderData.mTexture Field
[image]

VolumeTexture the data set is saved in.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public mTexture As VolumeTexture
C#
public VolumeTexture mTexture;
C++
public:
VolumeTexture mTexture sealed ;
J#
public VolumeTexture mTexture
JScript
public mTexture : VolumeTexture;

See Also

RenderData Class


Methods

RenderData Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | OpenFile | Opens a dataset file and reads the data into a volume texture.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

RenderData Class


OpenFile Method

RenderData.OpenFile Method
[image]

Opens a dataset file and reads the data into a volume texture.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub OpenFile( _
ByVal device As Device, _
ByVal File As String _
)
C#
public void OpenFile(
Device device,
string File
)
C++
public:
void OpenFile(
Device device,
String File
) sealed
J#
public void OpenFile(
Device device,
string File
)
JScript
public function OpenFile(
device : Device,
File : String
)

See Also

RenderData Class


Renderer Class

Renderer Class
See Also Example Members
[image]

This class manages all rendering operations.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Class Renderer
C#
public class Renderer
C++
ref class Renderer
J#
public class Renderer
JScript
public class Renderer

Remarks

This class manages all rendering operations.

Inheritance Hierarchy

System.Object
Bsp1.Renderer

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Renderer Members


Renderer Members

Renderer Members
See Also Example Constructors Fields Methods
[image]

This class manages all rendering operations.

The following tables list the members exposed by Renderer.

Public Constructors

 | Name | Description
Public method | Renderer | Default constructor
Top

Private Constructors

Name | Description
Renderer | Initializes the static fields of the Renderer class.
Top

Public Fields

 | Name | Description
Public field | mCube | Instance of a ColoredCube
 | mLightVec | Light Vector
Public field | mParent | parent window
 | mProjection | Projection matrix
 | mView | View matrix
 | mViewDist | View distance
 | mWorld | World matrix
Top

Private Fields

 | Name | Description
Private field | device | Reference to the render device
Private field | mOldMouse | last known mouse position
Private field | mPresentParams | Presentation Params for the DX Device
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeGraphics | Initializes the device, all matrices, and ColoredCube
Public method | LoadData | calls the ColoredCube.LoadData(filename) function, renders.
Public method | OnDataChanged | event handler: if triggerd, re-render.
Public method | OnResize | event handler: reset device if window was resized.
Public method | Render | Overloaded. wrapper method, calls the render(width, height, stepSize) method with default parameters
Public method | RenderHighres | very similar to render(width, height, stepSize), but renders into a texture surface and saves it to a given filename
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Renderer Class


Renderer Constructor

Renderer Constructor
[image]

Default constructor

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Renderer()
C++
public:
Renderer() sealed
J#
public Renderer()
JScript
public function Renderer()

See Also

Renderer Class


Renderer Static Constructor

Renderer Static Constructor
[image]

Initializes the static fields of the Renderer class.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Shared Sub New()
C#
static Renderer()
C++
static Renderer()
J#
static Renderer()
JScript
static function Renderer()

See Also

Renderer Class


Fields

Renderer Fields
[image]

Public Fields

 | Name | Description
Public field | mCube | Instance of a ColoredCube
 | mLightVec | Light Vector
Public field | mParent | parent window
 | mProjection | Projection matrix
 | mView | View matrix
 | mViewDist | View distance
 | mWorld | World matrix
Top

Private Fields

 | Name | Description
Private field | device | Reference to the render device
Private field | mOldMouse | last known mouse position
Private field | mPresentParams | Presentation Params for the DX Device
Top

See Also

Renderer Class


device Field

Renderer.device Field
[image]

Reference to the render device

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private device As Device
C#
private Device device;
C++
private:
Device device sealed ;
J#
private Device device
JScript
private device : Device;

See Also

Renderer Class


mCube Field

Renderer.mCube Field
[image]

Instance of a ColoredCube

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public mCube As ColoredCube
C#
public ColoredCube mCube;
C++
public:
ColoredCube mCube sealed ;
J#
public ColoredCube mCube
JScript
public mCube : ColoredCube;

See Also

Renderer Class


mLightVec Field

Renderer.mLightVec Field
[image]

Light Vector

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Shared mLightVec As Vector4
C#
public static Vector4 mLightVec;
C++
public:
static Vector4 mLightVec;
J#
public static Vector4 mLightVec
JScript
public static mLightVec : Vector4;

See Also

Renderer Class


mOldMouse Field

Renderer.mOldMouse Field
[image]

last known mouse position

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mOldMouse As Point
C#
private Point mOldMouse;
C++
private:
Point mOldMouse sealed ;
J#
private Point mOldMouse
JScript
private mOldMouse : Point;

See Also

Renderer Class


mParent Field

Renderer.mParent Field
[image]

parent window

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public mParent As MainWindow
C#
public MainWindow mParent;
C++
public:
MainWindow mParent sealed ;
J#
public MainWindow mParent
JScript
public mParent : MainWindow;

See Also

Renderer Class


mPresentParams Field

Renderer.mPresentParams Field
[image]

Presentation Params for the DX Device

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mPresentParams As PresentParameters
C#
private PresentParameters mPresentParams;
C++
private:
PresentParameters mPresentParams sealed ;
J#
private PresentParameters mPresentParams
JScript
private mPresentParams : PresentParameters;

See Also

Renderer Class


mProjection Field

Renderer.mProjection Field
[image]

Projection matrix

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Shared mProjection As Matrix
C#
public static Matrix mProjection;
C++
public:
static Matrix mProjection;
J#
public static Matrix mProjection
JScript
public static mProjection : Matrix;

See Also

Renderer Class


mView Field

Renderer.mView Field
[image]

View matrix

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Shared mView As Matrix
C#
public static Matrix mView;
C++
public:
static Matrix mView;
J#
public static Matrix mView
JScript
public static mView : Matrix;

See Also

Renderer Class


mViewDist Field

Renderer.mViewDist Field
[image]

View distance

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Shared mViewDist As Single
C#
public static float mViewDist;
C++
public:
static float mViewDist;
J#
public static float mViewDist
JScript
public static mViewDist : float;

See Also

Renderer Class


mWorld Field

Renderer.mWorld Field
[image]

World matrix

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Shared mWorld As Matrix
C#
public static Matrix mWorld;
C++
public:
static Matrix mWorld;
J#
public static Matrix mWorld
JScript
public static mWorld : Matrix;

See Also

Renderer Class


Methods

Renderer Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeGraphics | Initializes the device, all matrices, and ColoredCube
Public method | LoadData | calls the ColoredCube.LoadData(filename) function, renders.
Public method | OnDataChanged | event handler: if triggerd, re-render.
Public method | OnResize | event handler: reset device if window was resized.
Public method | Render | Overloaded. wrapper method, calls the render(width, height, stepSize) method with default parameters
Public method | RenderHighres | very similar to render(width, height, stepSize), but renders into a texture surface and saves it to a given filename
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Renderer Class


InitializeGraphics Method

Renderer.InitializeGraphics Method
[image]

Initializes the device, all matrices, and ColoredCube

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Function InitializeGraphics() As Boolean
C#
public bool InitializeGraphics()
C++
public:
bool InitializeGraphics() sealed
J#
public bool InitializeGraphics()
JScript
public function InitializeGraphics() : bool

See Also

Renderer Class


LoadData Method

Renderer.LoadData Method
[image]

calls the ColoredCube.LoadData(filename) function, renders.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub LoadData( _
ByVal filename As String _
)
C#
public void LoadData(
string filename
)
C++
public:
void LoadData(
String filename
) sealed
J#
public void LoadData(
string filename
)
JScript
public function LoadData(
filename : String
)

See Also

Renderer Class


OnDataChanged Method

Renderer.OnDataChanged Method
[image]

event handler: if triggerd, re-render.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub OnDataChanged( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
C#
public void OnDataChanged(
object sender,
EventArgs e
)
C++
public:
void OnDataChanged(
Object sender,
EventArgs e
) sealed
J#
public void OnDataChanged(
object sender,
EventArgs e
)
JScript
public function OnDataChanged(
sender : Object,
e : EventArgs
)

See Also

Renderer Class


OnResize Method

Renderer.OnResize Method
[image]

event handler: reset device if window was resized.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub OnResize( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
C#
public void OnResize(
object sender,
EventArgs e
)
C++
public:
void OnResize(
Object sender,
EventArgs e
) sealed
J#
public void OnResize(
object sender,
EventArgs e
)
JScript
public function OnResize(
sender : Object,
e : EventArgs
)

See Also

Renderer Class


Render Method

Renderer.Render Method

wrapper method, calls the render(width, height, stepSize) method with default parameters

Overload List

 | Name | Description
Public method | Render | wrapper method, calls the render(width, height, stepSize) method with default parameters
Public method | Render (Int32, Int32, Int32) | Render function - sets the device and all needed render calls, calls draw() function of ColoredCube, ends scene

See Also

Renderer Class


Render Method ()

Renderer.Render Method ()
See Also Example
[image]

wrapper method, calls the render(width, height, stepSize) method with default parameters

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub Render()
C#
public void Render()
C++
public:
void Render() sealed
J#
public void Render()
JScript
public function Render()

See Also

Renderer Class
Bsp1 Namespace
Renderer.Render Overload List


Render Method (Int32, Int32, Int32)

Renderer.Render Method (Int32, Int32, Int32)
See Also Example
[image]

Render function - sets the device and all needed render calls, calls draw() function of ColoredCube, ends scene

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub Render( _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal StepSize As Integer _
)
C#
public void Render(
int width,
int height,
int StepSize
)
C++
public:
void Render(
int width,
int height,
int StepSize
) sealed
J#
public void Render(
int width,
int height,
int StepSize
)
JScript
public function Render(
width : int,
height : int,
StepSize : int
)

See Also

Renderer Class
Bsp1 Namespace
Renderer.Render Overload List


RenderHighres Method

Renderer.RenderHighres Method
[image]

very similar to render(width, height, stepSize), but renders into a texture surface and saves it to a given filename

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub RenderHighres( _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal FileName As String, _
ByVal format As ImageFileFormat _
)
C#
public void RenderHighres(
int width,
int height,
string FileName,
ImageFileFormat format
)
C++
public:
void RenderHighres(
int width,
int height,
String FileName,
ImageFileFormat format
) sealed
J#
public void RenderHighres(
int width,
int height,
string FileName,
ImageFileFormat format
)
JScript
public function RenderHighres(
width : int,
height : int,
FileName : String,
format : ImageFileFormat
)

See Also

Renderer Class


RenderingForm Class

RenderingForm Class
See Also Example Members
[image]

This class is used to select a filename for a high res image to be saved

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Class RenderingForm
Inherits Form
C#
public class RenderingForm : Form
C++
ref class RenderingForm : Form
J#
public class RenderingForm extends Form
JScript
public class RenderingForm extends Form

Remarks

This class is used to select a filename for a high res image to be saved

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Bsp1.RenderingForm

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RenderingForm Members


RenderingForm Members

RenderingForm Members
See Also Example Constructors Fields Properties Methods Events Explicit Inteface Implementations
[image]

This class is used to select a filename for a high res image to be saved

The following tables list the members exposed by RenderingForm.

Public Constructors

 | Name | Description
Public method | RenderingForm | Default constructor
Top

Private Fields

 | Name | Description
Private field | btnBrowse |
Private field | btnOk |
Private field | components | Erforderliche Designervariable.
Private field | label1 |
Private field | label2 |
Private field | lblImage |
Private field | mFilename | Filename
Private field | mFormat | File Format
Private field | mHeight | Height of image
Private field | mWidth | Width of image
Private field | SaveImgDlg |
Private field | tbFileName |
Private field | tbHeight |
Private field | tbWidth |
Top

Public Properties

 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control)
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control)
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl)
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control)
Public property | AutoScale | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView. (inherited from Control)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl)
Public property | AutoSize | (inherited from Form)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form)
Public property | AutoValidate | (inherited from Form)
Public property | BackColor | (inherited from Form)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control)
Public property | BindingContext | (inherited from ContainerControl)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control)
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control)
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form)
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control)
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control)
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form)
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control)
Public property | File | Filename Getter and Setter
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control)
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control)
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control)
Public property | Format | File Format Getter
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form)
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control)
Public property | Height | Gets or sets the height of the control. (inherited from Control)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl)
Public property | Icon | Gets or sets the icon for the form. (inherited from Form)
Public property | ImageHeight | Image Heigth Getter
Public property | ImageWidth | Image Width Getter
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control)
Public property | Location | (inherited from Form)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form)
Public property | Margin | (inherited from Form)
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form)
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form)
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form)
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form)
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form)
Public property | Name | Gets or sets the name of the control. (inherited from Control)
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form)
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form)
Public property | Padding | Gets or sets padding within the control. (inherited from Control)
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control)
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control)
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control)
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control)
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form)
Public property | Site | Gets or sets the site of the control. (inherited from Control)
Public property | Size | Gets or sets the size of the form. (inherited from Form)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form)
Public property | TabStop | (inherited from Form)
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control)
Public property | Text | (inherited from Form)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl)
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control)
Public property | Width | Gets or sets the width of the control. (inherited from Control)
Public property | WindowState | Gets or sets the form's window state. (inherited from Form)
Public property | WindowTarget | (inherited from Control)
Top

Protected Properties

 | Name | Description
Family property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (inherited from ContainerControl)
Family property | CanRaiseEvents | Determines if events can be raised on the control. (inherited from Control)
Family property | CreateParams | (inherited from Form)
Family property | DefaultCursor | Gets or sets the default cursor for the control. (inherited from Control)
Family property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (inherited from Form)
Family property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (inherited from Control)
Family property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (inherited from Control)
Family property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (inherited from Control)
Family property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (inherited from Control)
Family property | DefaultSize | (inherited from Form)
Family property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (inherited from Component)
Family property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (inherited from Control)
Family property | Events | Gets the list of event handlers that are attached to this Component. (inherited from Component)
Family property | FontHeight | Gets or sets the height of the font of the control. (inherited from Control)
Family property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (inherited from ScrollableControl)
Family property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (inherited from Form)
Family property | RenderRightToLeft | (inherited from Control)
Family property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (inherited from Control)
Family property | ScaleChildren | Gets a value that determines the scaling of child controls. (inherited from Control)
Family property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (inherited from Control)
Family property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (inherited from Control)
Family property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (inherited from Form)
Family property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (inherited from ScrollableControl)
Top

Public Methods

 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form)
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form)
Public method | BeginInvoke | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control)
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control)
Public method | Close | Closes the form. (inherited from Form)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control)
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Overloaded. Releases the resources used by the form.
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (inherited from Control)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control)
Public method | Focus | Sets input focus to the control. (inherited from Control)
Public method | GetChildAtPoint | Overloaded. Retrieves the child control at a specified location. (inherited from Control)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Hide | Conceals the control from the user. (inherited from Control)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | Invalidate | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control. (inherited from Control)
Public method | Invoke | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle. (inherited from Control)
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl)
Public method | PerformLayout | Overloaded. Forces the control to apply layout logic to child controls. (inherited from Control)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control)
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form)
Public method | ResetBackColor | (inherited from Control)
Public method | ResetBindings | (inherited from Control)
Public method | ResetCursor | (inherited from Control)
Public method | ResetFont | (inherited from Control)
Public method | ResetForeColor | (inherited from Control)
Public method | ResetImeMode | (inherited from Control)
Public method | ResetRightToLeft | (inherited from Control)
Public method | ResetText | Resets the Text property to its default value. (inherited from Control)
Public method | ResumeLayout | Overloaded. Resumes the usual layout logic. (inherited from Control)
Public method | Scale | Overloaded. Scales the control and any child controls. (inherited from Control)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl)
Public method | Select | Overloaded. Activates the form and selects a child control. (inherited from Form)
Public method | SelectNextControl | Activates the next control. (inherited from Control)
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl)
Public method | SetBounds | Overloaded. Sets the bounds of the control. (inherited from Control)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form)
Public method | Show | Overloaded. Displays the form. (inherited from Form)
Public method | ShowDialog | Overloaded. Shows the form as a modal dialog box. (inherited from Form)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control)
Public method | ToString | (inherited from Form)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control)
Public method | Validate | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl)
Public method | ValidateChildren | Overloaded. Validates all selectable child controls in the form. (inherited from Form)
Top

Protected Methods

 | Name | Description
Family method | AccessibilityNotifyClients | Overloaded. Notifies the accessibility client applications of AccessibleEvents. (inherited from Control)
Family method | ActivateMdiChild | Activates the MDI child of a form. (inherited from Form)
Family method | AdjustFormScrollbars | (inherited from Form)
Family method | ApplyAutoScaling | Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (inherited from Form)
Family method | CenterToParent | Centers the position of the form within the bounds of the parent form. (inherited from Form)
Family method | CenterToScreen | Centers the form on the current screen. (inherited from Form)
Family method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (inherited from Control)
Family method | CreateControlsInstance | (inherited from Form)
Family method | CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (inherited from Form)
Family method | DefWndProc | (inherited from Form)
Family method | DestroyHandle | Destroys the handle associated with the control. (inherited from Control)
Family method | Dispose | Overloaded. Releases the resources used by the form.
Family method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (inherited from Component)
Family method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (inherited from Control)
Family method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (inherited from Control)
Family method | GetScaledBounds | (inherited from Form)
Family method | GetScrollState | Determines whether the specified flag has been set. (inherited from ScrollableControl)
Family method | GetService | Returns an object that represents a service provided by the Component or by its Container. (inherited from Component)
Family method | GetStyle | Retrieves the value of the specified control style bit for the control. (inherited from Control)
Family method | GetTopLevel | Determines if the control is a top-level control. (inherited from Control)
Family method | InitLayout | Called after the control has been added to another container. (inherited from Control)
Family method | InvokeGotFocus | Raises the GotFocus event for the specified control. (inherited from Control)
Family method | InvokeLostFocus | Raises the LostFocus event for the specified control. (inherited from Control)
Family method | InvokeOnClick | Raises the Click event for the specified control. (inherited from Control)
Family method | InvokePaint | Raises the Paint event for the specified control. (inherited from Control)
Family method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (inherited from Control)
Family method | IsInputChar | Determines if a character is an input character that the control recognizes. (inherited from Control)
Family method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (inherited from Control)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (inherited from Control)
Family method | OnActivated | Raises the Activated event. (inherited from Form)
Family method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (inherited from Control)
Family method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (inherited from ContainerControl)
Family method | OnBackColorChanged | Raises the BackColorChanged event. (inherited from Control)
Family method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (inherited from Form)
Family method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (inherited from Form)
Family method | OnBindingContextChanged | Raises the BindingContextChanged event. (inherited from Control)
Family method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (inherited from Control)
Family method | OnChangeUICues | Raises the ChangeUICues event. (inherited from Control)
Family method | OnClick | Raises the Click event. (inherited from Control)
Family method | OnClientSizeChanged | Raises the ClientSizeChanged event. (inherited from Control)
Family method | OnClosed | Raises the Closed event. (inherited from Form)
Family method | OnClosing | Raises the Closing event. (inherited from Form)
Family method | OnContextMenuChanged | Raises the ContextMenuChanged event. (inherited from Control)
Family method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (inherited from Control)
Family method | OnControlAdded | Raises the ControlAdded event. (inherited from Control)
Family method | OnControlRemoved | Raises the ControlRemoved event. (inherited from Control)
Family method | OnCreateControl | Raises the CreateControl event. (inherited from Form)
Family method | OnCursorChanged | Raises the CursorChanged event. (inherited from Control)
Family method | OnDeactivate | Raises the Deactivate event. (inherited from Form)
Family method | OnDockChanged | Raises the DockChanged event. (inherited from Control)
Family method | OnDoubleClick | Raises the DoubleClick event. (inherited from Control)
Family method | OnDragDrop | Raises the DragDrop event. (inherited from Control)
Family method | OnDragEnter | Raises the DragEnter event. (inherited from Control)
Family method | OnDragLeave | Raises the DragLeave event. (inherited from Control)
Family method | OnDragOver | Raises the DragOver event. (inherited from Control)
Family method | OnEnabledChanged | (inherited from Form)
Family method | OnEnter | Raises the Enter event. (inherited from Form)
Family method | OnFontChanged | (inherited from Form)
Family method | OnForeColorChanged | Raises the ForeColorChanged event. (inherited from Control)
Family method | OnFormClosed | Raises the FormClosed event. (inherited from Form)
Family method | OnFormClosing | Raises the FormClosing event. (inherited from Form)
Family method | OnGiveFeedback | Raises the GiveFeedback event. (inherited from Control)
Family method | OnGotFocus | Raises the GotFocus event. (inherited from Control)
Family method | OnHandleCreated | (inherited from Form)
Family method | OnHandleDestroyed | (inherited from Form)
Family method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (inherited from Form)
Family method | OnHelpRequested | Raises the HelpRequested event. (inherited from Control)
Family method | OnImeModeChanged | Raises the ImeModeChanged event. (inherited from Control)
Family method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (inherited from Form)
Family method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (inherited from Form)
Family method | OnInvalidated | Raises the Invalidated event. (inherited from Control)
Family method | OnKeyDown | Raises the KeyDown event. (inherited from Control)
Family method | OnKeyPress | Raises the KeyPress event. (inherited from Control)
Family method | OnKeyUp | Raises the KeyUp event. (inherited from Control)
Family method | OnLayout | (inherited from Form)
Family method | OnLeave | Raises the Leave event. (inherited from Control)
Family method | OnLoad | Raises the Load event. (inherited from Form)
Family method | OnLocationChanged | Raises the LocationChanged event. (inherited from Control)
Family method | OnLostFocus | Raises the LostFocus event. (inherited from Control)
Family method | OnMarginChanged | Raises the MarginChanged event. (inherited from Control)
Family method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (inherited from Form)
Family method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (inherited from Form)
Family method | OnMdiChildActivate | Raises the MdiChildActivate event. (inherited from Form)
Family method | OnMenuComplete | Raises the MenuComplete event. (inherited from Form)
Family method | OnMenuStart | Raises the MenuStart event. (inherited from Form)
Family method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (inherited from Form)
Family method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (inherited from Control)
Family method | OnMouseClick | Raises the MouseClick event. (inherited from Control)
Family method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (inherited from Control)
Family method | OnMouseDown | Raises the MouseDown event. (inherited from Control)
Family method | OnMouseEnter | Raises the MouseEnter event. (inherited from Control)
Family method | OnMouseHover | Raises the MouseHover event. (inherited from Control)
Family method | OnMouseLeave | Raises the MouseLeave event. (inherited from Control)
Family method | OnMouseMove | Raises the MouseMove event. (inherited from Control)
Family method | OnMouseUp | Raises the MouseUp event. (inherited from Control)
Family method | OnMouseWheel | Raises the MouseWheel event. (inherited from ScrollableControl)
Family method | OnMove | Raises the Move event. (inherited from Control)
Family method | OnNotifyMessage | Notifies the control of Windows messages. (inherited from Control)
Family method | OnPaddingChanged | (inherited from ScrollableControl)
Family method | OnPaint | (inherited from Form)
Family method | OnPaintBackground | (inherited from ScrollableControl)
Family method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (inherited from Control)
Family method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (inherited from Control)
Family method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (inherited from Control)
Family method | OnParentChanged | (inherited from ContainerControl)
Family method | OnParentCursorChanged | Raises the CursorChanged event. (inherited from Control)
Family method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (inherited from Control)
Family method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (inherited from Control)
Family method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (inherited from Control)
Family method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (inherited from Control)
Family method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (inherited from Control)
Family method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (inherited from Control)
Family method | OnPrint | Raises the Paint event. (inherited from Control)
Family method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (inherited from Control)
Family method | OnRegionChanged | Raises the RegionChanged event. (inherited from Control)
Family method | OnResize | (inherited from Form)
Family method | OnResizeBegin | Raises the ResizeBegin event. (inherited from Form)
Family method | OnResizeEnd | Raises the ResizeEnd event. (inherited from Form)
Family method | OnRightToLeftChanged | (inherited from ScrollableControl)
Family method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (inherited from Form)
Family method | OnScroll | Raises the Scroll event. (inherited from ScrollableControl)
Family method | OnShown | Raises the Shown event. (inherited from Form)
Family method | OnSizeChanged | Raises the SizeChanged event. (inherited from Control)
Family method | OnStyleChanged | (inherited from Form)
Family method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (inherited from Control)
Family method | OnTabIndexChanged | Raises the TabIndexChanged event. (inherited from Control)
Family method | OnTabStopChanged | Raises the TabStopChanged event. (inherited from Control)
Family method | OnTextChanged | (inherited from Form)
Family method | OnValidated | Raises the Validated event. (inherited from Control)
Family method | OnValidating | Raises the Validating event. (inherited from Control)
Family method | OnVisibleChanged | Raises the VisibleChanged event. (inherited from Form)
Family method | ProcessCmdKey | Processes a command key. (inherited from Form)
Family method | ProcessDialogChar | (inherited from Form)
Family method | ProcessDialogKey | Processes a dialog key. (inherited from Form)
Family method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (inherited from Control)
Family method | ProcessKeyMessage | Processes a keyboard message. (inherited from Control)
Family method | ProcessKeyPreview | (inherited from Form)
Family method | ProcessMnemonic | (inherited from Form)
Family method | ProcessTabKey | (inherited from Form)
Family method | RaiseDragEvent | Raises the appropriate drag event. (inherited from Control)
Family method | RaiseKeyEvent | Raises the appropriate key event. (inherited from Control)
Family method | RaiseMouseEvent | Raises the appropriate mouse event. (inherited from Control)
Family method | RaisePaintEvent | Raises the appropriate paint event. (inherited from Control)
Family method | RecreateHandle | Forces the re-creation of the handle for the control. (inherited from Control)
Family method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (inherited from Control)
Family method | RtlTranslateAlignment | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text. (inherited from Control)
Family method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (inherited from Control)
Family method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (inherited from Control)
Family method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (inherited from Control)
Family method | ScaleControl | (inherited from Form)
Family method | ScaleCore | Base function that performs scaling of the form. (inherited from Form)
Family method | ScrollToControl | Calculates the scroll offset to the specified child control. (inherited from ScrollableControl)
Family method | Select | Overloaded. Activates the form and selects a child control. (inherited from Form)
Family method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (inherited from Control)
Family method | SetBoundsCore | (inherited from Form)
Family method | SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (inherited from Form)
Family method | SetDisplayRectLocation | Positions the display window to the specified value. (inherited from ScrollableControl)
Family method | SetScrollState | Sets the specified scroll state flag. (inherited from ScrollableControl)
Family method | SetStyle | Sets the specified style bit to the specified value. (inherited from Control)
Family method | SetTopLevel | Sets the control as the top-level control. (inherited from Control)
Family method | SetVisibleCore | (inherited from Form)
Family method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (inherited from Control)
Family method | UpdateBounds | Overloaded. Updates the bounds of the control. (inherited from Control)
Family method | UpdateDefaultButton | Updates which button is the default button. (inherited from Form)
Family method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (inherited from Control)
Family method | UpdateZOrder | Updates the control in its parent's z-order. (inherited from Control)
Family method | WndProc | (inherited from Form)
Top

Private Methods

 | Name | Description
Private method | btnBrowse_Click | Event Handler
Private method | btnOk_Click | Event Handler
Private method | InitializeComponent | Erforderliche Methode für die Designerunterstützung. Der Inhalt der Methode darf nicht mit dem Code-Editor geändert werden.
Private method | SaveImgDlg_FileOk | Event Handler
Top

Public Events

 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form)
Public event | AutoSizeChanged | (inherited from Form)
Public event | AutoValidateChanged | (inherited from Form)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control)
Public event | Click | Occurs when the control is clicked. (inherited from Control)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control)
Public event | Closed | Occurs when the form is closed. (inherited from Form)
Public event | Closing | Occurs when the form is closing. (inherited from Form)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control)
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control)
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form)
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component)
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control)
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control)
Public event | Enter | Occurs when the control is entered. (inherited from Control)
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control)
Public event | FormClosed | Occurs after the form is closed. (inherited from Form)
Public event | FormClosing | Occurs before the form is closed. (inherited from Form)
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control)
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control)
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form)
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form)
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control)
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control)
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control)
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control)
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form)
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control)
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control)
Public event | MarginChanged | (inherited from Form)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form)
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form)
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control)
Public event | Move | Occurs when the control is moved. (inherited from Control)
Public event | OnOkClicked | Event Handler
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control)
Public event | Paint | Occurs when the control is redrawn. (inherited from Control)
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control)
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control)
Public event | Resize | Occurs when the control is resized. (inherited from Control)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl)
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form)
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control)
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control)
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form)
Public event | TabStopChanged | (inherited from Form)
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control)
Public event | Validated | Occurs when the control is finished validating. (inherited from Control)
Public event | Validating | Occurs when the control is validating. (inherited from Control)
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control)
Top

Explicit Interface Implementations

Name | Description
System#Windows#Forms#IContainerControl#ActivateControl | Activates a specified control. (inherited from ContainerControl)
System#Windows#Forms#IDropTarget#OnDragDrop | Raises the DragDrop event. (inherited from Control)
System#Windows#Forms#IDropTarget#OnDragEnter | Raises the DragEnter event. (inherited from Control)
System#Windows#Forms#IDropTarget#OnDragLeave | Raises the DragLeave event. (inherited from Control)
System#Windows#Forms#IDropTarget#OnDragOver | Raises the DragOver event. (inherited from Control)
System#Windows#Forms#ISupportOleDropSource#OnGiveFeedback | (inherited from Control)
System#Windows#Forms#ISupportOleDropSource#OnQueryContinueDrag | (inherited from Control)
System#Windows#Forms#Layout#IArrangedElement#PerformLayout | (inherited from Control)
System#Windows#Forms#Layout#IArrangedElement#SetBounds | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleControl#FreezeEvents | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleControl#GetControlInfo | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleControl#OnAmbientPropertyChange | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleControl#OnMnemonic | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#ContextSensitiveHelp | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#EnableModeless | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#GetWindow | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#OnDocWindowActivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#OnFrameWindowActivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#ResizeBorder | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#TranslateAccelerator | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#ContextSensitiveHelp | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#GetWindow | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#InPlaceDeactivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#ReactivateAndUndo | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#SetObjectRects | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#UIDeactivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#Advise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#Close | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#DoVerb | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#EnumAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#EnumVerbs | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetClientSite | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetClipboardData | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetMiscStatus | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetMoniker | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetUserClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetUserType | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#InitFromData | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#IsUpToDate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#OleUpdate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetClientSite | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetColorScheme | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetHostNames | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetMoniker | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#Unadvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleWindow#ContextSensitiveHelp | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleWindow#GetWindow | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersist#GetClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistPropertyBag#GetClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistPropertyBag#InitNew | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistPropertyBag#Load | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistPropertyBag#Save | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#GetClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#HandsOffStorage | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#InitNew | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#IsDirty | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#Load | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#Save | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#SaveCompleted | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#GetClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#GetSizeMax | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#InitNew | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#IsDirty | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#Load | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#Save | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IQuickActivate#GetContentExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IQuickActivate#QuickActivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IQuickActivate#SetContentExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#Draw | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#Freeze | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#GetAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#GetColorSet | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#SetAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#Unfreeze | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#Draw | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#Freeze | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#GetAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#GetColorSet | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#GetExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#SetAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#Unfreeze | (inherited from Control)
Top

See Also

RenderingForm Class


RenderingForm Constructor

RenderingForm Constructor
[image]

Default constructor

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RenderingForm()
C++
public:
RenderingForm() sealed
J#
public RenderingForm()
JScript
public function RenderingForm()

See Also

RenderingForm Class


Fields

RenderingForm Fields
[image]

Private Fields

 | Name | Description
Private field | btnBrowse |
Private field | btnOk |
Private field | components | Erforderliche Designervariable.
Private field | label1 |
Private field | label2 |
Private field | lblImage |
Private field | mFilename | Filename
Private field | mFormat | File Format
Private field | mHeight | Height of image
Private field | mWidth | Width of image
Private field | SaveImgDlg |
Private field | tbFileName |
Private field | tbHeight |
Private field | tbWidth |
Top

See Also

RenderingForm Class


btnBrowse Field

RenderingForm.btnBrowse Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private btnBrowse As Button
C#
private Button btnBrowse;
C++
private:
Button btnBrowse sealed ;
J#
private Button btnBrowse
JScript
private btnBrowse : Button;

See Also

RenderingForm Class


btnOk Field

RenderingForm.btnOk Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private btnOk As Button
C#
private Button btnOk;
C++
private:
Button btnOk sealed ;
J#
private Button btnOk
JScript
private btnOk : Button;

See Also

RenderingForm Class


components Field

RenderingForm.components Field
[image]

Erforderliche Designervariable.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private components As IContainer
C#
private IContainer components;
C++
private:
IContainer components sealed ;
J#
private IContainer components
JScript
private components : IContainer;

See Also

RenderingForm Class


label1 Field

RenderingForm.label1 Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private label1 As Label
C#
private Label label1;
C++
private:
Label label1 sealed ;
J#
private Label label1
JScript
private label1 : Label;

See Also

RenderingForm Class


label2 Field

RenderingForm.label2 Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private label2 As Label
C#
private Label label2;
C++
private:
Label label2 sealed ;
J#
private Label label2
JScript
private label2 : Label;

See Also

RenderingForm Class


lblImage Field

RenderingForm.lblImage Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private lblImage As Label
C#
private Label lblImage;
C++
private:
Label lblImage sealed ;
J#
private Label lblImage
JScript
private lblImage : Label;

See Also

RenderingForm Class


mFilename Field

RenderingForm.mFilename Field
[image]

Filename

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mFilename As String
C#
private string mFilename;
C++
private:
String mFilename sealed ;
J#
private string mFilename
JScript
private mFilename : String;

See Also

RenderingForm Class


mFormat Field

RenderingForm.mFormat Field
[image]

File Format

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mFormat As ImageFileFormat
C#
private ImageFileFormat mFormat;
C++
private:
ImageFileFormat mFormat sealed ;
J#
private ImageFileFormat mFormat
JScript
private mFormat : ImageFileFormat;

See Also

RenderingForm Class


mHeight Field

RenderingForm.mHeight Field
[image]

Height of image

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mHeight As Integer
C#
private int mHeight;
C++
private:
int mHeight sealed ;
J#
private int mHeight
JScript
private mHeight : int;

See Also

RenderingForm Class


mWidth Field

RenderingForm.mWidth Field
[image]

Width of image

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private mWidth As Integer
C#
private int mWidth;
C++
private:
int mWidth sealed ;
J#
private int mWidth
JScript
private mWidth : int;

See Also

RenderingForm Class


SaveImgDlg Field

RenderingForm.SaveImgDlg Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private SaveImgDlg As SaveFileDialog
C#
private SaveFileDialog SaveImgDlg;
C++
private:
SaveFileDialog SaveImgDlg sealed ;
J#
private SaveFileDialog SaveImgDlg
JScript
private SaveImgDlg : SaveFileDialog;

See Also

RenderingForm Class


tbFileName Field

RenderingForm.tbFileName Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private tbFileName As TextBox
C#
private TextBox tbFileName;
C++
private:
TextBox tbFileName sealed ;
J#
private TextBox tbFileName
JScript
private tbFileName : TextBox;

See Also

RenderingForm Class


tbHeight Field

RenderingForm.tbHeight Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private tbHeight As TextBox
C#
private TextBox tbHeight;
C++
private:
TextBox tbHeight sealed ;
J#
private TextBox tbHeight
JScript
private tbHeight : TextBox;

See Also

RenderingForm Class


tbWidth Field

RenderingForm.tbWidth Field
[image]

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private tbWidth As TextBox
C#
private TextBox tbWidth;
C++
private:
TextBox tbWidth sealed ;
J#
private TextBox tbWidth
JScript
private tbWidth : TextBox;

See Also

RenderingForm Class


Properties

RenderingForm Properties
[image]

Public Properties

 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (inherited from Form)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control)
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control)
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl)
Public property | ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (inherited from Form)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (inherited from Form)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control)
Public property | AutoScale | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (inherited from Form)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (inherited from Form)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (inherited from Form)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView. (inherited from Control)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl)
Public property | AutoSize | (inherited from Form)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (inherited from Form)
Public property | AutoValidate | (inherited from Form)
Public property | BackColor | (inherited from Form)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control)
Public property | BindingContext | (inherited from ContainerControl)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (inherited from Form)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control)
Public property | ClientSize | Gets or sets the size of the client area of the form. (inherited from Form)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control)
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (inherited from Form)
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control)
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control)
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (inherited from Form)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (inherited from Form)
Public property | DialogResult | Gets or sets the dialog result for the form. (inherited from Form)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control)
Public property | File | Filename Getter and Setter
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control)
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control)
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control)
Public property | Format | File Format Getter
Public property | FormBorderStyle | Gets or sets the border style of the form. (inherited from Form)
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control)
Public property | Height | Gets or sets the height of the control. (inherited from Control)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (inherited from Form)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl)
Public property | Icon | Gets or sets the icon for the form. (inherited from Form)
Public property | ImageHeight | Image Heigth Getter
Public property | ImageWidth | Image Width Getter
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (inherited from Form)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (inherited from Form)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (inherited from Form)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (inherited from Form)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control)
Public property | Location | (inherited from Form)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (inherited from Form)
Public property | Margin | (inherited from Form)
Public property | MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (inherited from Form)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (inherited from Form)
Public property | MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (inherited from Form)
Public property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (inherited from Form)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (inherited from Form)
Public property | MergedMenu | Gets the merged menu for the form. (inherited from Form)
Public property | MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (inherited from Form)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (inherited from Form)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (inherited from Form)
Public property | Name | Gets or sets the name of the control. (inherited from Control)
Public property | Opacity | Gets or sets the opacity level of the form. (inherited from Form)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (inherited from Form)
Public property | Owner | Gets or sets the form that owns this form. (inherited from Form)
Public property | Padding | Gets or sets padding within the control. (inherited from Control)
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control)
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control)
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control)
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control)
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (inherited from Form)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (inherited from Form)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (inherited from Form)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (inherited from Form)
Public property | Site | Gets or sets the site of the control. (inherited from Control)
Public property | Size | Gets or sets the size of the form. (inherited from Form)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (inherited from Form)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (inherited from Form)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Form)
Public property | TabStop | (inherited from Form)
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control)
Public property | Text | (inherited from Form)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (inherited from Form)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (inherited from Form)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (inherited from Form)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl)
Public property | Visible | Gets or sets a value indicating whether the control is displayed. (inherited from Control)
Public property | Width | Gets or sets the width of the control. (inherited from Control)
Public property | WindowState | Gets or sets the form's window state. (inherited from Form)
Public property | WindowTarget | (inherited from Control)
Top

Protected Properties

 | Name | Description
Family property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (inherited from ContainerControl)
Family property | CanRaiseEvents | Determines if events can be raised on the control. (inherited from Control)
Family property | CreateParams | (inherited from Form)
Family property | DefaultCursor | Gets or sets the default cursor for the control. (inherited from Control)
Family property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (inherited from Form)
Family property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (inherited from Control)
Family property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (inherited from Control)
Family property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (inherited from Control)
Family property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (inherited from Control)
Family property | DefaultSize | (inherited from Form)
Family property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (inherited from Component)
Family property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (inherited from Control)
Family property | Events | Gets the list of event handlers that are attached to this Component. (inherited from Component)
Family property | FontHeight | Gets or sets the height of the font of the control. (inherited from Control)
Family property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (inherited from ScrollableControl)
Family property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (inherited from Form)
Family property | RenderRightToLeft | (inherited from Control)
Family property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (inherited from Control)
Family property | ScaleChildren | Gets a value that determines the scaling of child controls. (inherited from Control)
Family property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (inherited from Control)
Family property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (inherited from Control)
Family property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (inherited from Form)
Family property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (inherited from ScrollableControl)
Top

See Also

RenderingForm Class


File Property

RenderingForm.File Property
[image]

Filename Getter and Setter

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property File As String
C#
public string File { get; }
C++
public property string File sealed {
String get();
}
J#
/** property */
public string get_File();
JScript
public function get File() : String

See Also

RenderingForm Class


Format Property

RenderingForm.Format Property
[image]

File Format Getter

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Format As ImageFileFormat
C#
public ImageFileFormat Format { get; }
C++
public property ImageFileFormat Format sealed {
ImageFileFormat get();
}
J#
/** property */
public ImageFileFormat get_Format();
JScript
public function get Format() : ImageFileFormat

See Also

RenderingForm Class


ImageHeight Property

RenderingForm.ImageHeight Property
[image]

Image Heigth Getter

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ImageHeight As Integer
C#
public int ImageHeight { get; }
C++
public property int ImageHeight sealed {
int get();
}
J#
/** property */
public int get_ImageHeight();
JScript
public function get ImageHeight() : int

See Also

RenderingForm Class


ImageWidth Property

RenderingForm.ImageWidth Property
[image]

Image Width Getter

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ImageWidth As Integer
C#
public int ImageWidth { get; }
C++
public property int ImageWidth sealed {
int get();
}
J#
/** property */
public int get_ImageWidth();
JScript
public function get ImageWidth() : int

See Also

RenderingForm Class


Methods

RenderingForm Methods
[image]

Public Methods

 | Name | Description
Public method | Activate | Activates the form and gives it focus. (inherited from Form)
Public method | AddOwnedForm | Adds an owned form to this form. (inherited from Form)
Public method | BeginInvoke | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control)
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control)
Public method | Close | Closes the form. (inherited from Form)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control)
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Overloaded. Releases the resources used by the form.
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (inherited from Control)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control)
Public method | Focus | Sets input focus to the control. (inherited from Control)
Public method | GetChildAtPoint | Overloaded. Retrieves the child control at a specified location. (inherited from Control)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Hide | Conceals the control from the user. (inherited from Control)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | Invalidate | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control. (inherited from Control)
Public method | Invoke | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle. (inherited from Control)
Public method | LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (inherited from Form)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl)
Public method | PerformLayout | Overloaded. Forces the control to apply layout logic to child controls. (inherited from Control)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control)
Public method | RemoveOwnedForm | Removes an owned form from this form. (inherited from Form)
Public method | ResetBackColor | (inherited from Control)
Public method | ResetBindings | (inherited from Control)
Public method | ResetCursor | (inherited from Control)
Public method | ResetFont | (inherited from Control)
Public method | ResetForeColor | (inherited from Control)
Public method | ResetImeMode | (inherited from Control)
Public method | ResetRightToLeft | (inherited from Control)
Public method | ResetText | Resets the Text property to its default value. (inherited from Control)
Public method | ResumeLayout | Overloaded. Resumes the usual layout logic. (inherited from Control)
Public method | Scale | Overloaded. Scales the control and any child controls. (inherited from Control)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl)
Public method | Select | Overloaded. Activates the form and selects a child control. (inherited from Form)
Public method | SelectNextControl | Activates the next control. (inherited from Control)
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl)
Public method | SetBounds | Overloaded. Sets the bounds of the control. (inherited from Control)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (inherited from Form)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (inherited from Form)
Public method | Show | Overloaded. Displays the form. (inherited from Form)
Public method | ShowDialog | Overloaded. Shows the form as a modal dialog box. (inherited from Form)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control)
Public method | ToString | (inherited from Form)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control)
Public method | Validate | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl)
Public method | ValidateChildren | Overloaded. Validates all selectable child controls in the form. (inherited from Form)
Top

Protected Methods

 | Name | Description
Family method | AccessibilityNotifyClients | Overloaded. Notifies the accessibility client applications of AccessibleEvents. (inherited from Control)
Family method | ActivateMdiChild | Activates the MDI child of a form. (inherited from Form)
Family method | AdjustFormScrollbars | (inherited from Form)
Family method | ApplyAutoScaling | Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (inherited from Form)
Family method | CenterToParent | Centers the position of the form within the bounds of the parent form. (inherited from Form)
Family method | CenterToScreen | Centers the form on the current screen. (inherited from Form)
Family method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (inherited from Control)
Family method | CreateControlsInstance | (inherited from Form)
Family method | CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (inherited from Form)
Family method | DefWndProc | (inherited from Form)
Family method | DestroyHandle | Destroys the handle associated with the control. (inherited from Control)
Family method | Dispose | Overloaded. Releases the resources used by the form.
Family method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (inherited from Component)
Family method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (inherited from Control)
Family method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (inherited from Control)
Family method | GetScaledBounds | (inherited from Form)
Family method | GetScrollState | Determines whether the specified flag has been set. (inherited from ScrollableControl)
Family method | GetService | Returns an object that represents a service provided by the Component or by its Container. (inherited from Component)
Family method | GetStyle | Retrieves the value of the specified control style bit for the control. (inherited from Control)
Family method | GetTopLevel | Determines if the control is a top-level control. (inherited from Control)
Family method | InitLayout | Called after the control has been added to another container. (inherited from Control)
Family method | InvokeGotFocus | Raises the GotFocus event for the specified control. (inherited from Control)
Family method | InvokeLostFocus | Raises the LostFocus event for the specified control. (inherited from Control)
Family method | InvokeOnClick | Raises the Click event for the specified control. (inherited from Control)
Family method | InvokePaint | Raises the Paint event for the specified control. (inherited from Control)
Family method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (inherited from Control)
Family method | IsInputChar | Determines if a character is an input character that the control recognizes. (inherited from Control)
Family method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (inherited from Control)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (inherited from Control)
Family method | OnActivated | Raises the Activated event. (inherited from Form)
Family method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (inherited from Control)
Family method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (inherited from ContainerControl)
Family method | OnBackColorChanged | Raises the BackColorChanged event. (inherited from Control)
Family method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (inherited from Form)
Family method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (inherited from Form)
Family method | OnBindingContextChanged | Raises the BindingContextChanged event. (inherited from Control)
Family method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (inherited from Control)
Family method | OnChangeUICues | Raises the ChangeUICues event. (inherited from Control)
Family method | OnClick | Raises the Click event. (inherited from Control)
Family method | OnClientSizeChanged | Raises the ClientSizeChanged event. (inherited from Control)
Family method | OnClosed | Raises the Closed event. (inherited from Form)
Family method | OnClosing | Raises the Closing event. (inherited from Form)
Family method | OnContextMenuChanged | Raises the ContextMenuChanged event. (inherited from Control)
Family method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (inherited from Control)
Family method | OnControlAdded | Raises the ControlAdded event. (inherited from Control)
Family method | OnControlRemoved | Raises the ControlRemoved event. (inherited from Control)
Family method | OnCreateControl | Raises the CreateControl event. (inherited from Form)
Family method | OnCursorChanged | Raises the CursorChanged event. (inherited from Control)
Family method | OnDeactivate | Raises the Deactivate event. (inherited from Form)
Family method | OnDockChanged | Raises the DockChanged event. (inherited from Control)
Family method | OnDoubleClick | Raises the DoubleClick event. (inherited from Control)
Family method | OnDragDrop | Raises the DragDrop event. (inherited from Control)
Family method | OnDragEnter | Raises the DragEnter event. (inherited from Control)
Family method | OnDragLeave | Raises the DragLeave event. (inherited from Control)
Family method | OnDragOver | Raises the DragOver event. (inherited from Control)
Family method | OnEnabledChanged | (inherited from Form)
Family method | OnEnter | Raises the Enter event. (inherited from Form)
Family method | OnFontChanged | (inherited from Form)
Family method | OnForeColorChanged | Raises the ForeColorChanged event. (inherited from Control)
Family method | OnFormClosed | Raises the FormClosed event. (inherited from Form)
Family method | OnFormClosing | Raises the FormClosing event. (inherited from Form)
Family method | OnGiveFeedback | Raises the GiveFeedback event. (inherited from Control)
Family method | OnGotFocus | Raises the GotFocus event. (inherited from Control)
Family method | OnHandleCreated | (inherited from Form)
Family method | OnHandleDestroyed | (inherited from Form)
Family method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (inherited from Form)
Family method | OnHelpRequested | Raises the HelpRequested event. (inherited from Control)
Family method | OnImeModeChanged | Raises the ImeModeChanged event. (inherited from Control)
Family method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (inherited from Form)
Family method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (inherited from Form)
Family method | OnInvalidated | Raises the Invalidated event. (inherited from Control)
Family method | OnKeyDown | Raises the KeyDown event. (inherited from Control)
Family method | OnKeyPress | Raises the KeyPress event. (inherited from Control)
Family method | OnKeyUp | Raises the KeyUp event. (inherited from Control)
Family method | OnLayout | (inherited from Form)
Family method | OnLeave | Raises the Leave event. (inherited from Control)
Family method | OnLoad | Raises the Load event. (inherited from Form)
Family method | OnLocationChanged | Raises the LocationChanged event. (inherited from Control)
Family method | OnLostFocus | Raises the LostFocus event. (inherited from Control)
Family method | OnMarginChanged | Raises the MarginChanged event. (inherited from Control)
Family method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (inherited from Form)
Family method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (inherited from Form)
Family method | OnMdiChildActivate | Raises the MdiChildActivate event. (inherited from Form)
Family method | OnMenuComplete | Raises the MenuComplete event. (inherited from Form)
Family method | OnMenuStart | Raises the MenuStart event. (inherited from Form)
Family method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (inherited from Form)
Family method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (inherited from Control)
Family method | OnMouseClick | Raises the MouseClick event. (inherited from Control)
Family method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (inherited from Control)
Family method | OnMouseDown | Raises the MouseDown event. (inherited from Control)
Family method | OnMouseEnter | Raises the MouseEnter event. (inherited from Control)
Family method | OnMouseHover | Raises the MouseHover event. (inherited from Control)
Family method | OnMouseLeave | Raises the MouseLeave event. (inherited from Control)
Family method | OnMouseMove | Raises the MouseMove event. (inherited from Control)
Family method | OnMouseUp | Raises the MouseUp event. (inherited from Control)
Family method | OnMouseWheel | Raises the MouseWheel event. (inherited from ScrollableControl)
Family method | OnMove | Raises the Move event. (inherited from Control)
Family method | OnNotifyMessage | Notifies the control of Windows messages. (inherited from Control)
Family method | OnPaddingChanged | (inherited from ScrollableControl)
Family method | OnPaint | (inherited from Form)
Family method | OnPaintBackground | (inherited from ScrollableControl)
Family method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (inherited from Control)
Family method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (inherited from Control)
Family method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (inherited from Control)
Family method | OnParentChanged | (inherited from ContainerControl)
Family method | OnParentCursorChanged | Raises the CursorChanged event. (inherited from Control)
Family method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (inherited from Control)
Family method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (inherited from Control)
Family method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (inherited from Control)
Family method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (inherited from Control)
Family method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (inherited from Control)
Family method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (inherited from Control)
Family method | OnPrint | Raises the Paint event. (inherited from Control)
Family method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (inherited from Control)
Family method | OnRegionChanged | Raises the RegionChanged event. (inherited from Control)
Family method | OnResize | (inherited from Form)
Family method | OnResizeBegin | Raises the ResizeBegin event. (inherited from Form)
Family method | OnResizeEnd | Raises the ResizeEnd event. (inherited from Form)
Family method | OnRightToLeftChanged | (inherited from ScrollableControl)
Family method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (inherited from Form)
Family method | OnScroll | Raises the Scroll event. (inherited from ScrollableControl)
Family method | OnShown | Raises the Shown event. (inherited from Form)
Family method | OnSizeChanged | Raises the SizeChanged event. (inherited from Control)
Family method | OnStyleChanged | (inherited from Form)
Family method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (inherited from Control)
Family method | OnTabIndexChanged | Raises the TabIndexChanged event. (inherited from Control)
Family method | OnTabStopChanged | Raises the TabStopChanged event. (inherited from Control)
Family method | OnTextChanged | (inherited from Form)
Family method | OnValidated | Raises the Validated event. (inherited from Control)
Family method | OnValidating | Raises the Validating event. (inherited from Control)
Family method | OnVisibleChanged | Raises the VisibleChanged event. (inherited from Form)
Family method | ProcessCmdKey | Processes a command key. (inherited from Form)
Family method | ProcessDialogChar | (inherited from Form)
Family method | ProcessDialogKey | Processes a dialog key. (inherited from Form)
Family method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (inherited from Control)
Family method | ProcessKeyMessage | Processes a keyboard message. (inherited from Control)
Family method | ProcessKeyPreview | (inherited from Form)
Family method | ProcessMnemonic | (inherited from Form)
Family method | ProcessTabKey | (inherited from Form)
Family method | RaiseDragEvent | Raises the appropriate drag event. (inherited from Control)
Family method | RaiseKeyEvent | Raises the appropriate key event. (inherited from Control)
Family method | RaiseMouseEvent | Raises the appropriate mouse event. (inherited from Control)
Family method | RaisePaintEvent | Raises the appropriate paint event. (inherited from Control)
Family method | RecreateHandle | Forces the re-creation of the handle for the control. (inherited from Control)
Family method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (inherited from Control)
Family method | RtlTranslateAlignment | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text. (inherited from Control)
Family method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (inherited from Control)
Family method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (inherited from Control)
Family method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (inherited from Control)
Family method | ScaleControl | (inherited from Form)
Family method | ScaleCore | Base function that performs scaling of the form. (inherited from Form)
Family method | ScrollToControl | Calculates the scroll offset to the specified child control. (inherited from ScrollableControl)
Family method | Select | Overloaded. Activates the form and selects a child control. (inherited from Form)
Family method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (inherited from Control)
Family method | SetBoundsCore | (inherited from Form)
Family method | SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (inherited from Form)
Family method | SetDisplayRectLocation | Positions the display window to the specified value. (inherited from ScrollableControl)
Family method | SetScrollState | Sets the specified scroll state flag. (inherited from ScrollableControl)
Family method | SetStyle | Sets the specified style bit to the specified value. (inherited from Control)
Family method | SetTopLevel | Sets the control as the top-level control. (inherited from Control)
Family method | SetVisibleCore | (inherited from Form)
Family method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (inherited from Control)
Family method | UpdateBounds | Overloaded. Updates the bounds of the control. (inherited from Control)
Family method | UpdateDefaultButton | Updates which button is the default button. (inherited from Form)
Family method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (inherited from Control)
Family method | UpdateZOrder | Updates the control in its parent's z-order. (inherited from Control)
Family method | WndProc | (inherited from Form)
Top

Private Methods

 | Name | Description
Private method | btnBrowse_Click | Event Handler
Private method | btnOk_Click | Event Handler
Private method | InitializeComponent | Erforderliche Methode für die Designerunterstützung. Der Inhalt der Methode darf nicht mit dem Code-Editor geändert werden.
Private method | SaveImgDlg_FileOk | Event Handler
Top

Explicit Interface Implementations

Name | Description
System#Windows#Forms#IContainerControl#ActivateControl | Activates a specified control. (inherited from ContainerControl)
System#Windows#Forms#IDropTarget#OnDragDrop | Raises the DragDrop event. (inherited from Control)
System#Windows#Forms#IDropTarget#OnDragEnter | Raises the DragEnter event. (inherited from Control)
System#Windows#Forms#IDropTarget#OnDragLeave | Raises the DragLeave event. (inherited from Control)
System#Windows#Forms#IDropTarget#OnDragOver | Raises the DragOver event. (inherited from Control)
System#Windows#Forms#ISupportOleDropSource#OnGiveFeedback | (inherited from Control)
System#Windows#Forms#ISupportOleDropSource#OnQueryContinueDrag | (inherited from Control)
System#Windows#Forms#Layout#IArrangedElement#PerformLayout | (inherited from Control)
System#Windows#Forms#Layout#IArrangedElement#SetBounds | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleControl#FreezeEvents | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleControl#GetControlInfo | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleControl#OnAmbientPropertyChange | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleControl#OnMnemonic | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#ContextSensitiveHelp | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#EnableModeless | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#GetWindow | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#OnDocWindowActivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#OnFrameWindowActivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#ResizeBorder | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceActiveObject#TranslateAccelerator | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#ContextSensitiveHelp | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#GetWindow | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#InPlaceDeactivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#ReactivateAndUndo | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#SetObjectRects | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleInPlaceObject#UIDeactivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#Advise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#Close | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#DoVerb | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#EnumAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#EnumVerbs | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetClientSite | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetClipboardData | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetMiscStatus | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetMoniker | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetUserClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#GetUserType | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#InitFromData | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#IsUpToDate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#OleUpdate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetClientSite | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetColorScheme | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetHostNames | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#SetMoniker | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleObject#Unadvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleWindow#ContextSensitiveHelp | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IOleWindow#GetWindow | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersist#GetClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistPropertyBag#GetClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistPropertyBag#InitNew | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistPropertyBag#Load | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistPropertyBag#Save | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#GetClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#HandsOffStorage | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#InitNew | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#IsDirty | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#Load | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#Save | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStorage#SaveCompleted | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#GetClassID | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#GetSizeMax | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#InitNew | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#IsDirty | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#Load | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IPersistStreamInit#Save | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IQuickActivate#GetContentExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IQuickActivate#QuickActivate | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IQuickActivate#SetContentExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#Draw | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#Freeze | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#GetAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#GetColorSet | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#SetAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject#Unfreeze | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#Draw | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#Freeze | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#GetAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#GetColorSet | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#GetExtent | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#SetAdvise | (inherited from Control)
System#Windows#Forms#UnsafeNativeMethods#IViewObject2#Unfreeze | (inherited from Control)
Top

See Also

RenderingForm Class


btnBrowse_Click Method

RenderingForm.btnBrowse_Click Method
[image]

Event Handler

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private Sub btnBrowse_Click( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
C#
private void btnBrowse_Click(
object sender,
EventArgs e
)
C++
private:
void btnBrowse_Click(
Object sender,
EventArgs e
) sealed
J#
private void btnBrowse_Click(
object sender,
EventArgs e
)
JScript
private function btnBrowse_Click(
sender : Object,
e : EventArgs
)

See Also

RenderingForm Class


btnOk_Click Method

RenderingForm.btnOk_Click Method
[image]

Event Handler

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private Sub btnOk_Click( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
C#
private void btnOk_Click(
object sender,
EventArgs e
)
C++
private:
void btnOk_Click(
Object sender,
EventArgs e
) sealed
J#
private void btnOk_Click(
object sender,
EventArgs e
)
JScript
private function btnOk_Click(
sender : Object,
e : EventArgs
)

See Also

RenderingForm Class


Dispose Method

RenderingForm.Dispose Method

Releases the resources used by the form.

Overload List

 | Name | Description
Family method | Dispose (Boolean) | Overridden. Verwendete Ressourcen bereinigen.
Public method | Dispose | Releases all resources used by the Component. (inherited from Component)

See Also

RenderingForm Class


Dispose Method (Boolean)

RenderingForm.Dispose Method (Boolean)
See Also Example
[image]

Verwendete Ressourcen bereinigen.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

Parameters

disposing
True, wenn verwaltete Ressourcen gelöscht werden sollen; andernfalls False.

See Also

RenderingForm Class
Bsp1 Namespace
RenderingForm.Dispose Overload List


InitializeComponent Method

RenderingForm.InitializeComponent Method
[image]

Erforderliche Methode für die Designerunterstützung. Der Inhalt der Methode darf nicht mit dem Code-Editor geändert werden.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private Sub InitializeComponent()
C#
private void InitializeComponent()
C++
private:
void InitializeComponent() sealed
J#
private void InitializeComponent()
JScript
private function InitializeComponent()

See Also

RenderingForm Class


SaveImgDlg_FileOk Method

RenderingForm.SaveImgDlg_FileOk Method
[image]

Event Handler

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private Sub SaveImgDlg_FileOk( _
ByVal sender As Object, _
ByVal e As CancelEventArgs _
)
C#
private void SaveImgDlg_FileOk(
object sender,
CancelEventArgs e
)
C++
private:
void SaveImgDlg_FileOk(
Object sender,
CancelEventArgs e
) sealed
J#
private void SaveImgDlg_FileOk(
object sender,
CancelEventArgs e
)
JScript
private function SaveImgDlg_FileOk(
sender : Object,
e : CancelEventArgs
)

See Also

RenderingForm Class


Events

RenderingForm Events
[image]

Public Events

 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (inherited from Form)
Public event | AutoSizeChanged | (inherited from Form)
Public event | AutoValidateChanged | (inherited from Form)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control)
Public event | Click | Occurs when the control is clicked. (inherited from Control)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control)
Public event | Closed | Occurs when the form is closed. (inherited from Form)
Public event | Closing | Occurs when the form is closing. (inherited from Form)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control)
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control)
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (inherited from Form)
Public event | Disposed | Adds an event handler to listen to the Disposed event on the component. (inherited from Component)
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control)
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control)
Public event | Enter | Occurs when the control is entered. (inherited from Control)
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control)
Public event | FormClosed | Occurs after the form is closed. (inherited from Form)
Public event | FormClosing | Occurs before the form is closed. (inherited from Form)
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control)
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control)
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (inherited from Form)
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (inherited from Form)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (inherited from Form)
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control)
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control)
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control)
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control)
Public event | Load | Occurs before a form is displayed for the first time. (inherited from Form)
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control)
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control)
Public event | MarginChanged | (inherited from Form)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (inherited from Form)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (inherited from Form)
Public event | MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (inherited from Form)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (inherited from Form)
Public event | MenuStart | Occurs when the menu of a form receives focus. (inherited from Form)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (inherited from Form)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (inherited from Control)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control)
Public event | Move | Occurs when the control is moved. (inherited from Control)
Public event | OnOkClicked | Event Handler
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control)
Public event | Paint | Occurs when the control is redrawn. (inherited from Control)
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control)
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control)
Public event | Resize | Occurs when the control is resized. (inherited from Control)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (inherited from Form)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (inherited from Form)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (inherited from Form)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl)
Public event | Shown | Occurs whenever the form is first displayed. (inherited from Form)
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control)
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control)
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (inherited from Form)
Public event | TabStopChanged | (inherited from Form)
Public event | TextChanged | Occurs when the Text property value changes. (inherited from Control)
Public event | Validated | Occurs when the control is finished validating. (inherited from Control)
Public event | Validating | Occurs when the control is validating. (inherited from Control)
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control)
Top

See Also

RenderingForm Class


OnOkClicked Event

RenderingForm.OnOkClicked Event
[image]

Event Handler

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Event OnOkClicked As EventHandler
C#
public event EventHandler OnOkClicked
C++
public:
virtual event EventHandler OnOkClicked {
void add(EventHandler value) sealed ;
void remove(EventHandler value) sealed ;
}
J#
/** event */
public final void add_OnOkClicked(EventHandler value);

/** event */
public final void remove_OnOkClicked(EventHandler value);
JScript
JScript suports the use of events, but not the declaration of new ones.

See Also

RenderingForm Class


RenderMethodEnum Enumeration

RenderMethodEnum Enumeration
[image]

Enumeration used to determine how the data set should be rendered.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Enum RenderMethodEnum
C#
public enum RenderMethodEnum
C++
public enum class RenderMethodEnum
J#
public enum RenderMethodEnum
JScript
public enum RenderMethodEnum

Remarks

Enumeration used to determine how the data set should be rendered.

Members

Member Name | Description
Slice | Data set is rendered as Slice.
Raycast | Data set is rendered with depth compositing raycasting.
MaximumIntensity | Data set is rendered with maximum intensity raycasting.

See Also

Bsp1 Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.


SlicingPlaneEnum Enumeration

SlicingPlaneEnum Enumeration
[image]

Enumeration for possible Slicing Planes, used to determine where and how a slice should be drawn.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Enum SlicingPlaneEnum
C#
public enum SlicingPlaneEnum
C++
public enum class SlicingPlaneEnum
J#
public enum SlicingPlaneEnum
JScript
public enum SlicingPlaneEnum

Remarks

Enumeration for possible Slicing Planes, used to determine where and how a slice should be drawn.

Members

Member Name | Description
xPlane | The Slice is drawn as a plane perpendicular to the x axis.
yPlane | The Slice is drawn as a plane perpendicular to the y axis.
zPlane | The Slice is drawn as a plane perpendicular to the z axis.

See Also

Bsp1 Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.


TextureData Structure

TextureData Structure
See Also Example Members
[image]

Contains RGBA Values for creating the transfer texture.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Structure TextureData
C#
public struct TextureData
C++
value class TextureData
J#
public final class TextureData extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Remarks

Contains RGBA Values for creating the transfer texture.

Inheritance Hierarchy

System.Object
Bsp1.TextureData

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

TextureData Members


TextureData Members

TextureData Members
See Also Example Constructors Fields Methods
[image]

Contains RGBA Values for creating the transfer texture.

The following tables list the members exposed by TextureData.

Public Constructors

 | Name | Description
Public method | TextureData | TextureData standard constructor.
Top

Public Fields

 | Name | Description
Public field | A | Alpha
Public field | B | Blue
Public field | G | Green
Public field | R | Red
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

See Also

TextureData Structure


TextureData Constructor

TextureData Constructor
[image]

TextureData standard constructor.

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal red As Byte, _
ByVal green As Byte, _
ByVal blue As Byte, _
ByVal alpha As Byte _
)
C#
public TextureData(
byte red,
byte green,
byte blue,
byte alpha
)
C++
public:
TextureData(
char red,
char green,
char blue,
char alpha
) sealed
J#
public TextureData(
byte red,
byte green,
byte blue,
byte alpha
)
JScript
public function TextureData(
red : Byte,
green : Byte,
blue : Byte,
alpha : Byte
)

See Also

TextureData Structure


Fields

TextureData Fields
[image]

Public Fields

 | Name | Description
Public field | A | Alpha
Public field | B | Blue
Public field | G | Green
Public field | R | Red
Top

See Also

TextureData Structure


A Field

TextureData.A Field
[image]

Alpha

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public A As Byte
C#
public byte A;
C++
public:
char A sealed ;
J#
public byte A
JScript
public A : Byte;

See Also

TextureData Structure


B Field

TextureData.B Field
[image]

Blue

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public B As Byte
C#
public byte B;
C++
public:
char B sealed ;
J#
public byte B
JScript
public B : Byte;

See Also

TextureData Structure


G Field

TextureData.G Field
[image]

Green

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public G As Byte
C#
public byte G;
C++
public:
char G sealed ;
J#
public byte G
JScript
public G : Byte;

See Also

TextureData Structure


R Field

TextureData.R Field
[image]

Red

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public R As Byte
C#
public byte R;
C++
public:
char R sealed ;
J#
public byte R
JScript
public R : Byte;

See Also

TextureData Structure


UnsafeBitmap Class

UnsafeBitmap Class
See Also Example Members
[image]

This class is a wrapper around a normal Bitmap Class It writes much faster by streaming...

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Class UnsafeBitmap
C#
public class UnsafeBitmap
C++
ref class UnsafeBitmap
J#
public class UnsafeBitmap
JScript
public class UnsafeBitmap

Remarks

This class is a wrapper around a normal Bitmap Class It writes much faster by streaming...

Inheritance Hierarchy

System.Object
Bsp1.UnsafeBitmap

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UnsafeBitmap Members


UnsafeBitmap Members

UnsafeBitmap Members
See Also Example Fields Properties Methods Explicit Inteface Implementations
[image]

This class is a wrapper around a normal Bitmap Class It writes much faster by streaming...

The following tables list the members exposed by UnsafeBitmap.

Public Constructors

Name | Description
UnsafeBitmap | Overloaded.
Top

Private Fields

 | Name | Description
Private field | bitmap | The Bitmap this UnsafeBitmap wraps around
Private field | bitmapData | Bitmap attributes
Private field | pBase | Pointer to first pixel of bitmap
Private field | savedSizeX | Bitmap Width
Private field | savedSizeY | Bitmap Height
Private field | width | Width
Top

Public Properties

 | Name | Description
Public property | Bitmap | Bitmap Getter
Top

Private Properties

 | Name | Description
Private property | PixelSize | returns size of one Pixel
Top

Public Methods

 | Name | Description
Public method | Dispose | Disposes the Bitmap
Public method | DrawLine | Overloaded. Draws a line using bresenham
Public method | DrawRect | Draws a rectangle
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPixel | returns a pixel at a certain position
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | LockBitmap | locks the bitmap for writing
Public method | PixelAt | returns pointer to Pixel Color
Public method | SetPixel | sets color of a certain pixel
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | UnlockBitmap | unlocks the Bitmap for writing
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
UnsafeBitmap | Overloaded.
Top

See Also

UnsafeBitmap Class


UnsafeBitmap Constructor

UnsafeBitmap Constructor

Overload List

 | Name | Description
Public method | UnsafeBitmap (Bitmap) | Default constructor
Public method | UnsafeBitmap (Int32, Int32) | second constructor, sets height and width

See Also

UnsafeBitmap Class


UnsafeBitmap Constructor (Bitmap)

UnsafeBitmap Constructor (Bitmap)
See Also Example
[image]

Default constructor

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal bitmap As Bitmap _
)
C#
public UnsafeBitmap(
Bitmap bitmap
)
C++
public:
UnsafeBitmap(
Bitmap bitmap
) sealed
J#
public UnsafeBitmap(
Bitmap bitmap
)
JScript
public function UnsafeBitmap(
bitmap : Bitmap
)

See Also

UnsafeBitmap Class
Bsp1 Namespace
UnsafeBitmap Constructor Overload List


UnsafeBitmap Constructor (Int32, Int32)

UnsafeBitmap Constructor (Int32, Int32)
See Also Example
[image]

second constructor, sets height and width

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal width As Integer, _
ByVal height As Integer _
)
C#
public UnsafeBitmap(
int width,
int height
)
C++
public:
UnsafeBitmap(
int width,
int height
) sealed
J#
public UnsafeBitmap(
int width,
int height
)
JScript
public function UnsafeBitmap(
width : int,
height : int
)

See Also

UnsafeBitmap Class
Bsp1 Namespace
UnsafeBitmap Constructor Overload List


Fields

UnsafeBitmap Fields
[image]

Private Fields

 | Name | Description
Private field | bitmap | The Bitmap this UnsafeBitmap wraps around
Private field | bitmapData | Bitmap attributes
Private field | pBase | Pointer to first pixel of bitmap
Private field | savedSizeX | Bitmap Width
Private field | savedSizeY | Bitmap Height
Private field | width | Width
Top

See Also

UnsafeBitmap Class


bitmap Field

UnsafeBitmap.bitmap Field
[image]

The Bitmap this UnsafeBitmap wraps around

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private bitmap As Bitmap
C#
private Bitmap bitmap;
C++
private:
Bitmap bitmap sealed ;
J#
private Bitmap bitmap
JScript
private bitmap : Bitmap;

See Also

UnsafeBitmap Class


bitmapData Field

UnsafeBitmap.bitmapData Field
[image]

Bitmap attributes

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private bitmapData As BitmapData
C#
private BitmapData bitmapData;
C++
private:
BitmapData bitmapData sealed ;
J#
private BitmapData bitmapData
JScript
private bitmapData : BitmapData;

See Also

UnsafeBitmap Class


pBase Field

UnsafeBitmap.pBase Field
[image]

Pointer to first pixel of bitmap

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Visual Basic does not support APIs that consume or return unsafe types.
C#
private byte* pBase;
C++
private:
char* pBase sealed ;
J#
Visual J# does not support APIs that consume or return unsafe types.
JScript
JScript does not support APIs that consume or return unsafe types.

See Also

UnsafeBitmap Class


savedSizeX Field

UnsafeBitmap.savedSizeX Field
[image]

Bitmap Width

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private savedSizeX As Integer
C#
private int savedSizeX;
C++
private:
int savedSizeX sealed ;
J#
private int savedSizeX
JScript
private savedSizeX : int;

See Also

UnsafeBitmap Class


savedSizeY Field

UnsafeBitmap.savedSizeY Field
[image]

Bitmap Height

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private savedSizeY As Integer
C#
private int savedSizeY;
C++
private:
int savedSizeY sealed ;
J#
private int savedSizeY
JScript
private savedSizeY : int;

See Also

UnsafeBitmap Class


width Field

UnsafeBitmap.width Field
[image]

Width

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private width As Integer
C#
private int width;
C++
private:
int width sealed ;
J#
private int width
JScript
private width : int;

See Also

UnsafeBitmap Class


Properties

UnsafeBitmap Properties
[image]

Public Properties

 | Name | Description
Public property | Bitmap | Bitmap Getter
Top

Private Properties

 | Name | Description
Private property | PixelSize | returns size of one Pixel
Top

See Also

UnsafeBitmap Class


Bitmap Property

UnsafeBitmap.Bitmap Property
[image]

Bitmap Getter

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bitmap As Bitmap
C#
public Bitmap Bitmap { get; }
C++
public property Bitmap Bitmap sealed {
Bitmap get();
}
J#
/** property */
public Bitmap get_Bitmap();
JScript
public function get Bitmap() : Bitmap

See Also

UnsafeBitmap Class


PixelSize Property

UnsafeBitmap.PixelSize Property
[image]

returns size of one Pixel

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Private ReadOnly Property PixelSize As Point
C#
private Point PixelSize { get; }
C++
private property Point PixelSize sealed {
Point get();
}
J#
/** property */
private Point get_PixelSize();
JScript
private function get PixelSize() : Point

See Also

UnsafeBitmap Class


Methods

UnsafeBitmap Methods
[image]

Public Methods

 | Name | Description
Public method | Dispose | Disposes the Bitmap
Public method | DrawLine | Overloaded. Draws a line using bresenham
Public method | DrawRect | Draws a rectangle
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPixel | returns a pixel at a certain position
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | LockBitmap | locks the bitmap for writing
Public method | PixelAt | returns pointer to Pixel Color
Public method | SetPixel | sets color of a certain pixel
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | UnlockBitmap | unlocks the Bitmap for writing
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

UnsafeBitmap Class


Dispose Method

UnsafeBitmap.Dispose Method
[image]

Disposes the Bitmap

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()
C++
public:
void Dispose() sealed
J#
public void Dispose()
JScript
public function Dispose()

See Also

UnsafeBitmap Class


DrawLine Method

UnsafeBitmap.DrawLine Method

Draws a line using bresenham

Overload List

 | Name | Description
Public method | DrawLine (Int32, Int32, Int32, Int32) | Draws a line using bresenham
Public method | DrawLine (Int32, Int32, Int32, Int32, PixelData) | Draws a line using bresenham with a certain color

See Also

UnsafeBitmap Class


DrawLine Method (Int32, Int32, Int32, Int32)

UnsafeBitmap.DrawLine Method (Int32, Int32, Int32, Int32)
See Also Example
[image]

Draws a line using bresenham

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub DrawLine( _
ByVal x1 As Integer, _
ByVal y1 As Integer, _
ByVal x2 As Integer, _
ByVal y2 As Integer _
)
C#
public void DrawLine(
int x1,
int y1,
int x2,
int y2
)
C++
public:
void DrawLine(
int x1,
int y1,
int x2,
int y2
) sealed
J#
public void DrawLine(
int x1,
int y1,
int x2,
int y2
)
JScript
public function DrawLine(
x1 : int,
y1 : int,
x2 : int,
y2 : int
)

See Also

UnsafeBitmap Class
Bsp1 Namespace
UnsafeBitmap.DrawLine Overload List


DrawLine Method (Int32, Int32, Int32, Int32, PixelData)

UnsafeBitmap.DrawLine Method (Int32, Int32, Int32, Int32, PixelData)
See Also Example
[image]

Draws a line using bresenham with a certain color

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub DrawLine( _
ByVal x1 As Integer, _
ByVal y1 As Integer, _
ByVal x2 As Integer, _
ByVal y2 As Integer, _
ByVal color As PixelData _
)
C#
public void DrawLine(
int x1,
int y1,
int x2,
int y2,
PixelData color
)
C++
public:
void DrawLine(
int x1,
int y1,
int x2,
int y2,
PixelData color
) sealed
J#
public void DrawLine(
int x1,
int y1,
int x2,
int y2,
PixelData color
)
JScript
public function DrawLine(
x1 : int,
y1 : int,
x2 : int,
y2 : int,
color : PixelData
)

See Also

UnsafeBitmap Class
Bsp1 Namespace
UnsafeBitmap.DrawLine Overload List


DrawRect Method

UnsafeBitmap.DrawRect Method
[image]

Draws a rectangle

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub DrawRect( _
ByVal x1 As Integer, _
ByVal y1 As Integer, _
ByVal x2 As Integer, _
ByVal y2 As Integer, _
ByVal color As PixelData _
)
C#
public void DrawRect(
int x1,
int y1,
int x2,
int y2,
PixelData color
)
C++
public:
void DrawRect(
int x1,
int y1,
int x2,
int y2,
PixelData color
) sealed
J#
public void DrawRect(
int x1,
int y1,
int x2,
int y2,
PixelData color
)
JScript
public function DrawRect(
x1 : int,
y1 : int,
x2 : int,
y2 : int,
color : PixelData
)

See Also

UnsafeBitmap Class


GetPixel Method

UnsafeBitmap.GetPixel Method
[image]

returns a pixel at a certain position

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Function GetPixel( _
ByVal x As Integer, _
ByVal y As Integer _
) As PixelData
C#
public PixelData GetPixel(
int x,
int y
)
C++
public:
PixelData GetPixel(
int x,
int y
) sealed
J#
public PixelData GetPixel(
int x,
int y
)
JScript
public function GetPixel(
x : int,
y : int
) : PixelData

See Also

UnsafeBitmap Class


LockBitmap Method

UnsafeBitmap.LockBitmap Method
[image]

locks the bitmap for writing

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub LockBitmap()
C#
public void LockBitmap()
C++
public:
void LockBitmap() sealed
J#
public void LockBitmap()
JScript
public function LockBitmap()

See Also

UnsafeBitmap Class


PixelAt Method

UnsafeBitmap.PixelAt Method
[image]

returns pointer to Pixel Color

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Visual Basic does not support APIs that consume or return unsafe types.
C#
public PixelData* PixelAt(
int x,
int y
)
C++
public:
PixelData* PixelAt(
int x,
int y
) sealed
J#
Visual J# does not support APIs that consume or return unsafe types.
JScript
JScript does not support APIs that consume or return unsafe types.

See Also

UnsafeBitmap Class


SetPixel Method

UnsafeBitmap.SetPixel Method
[image]

sets color of a certain pixel

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub SetPixel( _
ByVal x As Integer, _
ByVal y As Integer, _
ByVal color As PixelData _
)
C#
public void SetPixel(
int x,
int y,
PixelData color
)
C++
public:
void SetPixel(
int x,
int y,
PixelData color
) sealed
J#
public void SetPixel(
int x,
int y,
PixelData color
)
JScript
public function SetPixel(
x : int,
y : int,
color : PixelData
)

See Also

UnsafeBitmap Class


UnlockBitmap Method

UnsafeBitmap.UnlockBitmap Method
[image]

unlocks the Bitmap for writing

Namespace: Bsp1
Assembly: Bsp1 (in Bsp1.exe)

Syntax

Visual Basic (Declaration)
Public Sub UnlockBitmap()
C#
public void UnlockBitmap()
C++
public:
void UnlockBitmap() sealed
J#
public void UnlockBitmap()
JScript
public function UnlockBitmap()

See Also

UnsafeBitmap Class


Bsp1 Hierarchy

Bsp1 Hierarchy
System.Object
Bsp1.ColoredCube
Bsp1.RenderData
Bsp1.Renderer
Bsp1.UnsafeBitmap
System.MarshalByRefObject
System.ComponentModel.Component ---- System.ComponentModel.IComponent, System.IDisposable
System.Windows.Forms.Control ---- System.ComponentModel.ISynchronizeInvoke, System.Windows.Forms.IBindableComponent, System.Windows.Forms.IDropTarget, System.Windows.Forms.IWin32Window
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl ---- System.Windows.Forms.IContainerControl
System.Windows.Forms.Form
Bsp1.MainWindow
Bsp1.Progress
Bsp1.RenderingForm
System.ValueType
Bsp1.DensityLevels
Bsp1.PixelData
Bsp1.TextureData
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Bsp1.RenderMethodEnum
Bsp1.SlicingPlaneEnum

See Also

Bsp1 Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.


SDK Link Manager

NDoc Utilities
SDK Link Manager

SDK Link Namespace