Microsoft.Win32

An NDoc Documented Class Library

Microsoft.Win32 Namespace

Namespace hierarchy

Classes

Class | Description
CbtEventArgs |
HookEventArgs |
LocalCbtHook |
LocalWindowsHook |
MouseHook | A wrapper around the Mouse Hook API
MouseHookEventArgs | Contains the values passed by the MouseHook to the internal MouseProc, repackaged as .NET types

Delegates

Delegate | Description
LocalCbtHook.CbtEventHandler |
LocalWindowsHook.HookEventHandler |
LocalWindowsHook.HookProc |
MouseHookEventHandler | Delegate used when notifying clients of calls to the MouseProc

Enumerations

Enumeration | Description
CbtHookAction |
HitTestCode | .NET version of the Win32 API enum
HookType |


CbtEventArgs Class

For a list of all members of this type, see CbtEventArgs Members.

System.Object
EventArgs
CbtEventArgs

public class CbtEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Win32

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

CbtEventArgs Members | Microsoft.Win32 Namespace


CbtEventArgs Members

CbtEventArgs overview

Public Instance Constructors

CbtEventArgs Constructor Initializes a new instance of the CbtEventArgs class.

Public Instance Fields

ClassName
Handle
IsDialogWindow
Title

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CbtEventArgs Class | Microsoft.Win32 Namespace


CbtEventArgs Constructor

Initializes a new instance of the CbtEventArgs class.

public CbtEventArgs();

See Also

CbtEventArgs Class | Microsoft.Win32 Namespace


CbtEventArgs Fields

The fields of the CbtEventArgs class are listed below. For a complete list of CbtEventArgs class members, see the CbtEventArgs Members topic.

Public Instance Fields

ClassName
Handle
IsDialogWindow
Title

See Also

CbtEventArgs Class | Microsoft.Win32 Namespace


CbtEventArgs.ClassName Field

public String ClassName;

See Also

CbtEventArgs Class | Microsoft.Win32 Namespace


CbtEventArgs.Handle Field

public IntPtr Handle;

See Also

CbtEventArgs Class | Microsoft.Win32 Namespace


CbtEventArgs.IsDialogWindow Field

public Boolean IsDialogWindow;

See Also

CbtEventArgs Class | Microsoft.Win32 Namespace


CbtEventArgs.Title Field

public String Title;

See Also

CbtEventArgs Class | Microsoft.Win32 Namespace


CbtHookAction Enumeration

public enum CbtHookAction

Members

Member Name | Description
HCBT_MOVESIZE |
HCBT_MINMAX |
HCBT_QS |
HCBT_CREATEWND |
HCBT_DESTROYWND |
HCBT_ACTIVATE |
HCBT_CLICKSKIPPED |
HCBT_KEYSKIPPED |
HCBT_SYSCOMMAND |
HCBT_SETFOCUS |

Requirements

Namespace: Microsoft.Win32

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

Microsoft.Win32 Namespace


HitTestCode Enumeration

.NET version of the Win32 API enum

public enum HitTestCode

Members

Member Name | Description
HTERROR |
HTTRANSPARENT |
HTNOWHERE |
HTCLIENT |
HTCAPTION |
HTSYSMENU |
HTGROWBOX |
HTSIZE |
HTMENU |
HTHSCROLL |
HTVSCROLL |
HTMINBUTTON |
HTMAXBUTTON |
HTLEFT |
HTRIGHT |
HTTOP |
HTTOPLEFT |
HTTOPRIGHT |
HTBOTTOM |
HTBOTTOMLEFT |
HTBOTTOMRIGHT |
HTBORDER |
HTREDUCE |
HTZOOM |
HTSIZEFIRST |
HTSIZELAST |
HTOBJECT |
HTCLOSE |
HTHELP |

Requirements

Namespace: Microsoft.Win32

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

Microsoft.Win32 Namespace


HookEventArgs Class

For a list of all members of this type, see HookEventArgs Members.

System.Object
EventArgs
HookEventArgs

public class HookEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Win32

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

HookEventArgs Members | Microsoft.Win32 Namespace


HookEventArgs Members

HookEventArgs overview

Public Instance Constructors

HookEventArgs Constructor Initializes a new instance of the HookEventArgs class.

Public Instance Fields

HookCode
lParam
wParam

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HookEventArgs Class | Microsoft.Win32 Namespace


HookEventArgs Constructor

Initializes a new instance of the HookEventArgs class.

public HookEventArgs();

See Also

HookEventArgs Class | Microsoft.Win32 Namespace


HookEventArgs Fields

The fields of the HookEventArgs class are listed below. For a complete list of HookEventArgs class members, see the HookEventArgs Members topic.

Public Instance Fields

HookCode
lParam
wParam

See Also

HookEventArgs Class | Microsoft.Win32 Namespace


HookEventArgs.HookCode Field

public Int32 HookCode;

See Also

HookEventArgs Class | Microsoft.Win32 Namespace


HookEventArgs.lParam Field

public IntPtr lParam;

See Also

HookEventArgs Class | Microsoft.Win32 Namespace


HookEventArgs.wParam Field

public IntPtr wParam;

See Also

HookEventArgs Class | Microsoft.Win32 Namespace


HookType Enumeration

public enum HookType

Members

Member Name | Description
WH_JOURNALRECORD |
WH_JOURNALPLAYBACK |
WH_KEYBOARD |
WH_GETMESSAGE |
WH_CALLWNDPROC |
WH_CBT |
WH_SYSMSGFILTER |
WH_MOUSE |
WH_HARDWARE |
WH_DEBUG |
WH_SHELL |
WH_FOREGROUNDIDLE |
WH_CALLWNDPROCRET |
WH_KEYBOARD_LL |
WH_MOUSE_LL |

Requirements

Namespace: Microsoft.Win32

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

Microsoft.Win32 Namespace


LocalCbtHook Class

For a list of all members of this type, see LocalCbtHook Members.

System.Object
LocalWindowsHook
LocalCbtHook

public class LocalCbtHook : LocalWindowsHook

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Win32

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

LocalCbtHook Members | Microsoft.Win32 Namespace


LocalCbtHook Members

LocalCbtHook overview

Protected Static Methods

GetClassName
GetWindowText

Public Instance Constructors

LocalCbtHook Overloaded. Initializes a new instance of the LocalCbtHook class.

Public Instance Properties

IsInstalled (inherited from LocalWindowsHook)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Install (inherited from LocalWindowsHook) |
ToString (inherited from Object) | Returns a String that represents the current Object.
Uninstall (inherited from LocalWindowsHook) |

Public Instance Events

HookInvoked (inherited from LocalWindowsHook)
WindowActivated
WindowCreated
WindowDestroyed

Protected Instance Fields

m_class
m_filterFunc (inherited from LocalWindowsHook)
m_hhook (inherited from LocalWindowsHook)
m_hookType (inherited from LocalWindowsHook)
m_hwnd
m_isDialog
m_title

Protected Instance Methods

CoreHookProc (inherited from LocalWindowsHook) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnHookInvoked (inherited from LocalWindowsHook) |
OnWindowActivated |
OnWindowCreated |
OnWindowDestroyed |

See Also

LocalCbtHook Class | Microsoft.Win32 Namespace


LocalCbtHook Constructor

Initializes a new instance of the LocalCbtHook class.

Overload List

Initializes a new instance of the LocalCbtHook class.

public LocalCbtHook();

public LocalCbtHook(LocalWindowsHook.HookProc);

See Also

LocalCbtHook Class | Microsoft.Win32 Namespace


LocalCbtHook Constructor ()

Initializes a new instance of the LocalCbtHook class.

public LocalCbtHook();

See Also

LocalCbtHook Class | Microsoft.Win32 Namespace | LocalCbtHook Constructor Overload List


LocalCbtHook Constructor (HookProc)

public LocalCbtHook(
LocalWindowsHook.HookProc func
);

See Also

LocalCbtHook Class | Microsoft.Win32 Namespace | LocalCbtHook Constructor Overload List


LocalCbtHook Fields

The fields of the LocalCbtHook class are listed below. For a complete list of LocalCbtHook class members, see the LocalCbtHook Members topic.

Protected Instance Fields

m_class
m_filterFunc (inherited from LocalWindowsHook)
m_hhook (inherited from LocalWindowsHook)
m_hookType (inherited from LocalWindowsHook)
m_hwnd
m_isDialog
m_title

See Also

LocalCbtHook Class | Microsoft.Win32 Namespace


LocalCbtHook.m_class Field

protected String m_class;

See Also

LocalCbtHook Class | Microsoft.Win32 Namespace


LocalCbtHook.m_hwnd Field

protected IntPtr m_hwnd;

See Also

LocalCbtHook Class | Microsoft.Win32 Namespace


LocalCbtHook.m_isDialog Field

protected Boolean m_isDialog;

See Also

LocalCbtHook Class | Microsoft.Win32 Namespace


LocalCbtHook.m_title Field

protected String m_title;

See Also

LocalCbtHook Class | Microsoft.Win32 Namespace


LocalCbtHook Methods

The methods of the LocalCbtHook class are listed below. For a complete list of LocalCbtHook class members, see the LocalCbtHook Members topic.

Protected Static Methods

GetClassName
GetWindowText

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Install (inherited from LocalWindowsHook) |
ToString (inherited from Object) | Returns a String that represents the current Object.
Uninstall (inherited from LocalWindowsHook) |

Protected Instance Methods

CoreHookProc (inherited from LocalWindowsHook) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnHookInvoked (inherited from LocalWindowsHook) |
OnWindowActivated |
OnWindowCreated |
OnWindowDestroyed |

See Also

LocalCbtHook Class | Microsoft.Win32 Namespace


LocalCbtHook. Method

protected static int (
IntPtr hwnd,
StringBuilder lpClassName,
Int32 nMaxCount
);

See Also

LocalCbtHook Class | Microsoft.Win32 Namespace


LocalCbtHook. Method

protected static int (
IntPtr hwnd,
StringBuilder lpString,
Int32 nMaxCount
);

See Also

LocalCbtHook Class | Microsoft.Win32 Namespace


LocalCbtHook. Method

protected virtual void ();

See Also

LocalCbtHook Class | Microsoft.Win32 Namespace


LocalCbtHook Events

The events of the LocalCbtHook class are listed below. For a complete list of LocalCbtHook class members, see the LocalCbtHook Members topic.

Public Instance Events

HookInvoked (inherited from LocalWindowsHook)
WindowActivated
WindowCreated
WindowDestroyed

See Also

LocalCbtHook Class | Microsoft.Win32 Namespace


LocalCbtHook.LocalCbtHook.CbtEventHandler Event

public event WindowActivated;

See Also

LocalCbtHook Class | Microsoft.Win32 Namespace


LocalCbtHook.LocalCbtHook.CbtEventHandler Event

public event WindowCreated;

See Also

LocalCbtHook Class | Microsoft.Win32 Namespace


LocalCbtHook.LocalCbtHook.CbtEventHandler Event

public event WindowDestroyed;

See Also

LocalCbtHook Class | Microsoft.Win32 Namespace


LocalCbtHook.CbtEventHandler Delegate

public delegate void LocalCbtHook.CbtEventHandler(
Object sender,
CbtEventArgs e
);

Requirements

Namespace: Microsoft.Win32

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

Microsoft.Win32 Namespace


LocalWindowsHook Class

For a list of all members of this type, see LocalWindowsHook Members.

System.Object
LocalWindowsHook
LocalCbtHook
MouseHook

public class LocalWindowsHook

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Win32

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

LocalWindowsHook Members | Microsoft.Win32 Namespace


LocalWindowsHook Members

LocalWindowsHook overview

Protected Static Methods

CallNextHookEx
SetWindowsHookEx
UnhookWindowsHookEx

Public Instance Constructors

LocalWindowsHook Overloaded. Initializes a new instance of the LocalWindowsHook class.

Public Instance Properties

IsInstalled

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Install |
ToString (inherited from Object) | Returns a String that represents the current Object.
Uninstall |

Public Instance Events

HookInvoked

Protected Instance Fields

m_filterFunc
m_hhook
m_hookType

Protected Instance Methods

CoreHookProc |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnHookInvoked |

See Also

LocalWindowsHook Class | Microsoft.Win32 Namespace


LocalWindowsHook Constructor

Overload List

public LocalWindowsHook(HookType);

public LocalWindowsHook(HookType,LocalWindowsHook.HookProc);

See Also

LocalWindowsHook Class | Microsoft.Win32 Namespace


LocalWindowsHook Constructor (HookType)

public LocalWindowsHook(
HookType hook
);

See Also

LocalWindowsHook Class | Microsoft.Win32 Namespace | LocalWindowsHook Constructor Overload List


LocalWindowsHook Constructor (HookType, HookProc)

public LocalWindowsHook(
HookType hook,
LocalWindowsHook.HookProc func
);

See Also

LocalWindowsHook Class | Microsoft.Win32 Namespace | LocalWindowsHook Constructor Overload List


LocalWindowsHook Fields

The fields of the LocalWindowsHook class are listed below. For a complete list of LocalWindowsHook class members, see the LocalWindowsHook Members topic.

Protected Instance Fields

m_filterFunc
m_hhook
m_hookType

See Also

LocalWindowsHook Class | Microsoft.Win32 Namespace


LocalWindowsHook.m_filterFunc Field

protected LocalWindowsHook.HookProc m_filterFunc;

See Also

LocalWindowsHook Class | Microsoft.Win32 Namespace


LocalWindowsHook.m_hhook Field

protected IntPtr m_hhook;

See Also

LocalWindowsHook Class | Microsoft.Win32 Namespace


LocalWindowsHook.m_hookType Field

protected HookType m_hookType;

See Also

LocalWindowsHook Class | Microsoft.Win32 Namespace


LocalWindowsHook Properties

The properties of the LocalWindowsHook class are listed below. For a complete list of LocalWindowsHook class members, see the LocalWindowsHook Members topic.

Public Instance Properties

IsInstalled

See Also

LocalWindowsHook Class | Microsoft.Win32 Namespace


IsInstalled Property

An NDoc Documented Class Library

LocalWindowsHook.IsInstalled Property

public IsInstalled {get;}

See Also

LocalWindowsHook Class | Microsoft.Win32 Namespace


LocalWindowsHook Methods

The methods of the LocalWindowsHook class are listed below. For a complete list of LocalWindowsHook class members, see the LocalWindowsHook Members topic.

Protected Static Methods

CallNextHookEx
SetWindowsHookEx
UnhookWindowsHookEx

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Install |
ToString (inherited from Object) | Returns a String that represents the current Object.
Uninstall |

Protected Instance Methods

CoreHookProc |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnHookInvoked |

See Also

LocalWindowsHook Class | Microsoft.Win32 Namespace


LocalWindowsHook. Method

protected static int (
IntPtr hhook,
Int32 code,
IntPtr wParam,
IntPtr lParam
);

See Also

LocalWindowsHook Class | Microsoft.Win32 Namespace


LocalWindowsHook. Method

protected int (
Int32 code,
IntPtr wParam,
IntPtr lParam
);

See Also

LocalWindowsHook Class | Microsoft.Win32 Namespace


LocalWindowsHook. Method

public void ();

See Also

LocalWindowsHook Class | Microsoft.Win32 Namespace


LocalWindowsHook. Method

protected void (
HookEventArgs e
);

See Also

LocalWindowsHook Class | Microsoft.Win32 Namespace


LocalWindowsHook. Method

protected static IntPtr (
HookType code,
LocalWindowsHook.HookProc func,
IntPtr hInstance,
Int32 threadID
);

See Also

LocalWindowsHook Class | Microsoft.Win32 Namespace


LocalWindowsHook. Method

protected static int (
IntPtr hhook
);

See Also

LocalWindowsHook Class | Microsoft.Win32 Namespace


LocalWindowsHook Events

The events of the LocalWindowsHook class are listed below. For a complete list of LocalWindowsHook class members, see the LocalWindowsHook Members topic.

Public Instance Events

HookInvoked

See Also

LocalWindowsHook Class | Microsoft.Win32 Namespace


LocalWindowsHook.LocalWindowsHook.HookEventHandler Event

public event HookInvoked;

See Also

LocalWindowsHook Class | Microsoft.Win32 Namespace


LocalWindowsHook.HookEventHandler Delegate

public delegate void LocalWindowsHook.HookEventHandler(
Object sender,
HookEventArgs e
);

Requirements

Namespace: Microsoft.Win32

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

Microsoft.Win32 Namespace


LocalWindowsHook.HookProc Delegate

public delegate int LocalWindowsHook.HookProc(
Int32 code,
IntPtr wParam,
IntPtr lParam
);

Requirements

Namespace: Microsoft.Win32

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

Microsoft.Win32 Namespace


MouseHook Class

A wrapper around the Mouse Hook API

For a list of all members of this type, see MouseHook Members.

System.Object
LocalWindowsHook
MouseHook

public class MouseHook : LocalWindowsHook,

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Win32

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

MouseHook Members | Microsoft.Win32 Namespace


MouseHook Members

MouseHook overview

Public Instance Constructors

MouseHook Constructor This constructor does not AutoInstall istelf. Client code must call Install in order to begin receiving MouseEvents

Public Instance Properties

IsInstalled (inherited from LocalWindowsHook)

Public Instance Methods

Dispose | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Install (inherited from LocalWindowsHook) |
ToString (inherited from Object) | Returns a String that represents the current Object.
Uninstall (inherited from LocalWindowsHook) |

Public Instance Events

HookInvoked (inherited from LocalWindowsHook)
MouseDoubleClick
MouseDown
MouseMove
MouseUp

Protected Instance Fields

m_filterFunc (inherited from LocalWindowsHook)
m_hhook (inherited from LocalWindowsHook)
m_hookType (inherited from LocalWindowsHook)

Protected Instance Methods

CoreHookProc (inherited from LocalWindowsHook) |
Dispose | Overloaded.
Finalize |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
MouseProc | The callback passed to SetWindowsHookEx
OnHookInvoked (inherited from LocalWindowsHook) |
OnMouseDoubleClick |
OnMouseDown |
OnMouseMove |
OnMouseUp |

See Also

MouseHook Class | Microsoft.Win32 Namespace


MouseHook Constructor

This constructor does not AutoInstall istelf. Client code must call Install in order to begin receiving MouseEvents

public MouseHook();

See Also

MouseHook Class | Microsoft.Win32 Namespace


MouseHook Methods

The methods of the MouseHook class are listed below. For a complete list of MouseHook class members, see the MouseHook Members topic.

Public Instance Methods

Dispose | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Install (inherited from LocalWindowsHook) |
ToString (inherited from Object) | Returns a String that represents the current Object.
Uninstall (inherited from LocalWindowsHook) |

Protected Instance Methods

CoreHookProc (inherited from LocalWindowsHook) |
Dispose | Overloaded.
Finalize |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
MouseProc | The callback passed to SetWindowsHookEx
OnHookInvoked (inherited from LocalWindowsHook) |
OnMouseDoubleClick |
OnMouseDown |
OnMouseMove |
OnMouseUp |

See Also

MouseHook Class | Microsoft.Win32 Namespace


Method

An NDoc Documented Class Library

MouseHook. Method

Overload List

public void ();

protected void (Boolean);

See Also

MouseHook Class | Microsoft.Win32 Namespace


MouseHook. Method ()

public void ();

Implements

IDisposable.

See Also

MouseHook Class | Microsoft.Win32 Namespace | MouseHook. Overload List


MouseHook. Method (Boolean)

protected void (
Boolean disposing
);

See Also

MouseHook Class | Microsoft.Win32 Namespace | MouseHook. Overload List


MouseHook. Method

protected override void ();

See Also

MouseHook Class | Microsoft.Win32 Namespace


MouseHook. Method

The callback passed to SetWindowsHookEx

protected int (
Int32 code,
IntPtr wParam,
IntPtr lParam
);

Parameters

Int32
The action code passed from the hook chain
IntPtr
The mouse message being received
IntPtr
Message paramters

Return Value

return code to hook chain

See Also

MouseHook Class | Microsoft.Win32 Namespace


MouseHook. Method

protected void (
MouseHookEventArgs e
);

See Also

MouseHook Class | Microsoft.Win32 Namespace


MouseHook Events

The events of the MouseHook class are listed below. For a complete list of MouseHook class members, see the MouseHook Members topic.

Public Instance Events

HookInvoked (inherited from LocalWindowsHook)
MouseDoubleClick
MouseDown
MouseMove
MouseUp

See Also

MouseHook Class | Microsoft.Win32 Namespace


MouseHook.MouseHookEventHandler Event

public event MouseDoubleClick;

Event Data

The event handler receives an argument of type MouseHookEventArgs containing data related to this event. The following MouseHookEventArgs property provides information specific to this event.

Property | Description
IsNonClientArea | Did the event occur over a non-client area

See Also

MouseHook Class | Microsoft.Win32 Namespace


MouseHook.MouseHookEventHandler Event

public event MouseDown;

Event Data

The event handler receives an argument of type MouseHookEventArgs containing data related to this event. The following MouseHookEventArgs property provides information specific to this event.

Property | Description
IsNonClientArea | Did the event occur over a non-client area

See Also

MouseHook Class | Microsoft.Win32 Namespace


MouseHook.MouseHookEventHandler Event

public event MouseMove;

Event Data

The event handler receives an argument of type MouseHookEventArgs containing data related to this event. The following MouseHookEventArgs property provides information specific to this event.

Property | Description
IsNonClientArea | Did the event occur over a non-client area

See Also

MouseHook Class | Microsoft.Win32 Namespace


MouseHook.MouseHookEventHandler Event

public event MouseUp;

Event Data

The event handler receives an argument of type MouseHookEventArgs containing data related to this event. The following MouseHookEventArgs property provides information specific to this event.

Property | Description
IsNonClientArea | Did the event occur over a non-client area

See Also

MouseHook Class | Microsoft.Win32 Namespace


MouseHookEventArgs Class

Contains the values passed by the MouseHook to the internal MouseProc, repackaged as .NET types

For a list of all members of this type, see MouseHookEventArgs Members.

System.Object
MouseHookEventArgs

public class MouseHookEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Win32

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

MouseHookEventArgs Members | Microsoft.Win32 Namespace


MouseHookEventArgs Members

MouseHookEventArgs overview

Public Instance Constructors

MouseHookEventArgs Constructor

Public Instance Fields

Button | The button that is associated with the event
Control | The control that will ultimately receive the hooked message
HitTestCode | The window area that the mouse is over
X | The X location of the mouse when the event occured
Y | The Y location of the mouse when the event occured

Public Instance Properties

IsNonClientArea Did the event occur over a non-client area

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MouseHookEventArgs Class | Microsoft.Win32 Namespace


MouseHookEventArgs Constructor

public MouseHookEventArgs(
MouseButtons button,
Int32 x,
Int32 y,
Control control,
HitTestCode hitTestCode
);

See Also

MouseHookEventArgs Class | Microsoft.Win32 Namespace


MouseHookEventArgs Fields

The fields of the MouseHookEventArgs class are listed below. For a complete list of MouseHookEventArgs class members, see the MouseHookEventArgs Members topic.

Public Instance Fields

Button | The button that is associated with the event
Control | The control that will ultimately receive the hooked message
HitTestCode | The window area that the mouse is over
X | The X location of the mouse when the event occured
Y | The Y location of the mouse when the event occured

See Also

MouseHookEventArgs Class | Microsoft.Win32 Namespace


MouseHookEventArgs.Button Field

The button that is associated with the event

public readonly MouseButtons Button;

See Also

MouseHookEventArgs Class | Microsoft.Win32 Namespace


MouseHookEventArgs.Control Field

The control that will ultimately receive the hooked message

public readonly Control Control;

See Also

MouseHookEventArgs Class | Microsoft.Win32 Namespace


MouseHookEventArgs.HitTestCode Field

The window area that the mouse is over

public readonly HitTestCode HitTestCode;

See Also

MouseHookEventArgs Class | Microsoft.Win32 Namespace


MouseHookEventArgs.X Field

The X location of the mouse when the event occured

public readonly Int32 X;

See Also

MouseHookEventArgs Class | Microsoft.Win32 Namespace


MouseHookEventArgs.Y Field

The Y location of the mouse when the event occured

public readonly Int32 Y;

See Also

MouseHookEventArgs Class | Microsoft.Win32 Namespace


MouseHookEventArgs Properties

The properties of the MouseHookEventArgs class are listed below. For a complete list of MouseHookEventArgs class members, see the MouseHookEventArgs Members topic.

Public Instance Properties

IsNonClientArea Did the event occur over a non-client area

See Also

MouseHookEventArgs Class | Microsoft.Win32 Namespace


IsNonClientArea Property

An NDoc Documented Class Library

MouseHookEventArgs.IsNonClientArea Property

Did the event occur over a non-client area

public IsNonClientArea {get;}

See Also

MouseHookEventArgs Class | Microsoft.Win32 Namespace


MouseHookEventHandler Delegate

Delegate used when notifying clients of calls to the MouseProc

public delegate void MouseHookEventHandler(
Object sender,
MouseHookEventArgs e
);

Requirements

Namespace: Microsoft.Win32

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

Microsoft.Win32 Namespace


SpringEmbedders

An NDoc Documented Class Library

SpringEmbedders Namespace

Namespace hierarchy

Classes

Class | Description
Camera | Camera class
Complex | Class for complex numbers
DynamicVB | An abstraction of a vertex buffer to simplify rendering of dynamic data. Internal it creates a dynamic wirteonly vertexbuffer. When a lock call comes a locked stream of the demanded size is returned. Thereby the there is enough space left the buffer is locked with nooverride continuing after the last locked segment. When the size exceeds the buffer is dicarded and when the size is even bigger than the buffer, a bigger buffer is created.
Graph | Class for the graph
Graph.Edge | Class Edge
Graph.Node | Class for nodes.
GraphEdit | Class for the GraphEdit UI
GraphInfo | Class for GraphInfo UI
GraphViewer | Graphviewer Form Class
GroupBoxDrop | The general user control in the GroupBoxDropContainer
GroupBoxDropContainer | Container for the GroupDropBoxes
NodeDlg | Dialog that shows the properties of a node
OffscreenRT | A rendertarget with an assoziated offscreen surface and functions to access its data easily.
SaveDlg | Save Dialog.
SimulationParameters | Layout simulation parameters.
VisualParameters | Parameters to draw the graph

Enumerations

Enumeration | Description
Graph.LayoutType | Specifies the possible layout types.


Camera Class

Camera class

For a list of all members of this type, see Camera Members.

System.Object
Camera

public class Camera

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SpringEmbedders

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

Camera Members | SpringEmbedders Namespace


Camera Members

Camera overview

Public Instance Constructors

Camera Constructor Camera Constructor

Public Instance Properties

Far | Far Plane
Near | Near Plane
Position | Vector3 for the position of the camera
Proj | Projection Matrix
Rotation | Quaternion for the rotation
View | Viewmatrix
ViewDir | Vector3 for View direction
ViewRight | Vector3 for View right
ViewUp | Vector3 for View up
YawPitchRoll | Get Vector3 for yaw, pitch and roll

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
flip | Flips the camera Right/Left
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
lookAt | Creates a LookAtMatrix from target and upvector using the current camera position
move | Moves the camera in the world coordinate system
moveOriented | Moves the camera in the camera coordinate system
orthoProj | Creates a Orthogonal Projection
perspectiveProj | Creates a perspective Projection for the camera
perspectiveProjEx | Perspectives a perspective projection for the camera.
perspectiveProjFov | Perspectives a perspective projection for the camera.
reset | Resets the camera position to the origin
rotate | Rotates around the world XYZ Axis
rotateOriented | Rotates around the camera XYZ Axis
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Camera Class | SpringEmbedders Namespace


Camera Constructor

Camera Constructor

public Camera();

See Also

Camera Class | SpringEmbedders Namespace


Camera Properties

The properties of the Camera class are listed below. For a complete list of Camera class members, see the Camera Members topic.

Public Instance Properties

Far | Far Plane
Near | Near Plane
Position | Vector3 for the position of the camera
Proj | Projection Matrix
Rotation | Quaternion for the rotation
View | Viewmatrix
ViewDir | Vector3 for View direction
ViewRight | Vector3 for View right
ViewUp | Vector3 for View up
YawPitchRoll | Get Vector3 for yaw, pitch and roll

See Also

Camera Class | SpringEmbedders Namespace


Far Property

An NDoc Documented Class Library

Camera.Far Property

Far Plane

public Far {get;}

Parameters

See Also

Camera Class | SpringEmbedders Namespace


Near Property

An NDoc Documented Class Library

Camera.Near Property

Near Plane

public Near {get;}

Parameters

See Also

Camera Class | SpringEmbedders Namespace


Position Property

An NDoc Documented Class Library

Camera.Position Property

Vector3 for the position of the camera

public Position {get; set;}

Parameters

Property Value

The position.

See Also

Camera Class | SpringEmbedders Namespace


Proj Property

An NDoc Documented Class Library

Camera.Proj Property

Projection Matrix

public Proj {get; set;}

Parameters

See Also

Camera Class | SpringEmbedders Namespace


Rotation Property

An NDoc Documented Class Library

Camera.Rotation Property

Quaternion for the rotation

public Rotation {get; set;}

Parameters

Property Value

The rotation.

See Also

Camera Class | SpringEmbedders Namespace


View Property

An NDoc Documented Class Library

Camera.View Property

Viewmatrix

public View {get; set;}

Parameters

See Also

Camera Class | SpringEmbedders Namespace


ViewDir Property

An NDoc Documented Class Library

Camera.ViewDir Property

Vector3 for View direction

public ViewDir {get;}

Parameters

See Also

Camera Class | SpringEmbedders Namespace


ViewRight Property

An NDoc Documented Class Library

Camera.ViewRight Property

Vector3 for View right

public ViewRight {get;}

Parameters

See Also

Camera Class | SpringEmbedders Namespace


ViewUp Property

An NDoc Documented Class Library

Camera.ViewUp Property

Vector3 for View up

public ViewUp {get;}

Parameters

See Also

Camera Class | SpringEmbedders Namespace


YawPitchRoll Property

An NDoc Documented Class Library

Camera.YawPitchRoll Property

Get Vector3 for yaw, pitch and roll

public YawPitchRoll {get;}

Parameters

See Also

Camera Class | SpringEmbedders Namespace


Camera Methods

The methods of the Camera class are listed below. For a complete list of Camera class members, see the Camera Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
flip | Flips the camera Right/Left
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
lookAt | Creates a LookAtMatrix from target and upvector using the current camera position
move | Moves the camera in the world coordinate system
moveOriented | Moves the camera in the camera coordinate system
orthoProj | Creates a Orthogonal Projection
perspectiveProj | Creates a perspective Projection for the camera
perspectiveProjEx | Perspectives a perspective projection for the camera.
perspectiveProjFov | Perspectives a perspective projection for the camera.
reset | Resets the camera position to the origin
rotate | Rotates around the world XYZ Axis
rotateOriented | Rotates around the camera XYZ Axis
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Camera Class | SpringEmbedders Namespace


Camera. Method

Flips the camera Right/Left

public void ();

See Also

Camera Class | SpringEmbedders Namespace


Camera. Method

Creates a LookAtMatrix from target and upvector using the current camera position

public void (
Vector3 target,
Vector3 up
);

Parameters

Vector3
The target.
Vector3
The up vector.

See Also

Camera Class | SpringEmbedders Namespace


Camera. Method

Moves the camera in the world coordinate system

public void (
Vector3 dp
);

Parameters

Vector3
The offset.

See Also

Camera Class | SpringEmbedders Namespace


Camera. Method

Moves the camera in the camera coordinate system

public void (
Vector3 dp
);

Parameters

Vector3
The offset.

See Also

Camera Class | SpringEmbedders Namespace


Camera. Method

Creates a Orthogonal Projection

public void (
Single widht,
Single height,
Single near,
Single far
);

Parameters

Single
The widht.
Single
The height.
Single
The near plane distance.
Single
The far plane distance.

See Also

Camera Class | SpringEmbedders Namespace


Camera. Method

Creates a perspective Projection for the camera

public void (
Single width,
Single height,
Single near,
Single far
);

Parameters

Single
The width.
Single
The height.
Single
The near plane distance.
Single
The far plane distance.

See Also

Camera Class | SpringEmbedders Namespace


Camera. Method

Perspectives a perspective projection for the camera.

public void (
Single widht,
Single height,
Single near,
Single far
);

Parameters

Single
The widht.
Single
The height.
Single
The near plane distance.
Single
The far plane distance.

See Also

Camera Class | SpringEmbedders Namespace


Camera. Method

Perspectives a perspective projection for the camera.

public void (
Single fovy,
Single aspect,
Single near,
Single far
);

Parameters

Single
The fovy.
Single
The aspect ratio.
Single
The near plane distance.
Single
The far plane distance.

See Also

Camera Class | SpringEmbedders Namespace


Camera. Method

Resets the camera position to the origin

public void ();

See Also

Camera Class | SpringEmbedders Namespace


Camera. Method

Rotates around the world XYZ Axis

public void (
Vector3 ang
);

Parameters

Vector3
The angle

See Also

Camera Class | SpringEmbedders Namespace


Camera. Method

Rotates around the camera XYZ Axis

public void (
Vector3 ang
);

Parameters

Vector3
The angle

See Also

Camera Class | SpringEmbedders Namespace


Complex Class

Class for complex numbers

For a list of all members of this type, see Complex Members.

System.Object
Complex

public class Complex

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SpringEmbedders

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

Complex Members | SpringEmbedders Namespace


Complex Members

Complex overview

Public Static Methods

Abs | Returns the absolut value of a complex number.
Conj | The conjugation of a complex number.

Public Static Operators

Addition Operator | Implements the operator +.
Division Operator | Implements the operator /.
Multiplication Operator | Overloaded. Implements the operator *.
Subtraction Operator | Implements the operator -.
Unary Negation Operator | Implements the operator -.

Public Instance Constructors

Complex Constructor Initializes a new instance of the Complex class.

Public Instance Properties

Imag | Gets or sets the imaginary part.
Real | Gets or sets the real part.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Complex Class | SpringEmbedders Namespace


Complex Constructor

Initializes a new instance of the Complex class.

public Complex(
Single real,
Single imag
);

Parameters

Single
The real part.
Single
The imaginary part.

See Also

Complex Class | SpringEmbedders Namespace


Complex Properties

The properties of the Complex class are listed below. For a complete list of Complex class members, see the Complex Members topic.

Public Instance Properties

Imag | Gets or sets the imaginary part.
Real | Gets or sets the real part.

See Also

Complex Class | SpringEmbedders Namespace


Imag Property

An NDoc Documented Class Library

Complex.Imag Property

Gets or sets the imaginary part.

public Imag {get; set;}

Property Value

The imag.

See Also

Complex Class | SpringEmbedders Namespace


Real Property

An NDoc Documented Class Library

Complex.Real Property

Gets or sets the real part.

public Real {get; set;}

Property Value

The real.

See Also

Complex Class | SpringEmbedders Namespace


Complex Methods

The methods of the Complex class are listed below. For a complete list of Complex class members, see the Complex Members topic.

Public Static Methods

Abs | Returns the absolut value of a complex number.
Conj | The conjugation of a complex number.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Complex Class | SpringEmbedders Namespace


Complex. Method

Returns the absolut value of a complex number.

public static float (
Complex c
);

Parameters

Complex
The complex number.

Return Value

Absolut value.

See Also

Complex Class | SpringEmbedders Namespace


Complex. Method

The conjugation of a complex number.

public static Complex (
Complex c
);

Parameters

Complex
The complex number.

Return Value

Conjugated complex number.

See Also

Complex Class | SpringEmbedders Namespace


Complex Operators

The operators of the Complex class are listed below. For a complete list of Complex class members, see the Complex Members topic.

Public Static Operators

Addition Operator | Implements the operator +.
Division Operator | Implements the operator /.
Multiplication Operator | Overloaded. Implements the operator *.
Subtraction Operator | Implements the operator -.
Unary Negation Operator | Implements the operator -.

See Also

Complex Class | Complex Members | SpringEmbedders Namespace


Complex Addition Operator

Implements the operator +.

public static Complex operator +(
Complex left,
Complex right
);

Parameters

Complex
The left operand.
Complex
The right operand.

Return Value

The result of the operator.

See Also

Complex Class | SpringEmbedders Namespace


Complex Division Operator

Implements the operator /.

public static Complex operator /(
Complex z,
Complex n
);

Parameters

Complex
The dividend.
Complex
The divisor.

Return Value

The result of the operator.

See Also

Complex Class | SpringEmbedders Namespace


Complex Multiplication Operator

Implements the operator *.

Overload List

Implements the operator *.

public static Complex Multiplication Operator(Complex,Complex);

Implements the operator *.

public static Complex Multiplication Operator(Complex,Single);

Implements the operator *.

public static Complex Multiplication Operator(Single,Complex);

See Also

Complex Class | SpringEmbedders Namespace


Complex Multiplication Operator

Implements the operator *.

public static Complex operator *(
Complex left,
Complex right
);

Parameters

Complex
The left operand.
Complex
The right operand.

Return Value

The result of the operator.

See Also

Complex Class | SpringEmbedders Namespace | ComplexMultiplication Operator Overload List


Complex Multiplication Operator

Implements the operator *.

public static Complex operator *(
Complex left,
Single right
);

Parameters

Complex
The left operand.
Single
The right operand.

Return Value

The result of the operator.

See Also

Complex Class | SpringEmbedders Namespace | ComplexMultiplication Operator Overload List


Complex Multiplication Operator

Implements the operator *.

public static Complex operator *(
Single left,
Complex right
);

Parameters

Single
The left operand.
Complex
The right operand.

Return Value

The result of the operator.

See Also

Complex Class | SpringEmbedders Namespace | ComplexMultiplication Operator Overload List


Complex Subtraction Operator

Implements the operator -.

public static Complex operator -(
Complex left,
Complex right
);

Parameters

Complex
The left operand.
Complex
The right operand.

Return Value

The result of the operator.

See Also

Complex Class | SpringEmbedders Namespace


Complex Unary Negation Operator

Implements the operator -.

public static Complex operator -(
Complex c
);

Parameters

Complex
The complex number.

Return Value

The inverse complex number.

See Also

Complex Class | SpringEmbedders Namespace


DynamicVB Class

An abstraction of a vertex buffer to simplify rendering of dynamic data. Internal it creates a dynamic wirteonly vertexbuffer. When a lock call comes a locked stream of the demanded size is returned. Thereby the there is enough space left the buffer is locked with nooverride continuing after the last locked segment. When the size exceeds the buffer is dicarded and when the size is even bigger than the buffer, a bigger buffer is created.

For a list of all members of this type, see DynamicVB Members.

System.Object
DynamicVB

public class DynamicVB

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SpringEmbedders

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

DynamicVB Members | SpringEmbedders Namespace


DynamicVB Members

DynamicVB overview

Public Instance Constructors

DynamicVB Constructor Initializes a new instance of the DynamicVB class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Lock | Locks the VB for a certain size of data.
SetVBStream | Binds the VB to a vertex stream and automatically sets the offset from the last lock.
ToString (inherited from Object) | Returns a String that represents the current Object.
Unlock | Unlocks the VB.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DynamicVB Class | SpringEmbedders Namespace


DynamicVB Constructor

Initializes a new instance of the DynamicVB class.

public DynamicVB(
Device device,
Int32 nSize
);

Parameters

Device
The device.
Int32
Size of the initial buffer in bytes.

See Also

DynamicVB Class | SpringEmbedders Namespace


DynamicVB Methods

The methods of the DynamicVB class are listed below. For a complete list of DynamicVB class members, see the DynamicVB Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Lock | Locks the VB for a certain size of data.
SetVBStream | Binds the VB to a vertex stream and automatically sets the offset from the last lock.
ToString (inherited from Object) | Returns a String that represents the current Object.
Unlock | Unlocks the VB.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DynamicVB Class | SpringEmbedders Namespace


DynamicVB. Method

Locks the VB for a certain size of data.

public GraphicsStream (
Int32 nSize
);

Parameters

Int32

Return Value

The stream of the locked data.

See Also

DynamicVB Class | SpringEmbedders Namespace


DynamicVB. Method

Binds the VB to a vertex stream and automatically sets the offset from the last lock.

public void (
Int32 nStride,
Int32 nStream
);

Parameters

Int32
The stride of a vertex.
Int32
The index of the stream.

See Also

DynamicVB Class | SpringEmbedders Namespace


DynamicVB. Method

Unlocks the VB.

public void ();

Parameters

Return Value

See Also

DynamicVB Class | SpringEmbedders Namespace


Graph Class

Class for the graph

For a list of all members of this type, see Graph Members.

System.Object
Graph

public class Graph

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SpringEmbedders

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

Graph Members | SpringEmbedders Namespace


Graph Members

Graph overview

Public Instance Constructors

Graph Constructor Constructor

Public Instance Properties

FX | Gets the Shader Effect.
HyperbolicCenter | Gets or sets the center for the hyperbolic layout.
InfoViewer | Gets or sets the graph info viewer.
Layout | Gets and sets Layout
Simulation | Gets or sets the simulation parameters.
Visual | Gets or sets the visual parameters.

Public Instance Methods

addEdge | Adds edges to current layout
addNode | Adds notes to current layout
clear | Clears the graph.
delSel | Deletes Selection
draw | Draws all (edges, nodes, layout)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
open | Opens a graph from a file.
pickCoord | Returns Coordinates for picking
pickEdge | Picks the edge under the cursor [Not implemented].
pickNode | Picks node where mosue is pointing.
projectNode | Projects a node to screen coordinates.
pullNode | Apply pulling for nodes
randomizePos | Randomizes the positions of the nodes.
save | Saves the graph to a file.
scroll | Scroll on layout
selectNode | Select node
selRect | Creates rectangle for selection (delete)
ToString (inherited from Object) | Returns a String that represents the current Object.
unselect | Unselection all nodes
updateLayout | Updates the layout.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Graph Class | SpringEmbedders Namespace


Graph Constructor

Constructor

public Graph(
Device dv
);

Parameters

Device
Device

Return Value

See Also

Graph Class | SpringEmbedders Namespace


Graph Properties

The properties of the Graph class are listed below. For a complete list of Graph class members, see the Graph Members topic.

Public Instance Properties

FX | Gets the Shader Effect.
HyperbolicCenter | Gets or sets the center for the hyperbolic layout.
InfoViewer | Gets or sets the graph info viewer.
Layout | Gets and sets Layout
Simulation | Gets or sets the simulation parameters.
Visual | Gets or sets the visual parameters.

See Also

Graph Class | SpringEmbedders Namespace


FX Property

An NDoc Documented Class Library

Graph.FX Property

Gets the Shader Effect.

public FX {get;}

Property Value

The FX.

See Also

Graph Class | SpringEmbedders Namespace


HyperbolicCenter Property

An NDoc Documented Class Library

Graph.HyperbolicCenter Property

Gets or sets the center for the hyperbolic layout.

public HyperbolicCenter {get; set;}

Property Value

The hyperbolic center.

See Also

Graph Class | SpringEmbedders Namespace


InfoViewer Property

An NDoc Documented Class Library

Graph.InfoViewer Property

Gets or sets the graph info viewer.

public InfoViewer {get; set;}

Property Value

The info viewer drop box.

See Also

Graph Class | SpringEmbedders Namespace


Layout Property

An NDoc Documented Class Library

Graph.Layout Property

Gets and sets Layout

public Layout {get; set;}

See Also

Graph Class | SpringEmbedders Namespace


Simulation Property

An NDoc Documented Class Library

Graph.Simulation Property

Gets or sets the simulation parameters.

public Simulation {get; set;}

Property Value

The simulation parameters drop box.

See Also

Graph Class | SpringEmbedders Namespace


Visual Property

An NDoc Documented Class Library

Graph.Visual Property

Gets or sets the visual parameters.

public Visual {get; set;}

Property Value

The visual parameters drop box.

See Also

Graph Class | SpringEmbedders Namespace


Graph Methods

The methods of the Graph class are listed below. For a complete list of Graph class members, see the Graph Members topic.

Public Instance Methods

addEdge | Adds edges to current layout
addNode | Adds notes to current layout
clear | Clears the graph.
delSel | Deletes Selection
draw | Draws all (edges, nodes, layout)
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
open | Opens a graph from a file.
pickCoord | Returns Coordinates for picking
pickEdge | Picks the edge under the cursor [Not implemented].
pickNode | Picks node where mosue is pointing.
projectNode | Projects a node to screen coordinates.
pullNode | Apply pulling for nodes
randomizePos | Randomizes the positions of the nodes.
save | Saves the graph to a file.
scroll | Scroll on layout
selectNode | Select node
selRect | Creates rectangle for selection (delete)
ToString (inherited from Object) | Returns a String that represents the current Object.
unselect | Unselection all nodes
updateLayout | Updates the layout.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Graph Class | SpringEmbedders Namespace


Graph. Method

Adds edges to current layout

public void (
Graph.Edge e
);

Parameters

Graph.Edge
Edge

See Also

Graph Class | SpringEmbedders Namespace


Graph. Method

Adds notes to current layout

public void (
Graph.Node node
);

Parameters

Graph.Node
Node

See Also

Graph Class | SpringEmbedders Namespace


Graph. Method

Clears the graph.

public void ();

See Also

Graph Class | SpringEmbedders Namespace


Graph. Method

Deletes Selection

public void ();

See Also

Graph Class | SpringEmbedders Namespace


Graph. Method

Draws all (edges, nodes, layout)

public void (
Camera cam
);

Parameters

Camera
Camera

Return Value

Vector 3

See Also

Graph Class | SpringEmbedders Namespace


Graph. Method

Opens a graph from a file.

public void (
String fn
);

Parameters

String
The filename.

See Also

Graph Class | SpringEmbedders Namespace


Graph. Method

Returns Coordinates for picking

public Vector2 (
Point mauspos,
Camera cam
);

Parameters

Point
The mouse position.
Camera
The camera.

Return Value

Vector2

See Also

Graph Class | SpringEmbedders Namespace


Graph. Method

Picks the edge under the cursor [Not implemented].

public Edge ();

Return Value

See Also

Graph Class | SpringEmbedders Namespace


Graph. Method

Picks node where mosue is pointing.

public Node (
Point mauspos,
Camera cam
);

Parameters

Point
The mouse position.
Camera
The camera.

Return Value

The picked node or null.

See Also

Graph Class | SpringEmbedders Namespace


Graph. Method

Projects a node to screen coordinates.

public Vector3 (
Graph.Node n,
Camera cam
);

Parameters

Graph.Node
The n.
Camera
The cam.

Return Value

See Also

Graph Class | SpringEmbedders Namespace


Graph. Method

Apply pulling for nodes

public void (
Graph.Node n,
Vector2 f,
Single dt
);

Parameters

Graph.Node
The node.
Vector2
The force.
Single
The timestep.

See Also

Graph Class | SpringEmbedders Namespace


Graph. Method

Randomizes the positions of the nodes.

public void ();

See Also

Graph Class | SpringEmbedders Namespace


Graph. Method

Saves the graph to a file.

public void (
String fn,
Boolean layout
);

Parameters

String
The filename.
Boolean
if set to true the graph will be saved with the layout.

See Also

Graph Class | SpringEmbedders Namespace


Graph. Method

Scroll on layout

public void (
Vector2 d
);

Parameters

Vector2
distance

Return Value

Float

See Also

Graph Class | SpringEmbedders Namespace


Graph. Method

Select node

public void (
Graph.Node node
);

Parameters

Graph.Node
Node

See Also

Graph Class | SpringEmbedders Namespace


Graph. Method

Creates rectangle for selection (delete)

public void (
Rectangle r,
Camera cam
);

Parameters

Rectangle
The rectangele.
Camera
The camera.

See Also

Graph Class | SpringEmbedders Namespace


Graph. Method

Unselection all nodes

public void ();

See Also

Graph Class | SpringEmbedders Namespace


Graph. Method

Updates the layout.

public void (
Single dt
);

Parameters

Single
The timestep.

See Also

Graph Class | SpringEmbedders Namespace


Graph.Edge Class

Class Edge

For a list of all members of this type, see Graph.Edge Members.

System.Object
Graph.Edge

public class Graph.Edge

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SpringEmbedders

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

Graph.Edge Members | SpringEmbedders Namespace


Graph.Edge Members

Graph.Edge overview

Public Instance Constructors

Graph.Edge Constructor Constructor

Public Instance Fields

n1 | Edge node 1.
n2 | Edge node 2.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getOtherNode | Selects other node for connection
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Graph.Edge Class | SpringEmbedders Namespace


Graph.Edge Constructor

Constructor

public Graph.Edge(
Graph.Node n1,
Graph.Node n2
);

Parameters

Graph.Node
Node 1.
Graph.Node
Node 2.

See Also

Graph.Edge Class | SpringEmbedders Namespace


Graph.Edge Fields

The fields of the Graph.Edge class are listed below. For a complete list of Graph.Edge class members, see the Graph.Edge Members topic.

Public Instance Fields

n1 | Edge node 1.
n2 | Edge node 2.

See Also

Graph.Edge Class | SpringEmbedders Namespace


Graph.Edge.n1 Field

Edge node 1.

public Graph.Node n1;

See Also

Graph.Edge Class | SpringEmbedders Namespace


Graph.Edge.n2 Field

Edge node 2.

public Graph.Node n2;

See Also

Graph.Edge Class | SpringEmbedders Namespace


Graph.Edge Methods

The methods of the Graph.Edge class are listed below. For a complete list of Graph.Edge class members, see the Graph.Edge Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
getOtherNode | Selects other node for connection
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Graph.Edge Class | SpringEmbedders Namespace


Graph.Edge. Method

Selects other node for connection

public Node (
Graph.Node n
);

Parameters

Graph.Node
Node

Return Value

Node

See Also

Graph.Edge Class | SpringEmbedders Namespace


Graph.LayoutType Enumeration

Specifies the possible layout types.

public enum Graph.LayoutType

Members

Member Name | Description
Euclidean | Euclidean layout.
Spheric | Spherical layout.
Hyperbolic | Hyperbolic layout.

Requirements

Namespace: SpringEmbedders

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

SpringEmbedders Namespace


Graph.Node Class

Class for nodes.

For a list of all members of this type, see Graph.Node Members.

System.Object
Graph.Node

public class Graph.Node

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SpringEmbedders

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

Graph.Node Members | SpringEmbedders Namespace


Graph.Node Members

Graph.Node overview

Public Static Methods

invWorld Project node from world position to graph coordinates.

Public Instance Constructors

Graph.Node Overloaded. Initializes a new instance of the Graph.Node class.

Public Instance Fields

adjacency
caption
graph
sel
texIndex

Public Instance Properties

Position Gets or sets the position.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
moveTangentOffset | Moves the node in give direction in tangent space on the graph
randomizePos | Creates a randomize position for the node
ToString (inherited from Object) | Returns a String that represents the current Object.
toTangent | Transforme a node into tangent space.
toWorld | Transforms node to 3d world position.
u | Creates tangent vector u of sphere node
v | Creates tangent vector v of sphere node

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Graph.Node Class | SpringEmbedders Namespace


Graph.Node Constructor

Constructor

Overload List

minimal constructor, randomizes position

public Graph.Node(String,Graph);

Constructor

public Graph.Node(String,Graph,Single,Single);

See Also

Graph.Node Class | SpringEmbedders Namespace


Graph.Node Constructor (String, Graph, Single, Single)

Constructor

public Graph.Node(
String caption,
Graph g,
Single x,
Single y
);

Parameters

String
The caption.
Graph
The graph.
Single
x.
Single
y.

See Also

Graph.Node Class | SpringEmbedders Namespace | Graph.Node Constructor Overload List


Graph.Node Constructor (String, Graph)

minimal constructor, randomizes position

public Graph.Node(
String caption,
Graph g
);

Parameters

String
The caption.
Graph
The graph.

Return Value

See Also

Graph.Node Class | SpringEmbedders Namespace | Graph.Node Constructor Overload List


Graph.Node Fields

The fields of the Graph.Node class are listed below. For a complete list of Graph.Node class members, see the Graph.Node Members topic.

Public Instance Fields

adjacency
caption
graph
sel
texIndex

See Also

Graph.Node Class | SpringEmbedders Namespace


Graph.Node.adjacency Field

public LinkedList<T> adjacency;

See Also

Graph.Node Class | SpringEmbedders Namespace


Graph.Node.caption Field

public String caption;

See Also

Graph.Node Class | SpringEmbedders Namespace


Graph.Node.graph Field

public Graph graph;

See Also

Graph.Node Class | SpringEmbedders Namespace


Graph.Node.sel Field

public Boolean sel;

See Also

Graph.Node Class | SpringEmbedders Namespace


Graph.Node.texIndex Field

public Int32 texIndex;

See Also

Graph.Node Class | SpringEmbedders Namespace


Graph.Node Properties

The properties of the Graph.Node class are listed below. For a complete list of Graph.Node class members, see the Graph.Node Members topic.

Public Instance Properties

Position Gets or sets the position.

See Also

Graph.Node Class | SpringEmbedders Namespace


Position Property

An NDoc Documented Class Library

Graph.Node.Position Property

Gets or sets the position.

public Position {get; set;}

Property Value

The position.

See Also

Graph.Node Class | SpringEmbedders Namespace


Graph.Node Methods

The methods of the Graph.Node class are listed below. For a complete list of Graph.Node class members, see the Graph.Node Members topic.

Public Static Methods

invWorld Project node from world position to graph coordinates.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
moveTangentOffset | Moves the node in give direction in tangent space on the graph
randomizePos | Creates a randomize position for the node
ToString (inherited from Object) | Returns a String that represents the current Object.
toTangent | Transforme a node into tangent space.
toWorld | Transforms node to 3d world position.
u | Creates tangent vector u of sphere node
v | Creates tangent vector v of sphere node

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Graph.Node Class | SpringEmbedders Namespace


Graph.Node. Method

Project node from world position to graph coordinates.

public static Vector2 (
Vector3 pos,
Graph g
);

Parameters

Vector3
The 3d world posistion of a nodes.
Graph
The graph.

Return Value

Graph position.

See Also

Graph.Node Class | SpringEmbedders Namespace


Graph.Node. Method

Moves the node in give direction in tangent space on the graph

public void (
Vector2 t
);

Parameters

Vector2
Offset to move in tangent space

Return Value

See Also

Graph.Node Class | SpringEmbedders Namespace


Graph.Node. Method

Creates a randomize position for the node

public void ();

See Also

Graph.Node Class | SpringEmbedders Namespace


Graph.Node. Method

Transforme a node into tangent space.

public Vector2 (
Graph.Node n
);

Parameters

Graph.Node
Node

Return Value

Node tangent space coordinates.

See Also

Graph.Node Class | SpringEmbedders Namespace


Graph.Node. Method

Transforms node to 3d world position.

public Vector3 ();

Return Value

World postion of node.

See Also

Graph.Node Class | SpringEmbedders Namespace


Graph.Node. Method

Creates tangent vector u of sphere node

public Vector3 ();

Return Value

Tangent U

See Also

Graph.Node Class | SpringEmbedders Namespace


Graph.Node. Method

Creates tangent vector v of sphere node

public Vector3 ();

Return Value

Tangent v

See Also

Graph.Node Class | SpringEmbedders Namespace


GraphEdit Class

Class for the GraphEdit UI

For a list of all members of this type, see GraphEdit Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
GraphEdit

public class GraphEdit : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SpringEmbedders

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

GraphEdit Members | SpringEmbedders Namespace


GraphEdit Members

GraphEdit overview

Public Instance Constructors

GraphEdit Constructor Initializes a new instance of the GraphEdit class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Graph |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InEditMode |
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
rbEdit_Click |
rbSpherical_Click |
rbView_Click |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
ModeChanged |
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GraphEdit Class | SpringEmbedders Namespace


GraphEdit Constructor

Initializes a new instance of the GraphEdit class.

public GraphEdit();

See Also

GraphEdit Class | SpringEmbedders Namespace


GraphEdit Properties

The properties of the GraphEdit class are listed below. For a complete list of GraphEdit class members, see the GraphEdit Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Graph |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InEditMode |
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

GraphEdit Class | SpringEmbedders Namespace


Graph Property

An NDoc Documented Class Library

GraphEdit.Graph Property

public Graph {get; set;}

See Also

GraphEdit Class | SpringEmbedders Namespace


InEditMode Property

An NDoc Documented Class Library

GraphEdit.InEditMode Property

public InEditMode {get;}

See Also

GraphEdit Class | SpringEmbedders Namespace


GraphEdit Methods

The methods of the GraphEdit class are listed below. For a complete list of GraphEdit class members, see the GraphEdit Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
rbEdit_Click |
rbSpherical_Click |
rbView_Click |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GraphEdit Class | SpringEmbedders Namespace


Method

An NDoc Documented Class Library

GraphEdit. Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void ();

Clean up any resources being used.

protected override void (Boolean);

See Also

GraphEdit Class | SpringEmbedders Namespace


GraphEdit. Method (Boolean)

Clean up any resources being used.

protected override void (
Boolean disposing
);

Parameters

Boolean
true if managed resources should be disposed; otherwise, false.

See Also

GraphEdit Class | SpringEmbedders Namespace | GraphEdit. Overload List


GraphEdit. Method

public void (
Object sender,
EventArgs e
);

See Also

GraphEdit Class | SpringEmbedders Namespace


GraphEdit Events

The events of the GraphEdit class are listed below. For a complete list of GraphEdit class members, see the GraphEdit Members topic.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
ModeChanged |
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

GraphEdit Class | SpringEmbedders Namespace


GraphEdit.EventHandler Event

public event ModeChanged;

See Also

GraphEdit Class | SpringEmbedders Namespace


GraphInfo Class

Class for GraphInfo UI

For a list of all members of this type, see GraphInfo Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
GraphInfo

public class GraphInfo : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SpringEmbedders

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

GraphInfo Members | SpringEmbedders Namespace


GraphInfo Members

GraphInfo overview

Public Instance Constructors

GraphInfo Constructor Constructor

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
EdgeCount | sets edge count
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
NodeCount | sets node count
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Tension | sets average Tension
Text (inherited from UserControl) |
Time | sets time
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GraphInfo Class | SpringEmbedders Namespace


GraphInfo Constructor

Constructor

public GraphInfo();

See Also

GraphInfo Class | SpringEmbedders Namespace


GraphInfo Properties

The properties of the GraphInfo class are listed below. For a complete list of GraphInfo class members, see the GraphInfo Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
EdgeCount | sets edge count
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
NodeCount | sets node count
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Tension | sets average Tension
Text (inherited from UserControl) |
Time | sets time
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

GraphInfo Class | SpringEmbedders Namespace


EdgeCount Property

An NDoc Documented Class Library

GraphInfo.EdgeCount Property

sets edge count

public EdgeCount {set;}

See Also

GraphInfo Class | SpringEmbedders Namespace


NodeCount Property

An NDoc Documented Class Library

GraphInfo.NodeCount Property

sets node count

public NodeCount {set;}

See Also

GraphInfo Class | SpringEmbedders Namespace


Tension Property

An NDoc Documented Class Library

GraphInfo.Tension Property

sets average Tension

public Tension {set;}

See Also

GraphInfo Class | SpringEmbedders Namespace


Time Property

An NDoc Documented Class Library

GraphInfo.Time Property

sets time

public Time {set;}

See Also

GraphInfo Class | SpringEmbedders Namespace


GraphInfo Methods

The methods of the GraphInfo class are listed below. For a complete list of GraphInfo class members, see the GraphInfo Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GraphInfo Class | SpringEmbedders Namespace


Method

An NDoc Documented Class Library

GraphInfo. Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void ();

Clean up any resources being used.

protected override void (Boolean);

See Also

GraphInfo Class | SpringEmbedders Namespace


GraphInfo. Method (Boolean)

Clean up any resources being used.

protected override void (
Boolean disposing
);

Parameters

Boolean
true if managed resources should be disposed; otherwise, false.

See Also

GraphInfo Class | SpringEmbedders Namespace | GraphInfo. Overload List


GraphViewer Class

Graphviewer Form Class

For a list of all members of this type, see GraphViewer Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
GraphViewer

public class GraphViewer : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SpringEmbedders

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

GraphViewer Members | SpringEmbedders Namespace


GraphViewer Members

GraphViewer overview

Public Instance Constructors

GraphViewer Constructor Constructor for graphviewer.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
Init3D | Initializes 3D
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
OnResetDevice | Called when [reset device].
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
Render | Begins to render graph
Reset | Resets all
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GraphViewer Class | SpringEmbedders Namespace


GraphViewer Constructor

Constructor for graphviewer.

public GraphViewer();

See Also

GraphViewer Class | SpringEmbedders Namespace


GraphViewer Methods

The methods of the GraphViewer class are listed below. For a complete list of GraphViewer class members, see the GraphViewer Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
Init3D | Initializes 3D
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
OnResetDevice | Called when [reset device].
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
Render | Begins to render graph
Reset | Resets all
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GraphViewer Class | SpringEmbedders Namespace


Method

An NDoc Documented Class Library

GraphViewer. Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void ();

Clean up any resources being used.

protected override void (Boolean);

See Also

GraphViewer Class | SpringEmbedders Namespace


GraphViewer. Method (Boolean)

Clean up any resources being used.

protected override void (
Boolean disposing
);

Parameters

Boolean
true if managed resources should be disposed; otherwise, false.

See Also

GraphViewer Class | SpringEmbedders Namespace | GraphViewer. Overload List


GraphViewer. Method

Initializes 3D

public void ();

See Also

GraphViewer Class | SpringEmbedders Namespace


GraphViewer. Method

Called when [reset device].

public void (
Object sender,
EventArgs e
);

Parameters

Object
The sender.
EventArgs
The EventArgs instance containing the event data.

See Also

GraphViewer Class | SpringEmbedders Namespace


GraphViewer. Method

protected override void (
EventArgs e
);

Parameters

EventArgs
Eventargument

Return Value

See Also

GraphViewer Class | SpringEmbedders Namespace


GraphViewer. Method

Begins to render graph

public void ();

See Also

GraphViewer Class | SpringEmbedders Namespace


GraphViewer. Method

Resets all

public void ();

See Also

GraphViewer Class | SpringEmbedders Namespace


GroupBoxDrop Class

The general user control in the GroupBoxDropContainer

For a list of all members of this type, see GroupBoxDrop Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
GroupBoxDrop

public class GroupBoxDrop : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SpringEmbedders

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

GroupBoxDrop Members | SpringEmbedders Namespace


GroupBoxDrop Members

GroupBoxDrop overview

Public Instance Constructors

GroupBoxDrop Constructor Initializes a new instance of the GroupBoxDrop class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
Content | Gets the content.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DropState | Gets or sets a value indicating whether its opened or not.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Title | Gets or sets the title.
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
DropStateChanged | Occurs when the DropState changed.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GroupBoxDrop Class | SpringEmbedders Namespace


GroupBoxDrop Constructor

Initializes a new instance of the GroupBoxDrop class.

public GroupBoxDrop(
Control content,
String title
);

Parameters

Control
The content.
String
The title.

See Also

GroupBoxDrop Class | SpringEmbedders Namespace


GroupBoxDrop Properties

The properties of the GroupBoxDrop class are listed below. For a complete list of GroupBoxDrop class members, see the GroupBoxDrop Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
Content | Gets the content.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DropState | Gets or sets a value indicating whether its opened or not.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Title | Gets or sets the title.
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

GroupBoxDrop Class | SpringEmbedders Namespace


Content Property

An NDoc Documented Class Library

GroupBoxDrop.Content Property

Gets the content.

public Content {get;}

Property Value

The content.

See Also

GroupBoxDrop Class | SpringEmbedders Namespace


DropState Property

An NDoc Documented Class Library

GroupBoxDrop.DropState Property

Gets or sets a value indicating whether its opened or not.

public DropState {get; set;}

Property Value

true if [drop state]; otherwise, false.

See Also

GroupBoxDrop Class | SpringEmbedders Namespace


Title Property

An NDoc Documented Class Library

GroupBoxDrop.Title Property

Gets or sets the title.

public Title {get; set;}

Property Value

The title.

See Also

GroupBoxDrop Class | SpringEmbedders Namespace


GroupBoxDrop Methods

The methods of the GroupBoxDrop class are listed below. For a complete list of GroupBoxDrop class members, see the GroupBoxDrop Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GroupBoxDrop Class | SpringEmbedders Namespace


Method

An NDoc Documented Class Library

GroupBoxDrop. Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void ();

Clean up any resources being used.

protected override void (Boolean);

See Also

GroupBoxDrop Class | SpringEmbedders Namespace


GroupBoxDrop. Method (Boolean)

Clean up any resources being used.

protected override void (
Boolean disposing
);

Parameters

Boolean
true if managed resources should be disposed; otherwise, false.

See Also

GroupBoxDrop Class | SpringEmbedders Namespace | GroupBoxDrop. Overload List


GroupBoxDrop Events

The events of the GroupBoxDrop class are listed below. For a complete list of GroupBoxDrop class members, see the GroupBoxDrop Members topic.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
DropStateChanged | Occurs when the DropState changed.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

GroupBoxDrop Class | SpringEmbedders Namespace


GroupBoxDrop.EventHandler Event

Occurs when the DropState changed.

public event DropStateChanged;

See Also

GroupBoxDrop Class | SpringEmbedders Namespace


GroupBoxDropContainer Class

Container for the GroupDropBoxes

For a list of all members of this type, see GroupBoxDropContainer Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
GroupBoxDropContainer

public class GroupBoxDropContainer : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SpringEmbedders

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

GroupBoxDropContainer Members | SpringEmbedders Namespace


GroupBoxDropContainer Members

GroupBoxDropContainer overview

Public Instance Constructors

GroupBoxDropContainer Constructor Initializes a new instance of the GroupBoxDropContainer class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

AddDrop |
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveDrop |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GroupBoxDropContainer Class | SpringEmbedders Namespace


GroupBoxDropContainer Constructor

Initializes a new instance of the GroupBoxDropContainer class.

public GroupBoxDropContainer();

See Also

GroupBoxDropContainer Class | SpringEmbedders Namespace


GroupBoxDropContainer Methods

The methods of the GroupBoxDropContainer class are listed below. For a complete list of GroupBoxDropContainer class members, see the GroupBoxDropContainer Members topic.

Public Instance Methods

AddDrop |
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveDrop |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GroupBoxDropContainer Class | SpringEmbedders Namespace


GroupBoxDropContainer. Method

public void (
GroupBoxDrop box
);

See Also

GroupBoxDropContainer Class | SpringEmbedders Namespace


Method

An NDoc Documented Class Library

GroupBoxDropContainer. Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void ();

Clean up any resources being used.

protected override void (Boolean);

See Also

GroupBoxDropContainer Class | SpringEmbedders Namespace


GroupBoxDropContainer. Method (Boolean)

Clean up any resources being used.

protected override void (
Boolean disposing
);

Parameters

Boolean
true if managed resources should be disposed; otherwise, false.

See Also

GroupBoxDropContainer Class | SpringEmbedders Namespace | GroupBoxDropContainer. Overload List


GroupBoxDropContainer. Method

public void (
Int32 i
);

See Also

GroupBoxDropContainer Class | SpringEmbedders Namespace


NodeDlg Class

Dialog that shows the properties of a node

For a list of all members of this type, see NodeDlg Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
NodeDlg

public class NodeDlg : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SpringEmbedders

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

NodeDlg Members | SpringEmbedders Namespace


NodeDlg Members

NodeDlg overview

Public Instance Constructors

NodeDlg Constructor Initializes a new instance of the NodeDlg class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
SetNode | Sets the node which properties should be displayed.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown | Raises the Shown event, where the focus is set to the textbox.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

NodeDlg Class | SpringEmbedders Namespace


NodeDlg Constructor

Initializes a new instance of the NodeDlg class.

public NodeDlg();

See Also

NodeDlg Class | SpringEmbedders Namespace


NodeDlg Methods

The methods of the NodeDlg class are listed below. For a complete list of NodeDlg class members, see the NodeDlg Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
SetNode | Sets the node which properties should be displayed.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown | Raises the Shown event, where the focus is set to the textbox.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

NodeDlg Class | SpringEmbedders Namespace


Method

An NDoc Documented Class Library

NodeDlg. Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void ();

Clean up any resources being used.

protected override void (Boolean);

See Also

NodeDlg Class | SpringEmbedders Namespace


NodeDlg. Method (Boolean)

Clean up any resources being used.

protected override void (
Boolean disposing
);

Parameters

Boolean
true if managed resources should be disposed; otherwise, false.

See Also

NodeDlg Class | SpringEmbedders Namespace | NodeDlg. Overload List


NodeDlg. Method

Raises the Shown event, where the focus is set to the textbox.

protected override void (
EventArgs e
);

Parameters

EventArgs
A EventArgs that contains the event data.

See Also

NodeDlg Class | SpringEmbedders Namespace


NodeDlg. Method

Sets the node which properties should be displayed.

public void (
Graph.Node n
);

Parameters

Graph.Node
The node.

See Also

NodeDlg Class | SpringEmbedders Namespace


OffscreenRT Class

A rendertarget with an assoziated offscreen surface and functions to access its data easily.

For a list of all members of this type, see OffscreenRT Members.

System.Object
OffscreenRT

public class OffscreenRT

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SpringEmbedders

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

OffscreenRT Members | SpringEmbedders Namespace


OffscreenRT Members

OffscreenRT overview

Public Instance Constructors

OffscreenRT Constructor Initializes a new instance of the OffscreenRT class.

Public Instance Methods

EndRender | Restores the old rendertarget and depthstencil surface.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetGPUSurface | Gets the GPU surface.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLockedData | Gets the locked data stream.
GetOffscreenSurface | Gets the offscreen surface.
GetType (inherited from Object) | Gets the Type of the current instance.
GetXl | Gets the xl.
GetYl | Gets the yl.
Lock | Locks the offscreen surface.
SetSize | Sets the size.
StartRender | Set the rendertarget as new rendertarget, while the old rendertaget and depthstencil surface are keept or restore them.
ToString (inherited from Object) | Returns a String that represents the current Object.
Unlock | Unlocks the offscreen surface.
UpdateGPUSurface | Updates the GPU surface with the offscreen data.
UpdateOffscreenSurface | Updates the offscreen surface with the gpu data.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OffscreenRT Class | SpringEmbedders Namespace


OffscreenRT Constructor

Initializes a new instance of the OffscreenRT class.

public OffscreenRT(
Device device,
Int32 xl,
Int32 yl,
Format format,
Boolean autolock,
Boolean autorestore,
Boolean autoupdate
);

Parameters

Device
The device.
Int32
The width.
Int32
The height.
Format
The format.
Boolean
if set to true then the surface is automatically locked after an update.
Boolean
if set to true the gpu surface is automatically restored with the offscreen surface after a device reset, do that data can be accessed every time.
Boolean
if set to true the gpu surface is automatically copied back to the offscreen surface after rendering, to that it is always up to date.

See Also

OffscreenRT Class | SpringEmbedders Namespace


OffscreenRT Methods

The methods of the OffscreenRT class are listed below. For a complete list of OffscreenRT class members, see the OffscreenRT Members topic.

Public Instance Methods

EndRender | Restores the old rendertarget and depthstencil surface.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetGPUSurface | Gets the GPU surface.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLockedData | Gets the locked data stream.
GetOffscreenSurface | Gets the offscreen surface.
GetType (inherited from Object) | Gets the Type of the current instance.
GetXl | Gets the xl.
GetYl | Gets the yl.
Lock | Locks the offscreen surface.
SetSize | Sets the size.
StartRender | Set the rendertarget as new rendertarget, while the old rendertaget and depthstencil surface are keept or restore them.
ToString (inherited from Object) | Returns a String that represents the current Object.
Unlock | Unlocks the offscreen surface.
UpdateGPUSurface | Updates the GPU surface with the offscreen data.
UpdateOffscreenSurface | Updates the offscreen surface with the gpu data.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OffscreenRT Class | SpringEmbedders Namespace


OffscreenRT. Method

Restores the old rendertarget and depthstencil surface.

public void ();

See Also

OffscreenRT Class | SpringEmbedders Namespace


OffscreenRT. Method

Gets the GPU surface.

public Texture ();

Return Value

See Also

OffscreenRT Class | SpringEmbedders Namespace


OffscreenRT. Method

Gets the locked data stream.

public GraphicsStream ();

Return Value

See Also

OffscreenRT Class | SpringEmbedders Namespace


OffscreenRT. Method

Gets the offscreen surface.

public Texture ();

Return Value

See Also

OffscreenRT Class | SpringEmbedders Namespace


OffscreenRT. Method

Gets the xl.

public int ();

Return Value

See Also

OffscreenRT Class | SpringEmbedders Namespace


OffscreenRT. Method

Gets the yl.

public int ();

Return Value

See Also

OffscreenRT Class | SpringEmbedders Namespace


OffscreenRT. Method

Locks the offscreen surface.

public GraphicsStream ();

Return Value

See Also

OffscreenRT Class | SpringEmbedders Namespace


OffscreenRT. Method

Sets the size.

public void (
Int32 xl,
Int32 yl
);

Parameters

Int32
The xl.
Int32
The yl.

See Also

OffscreenRT Class | SpringEmbedders Namespace


OffscreenRT. Method

Set the rendertarget as new rendertarget, while the old rendertaget and depthstencil surface are keept or restore them.

public void ();

See Also

OffscreenRT Class | SpringEmbedders Namespace


OffscreenRT. Method

Unlocks the offscreen surface.

public void ();

See Also

OffscreenRT Class | SpringEmbedders Namespace


OffscreenRT. Method

Updates the GPU surface with the offscreen data.

public void ();

See Also

OffscreenRT Class | SpringEmbedders Namespace


OffscreenRT. Method

Updates the offscreen surface with the gpu data.

public void ();

See Also

OffscreenRT Class | SpringEmbedders Namespace


SaveDlg Class

Save Dialog.

For a list of all members of this type, see SaveDlg Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
SaveDlg

public class SaveDlg : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SpringEmbedders

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

SaveDlg Members | SpringEmbedders Namespace


SaveDlg Members

SaveDlg overview

Public Instance Constructors

SaveDlg Constructor Initializes a new instance of the SaveDlg class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
SaveGraphOnly |
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SaveDlg Class | SpringEmbedders Namespace


SaveDlg Constructor

Initializes a new instance of the SaveDlg class.

public SaveDlg();

See Also

SaveDlg Class | SpringEmbedders Namespace


SaveDlg Properties

The properties of the SaveDlg class are listed below. For a complete list of SaveDlg class members, see the SaveDlg Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
SaveGraphOnly |
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

SaveDlg Class | SpringEmbedders Namespace


SaveGraphOnly Property

An NDoc Documented Class Library

SaveDlg.SaveGraphOnly Property

public SaveGraphOnly {get;}

See Also

SaveDlg Class | SpringEmbedders Namespace


SaveDlg Methods

The methods of the SaveDlg class are listed below. For a complete list of SaveDlg class members, see the SaveDlg Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SaveDlg Class | SpringEmbedders Namespace


Method

An NDoc Documented Class Library

SaveDlg. Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void ();

Clean up any resources being used.

protected override void (Boolean);

See Also

SaveDlg Class | SpringEmbedders Namespace


SaveDlg. Method (Boolean)

Clean up any resources being used.

protected override void (
Boolean disposing
);

Parameters

Boolean
true if managed resources should be disposed; otherwise, false.

See Also

SaveDlg Class | SpringEmbedders Namespace | SaveDlg. Overload List


SimulationParameters Class

Layout simulation parameters.

For a list of all members of this type, see SimulationParameters Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
SimulationParameters

public class SimulationParameters : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SpringEmbedders

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

SimulationParameters Members | SpringEmbedders Namespace


SimulationParameters Members

SimulationParameters overview

Public Instance Constructors

SimulationParameters Constructor Initializes a new instance of the SimulationParameters class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoK | Gets or sets a value indicating whether kopt is calculated automatically.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForceScale | Gets or sets the ForceScale.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
KOpt | Gets or sets Kopt.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaxDisp | Gets or sets the max displacement of a node.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MaxTimestep | Gets or sets the max timestep.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Realtime | Gets a value indicating whether the simulation is updated in realtime or not.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
SupportGPUAcceleration | Gets or sets a value indicating whether [support GPU acceleration].
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseGPUAccceleration | Gets or sets a value indicating whether [use GPU accceleration].
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
OnGPUAccelUseChange | Occurs when UseGPUAccceleration changed
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SimulationParameters Class | SpringEmbedders Namespace


SimulationParameters Constructor

Initializes a new instance of the SimulationParameters class.

public SimulationParameters();

See Also

SimulationParameters Class | SpringEmbedders Namespace


SimulationParameters Properties

The properties of the SimulationParameters class are listed below. For a complete list of SimulationParameters class members, see the SimulationParameters Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoK | Gets or sets a value indicating whether kopt is calculated automatically.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForceScale | Gets or sets the ForceScale.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
KOpt | Gets or sets Kopt.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaxDisp | Gets or sets the max displacement of a node.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MaxTimestep | Gets or sets the max timestep.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Realtime | Gets a value indicating whether the simulation is updated in realtime or not.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
SupportGPUAcceleration | Gets or sets a value indicating whether [support GPU acceleration].
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseGPUAccceleration | Gets or sets a value indicating whether [use GPU accceleration].
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

SimulationParameters Class | SpringEmbedders Namespace


AutoK Property

An NDoc Documented Class Library

SimulationParameters.AutoK Property

Gets or sets a value indicating whether kopt is calculated automatically.

public AutoK {get; set;}

Property Value

true if [auto K]; otherwise, false.

See Also

SimulationParameters Class | SpringEmbedders Namespace


ForceScale Property

An NDoc Documented Class Library

SimulationParameters.ForceScale Property

Gets or sets the ForceScale.

public ForceScale {get; set;}

Property Value

The force scale.

See Also

SimulationParameters Class | SpringEmbedders Namespace


KOpt Property

An NDoc Documented Class Library

SimulationParameters.KOpt Property

Gets or sets Kopt.

public KOpt {get; set;}

Property Value

The K opt.

See Also

SimulationParameters Class | SpringEmbedders Namespace


MaxDisp Property

An NDoc Documented Class Library

SimulationParameters.MaxDisp Property

Gets or sets the max displacement of a node.

public MaxDisp {get; set;}

Property Value

The max disp.

See Also

SimulationParameters Class | SpringEmbedders Namespace


MaxTimestep Property

An NDoc Documented Class Library

SimulationParameters.MaxTimestep Property

Gets or sets the max timestep.

public MaxTimestep {get; set;}

Property Value

The max timestep.

See Also

SimulationParameters Class | SpringEmbedders Namespace


Realtime Property

An NDoc Documented Class Library

SimulationParameters.Realtime Property

Gets a value indicating whether the simulation is updated in realtime or not.

public Realtime {get;}

Property Value

true if realtime; otherwise, false.

See Also

SimulationParameters Class | SpringEmbedders Namespace


SupportGPUAcceleration Property

An NDoc Documented Class Library

SimulationParameters.SupportGPUAcceleration Property

Gets or sets a value indicating whether [support GPU acceleration].

public SupportGPUAcceleration {get; set;}

Property Value

true if [support GPU acceleration]; otherwise, false.

See Also

SimulationParameters Class | SpringEmbedders Namespace


UseGPUAccceleration Property

An NDoc Documented Class Library

SimulationParameters.UseGPUAccceleration Property

Gets or sets a value indicating whether [use GPU accceleration].

public UseGPUAccceleration {get; set;}

Property Value

true if [use GPU accceleration]; otherwise, false.

See Also

SimulationParameters Class | SpringEmbedders Namespace


SimulationParameters Methods

The methods of the SimulationParameters class are listed below. For a complete list of SimulationParameters class members, see the SimulationParameters Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SimulationParameters Class | SpringEmbedders Namespace


Method

An NDoc Documented Class Library

SimulationParameters. Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void ();

Clean up any resources being used.

protected override void (Boolean);

See Also

SimulationParameters Class | SpringEmbedders Namespace


SimulationParameters. Method (Boolean)

Clean up any resources being used.

protected override void (
Boolean disposing
);

Parameters

Boolean
true if managed resources should be disposed; otherwise, false.

See Also

SimulationParameters Class | SpringEmbedders Namespace | SimulationParameters. Overload List


SimulationParameters Events

The events of the SimulationParameters class are listed below. For a complete list of SimulationParameters class members, see the SimulationParameters Members topic.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
OnGPUAccelUseChange | Occurs when UseGPUAccceleration changed
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

SimulationParameters Class | SpringEmbedders Namespace


SimulationParameters.EventHandler Event

Occurs when UseGPUAccceleration changed

public event OnGPUAccelUseChange;

See Also

SimulationParameters Class | SpringEmbedders Namespace


VisualParameters Class

Parameters to draw the graph

For a list of all members of this type, see VisualParameters Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
VisualParameters

public class VisualParameters : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SpringEmbedders

Assembly: SpringEmbedders (in SpringEmbedders.exe)

See Also

VisualParameters Members | SpringEmbedders Namespace


VisualParameters Members

VisualParameters overview

Public Instance Constructors

VisualParameters Constructor Initializes a new instance of the VisualParameters class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DrawCaptions | Gets a value indicating whether [draw captions].
EdgeColor | Gets the color of the edge.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutColor | Gets the color of the layout.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
NodeColor | Gets the color of the node.
NodeScale | Gets the node scale.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

VisualParameters Class | SpringEmbedders Namespace


VisualParameters Constructor

Initializes a new instance of the VisualParameters class.

public VisualParameters();

See Also

VisualParameters Class | SpringEmbedders Namespace


VisualParameters Properties

The properties of the VisualParameters class are listed below. For a complete list of VisualParameters class members, see the VisualParameters Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DrawCaptions | Gets a value indicating whether [draw captions].
EdgeColor | Gets the color of the edge.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutColor | Gets the color of the layout.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
NodeColor | Gets the color of the node.
NodeScale | Gets the node scale.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

VisualParameters Class | SpringEmbedders Namespace


DrawCaptions Property

An NDoc Documented Class Library

VisualParameters.DrawCaptions Property

Gets a value indicating whether [draw captions].

public DrawCaptions {get;}

Property Value

true if [draw captions]; otherwise, false.

See Also

VisualParameters Class | SpringEmbedders Namespace


EdgeColor Property

An NDoc Documented Class Library

VisualParameters.EdgeColor Property

Gets the color of the edge.

public EdgeColor {get;}

Property Value

The color of the edge.

See Also

VisualParameters Class | SpringEmbedders Namespace


LayoutColor Property

An NDoc Documented Class Library

VisualParameters.LayoutColor Property

Gets the color of the layout.

public LayoutColor {get;}

Property Value

The color of the layout.

See Also

VisualParameters Class | SpringEmbedders Namespace


NodeColor Property

An NDoc Documented Class Library

VisualParameters.NodeColor Property

Gets the color of the node.

public NodeColor {get;}

Property Value

The color of the node.

See Also

VisualParameters Class | SpringEmbedders Namespace


NodeScale Property

An NDoc Documented Class Library

VisualParameters.NodeScale Property

Gets the node scale.

public NodeScale {get;}

Property Value

The node scale.

See Also

VisualParameters Class | SpringEmbedders Namespace


VisualParameters Methods

The methods of the VisualParameters class are listed below. For a complete list of VisualParameters class members, see the VisualParameters Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

VisualParameters Class | SpringEmbedders Namespace


Method

An NDoc Documented Class Library

VisualParameters. Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void ();

Clean up any resources being used.

protected override void (Boolean);

See Also

VisualParameters Class | SpringEmbedders Namespace


VisualParameters. Method (Boolean)

Clean up any resources being used.

protected override void (
Boolean disposing
);

Parameters

Boolean
true if managed resources should be disposed; otherwise, false.

See Also

VisualParameters Class | SpringEmbedders Namespace | VisualParameters. Overload List


Hierarchy

System.Object
Microsoft.Win32.LocalWindowsHook
Microsoft.Win32.LocalCbtHook
Microsoft.Win32.MouseHook ---- System.IDisposable
Microsoft.Win32.MouseHookEventArgs
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Microsoft.Win32.LocalCbtHook.CbtEventHandler
Microsoft.Win32.LocalWindowsHook.HookEventHandler
Microsoft.Win32.LocalWindowsHook.HookProc
Microsoft.Win32.MouseHookEventHandler
System.EventArgs
Microsoft.Win32.CbtEventArgs
Microsoft.Win32.HookEventArgs
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Microsoft.Win32.CbtHookAction
Microsoft.Win32.HitTestCode
Microsoft.Win32.HookType

See Also

Microsoft.Win32 Namespace


Hierarchy

System.Object
SpringEmbedders.Camera
SpringEmbedders.Complex
SpringEmbedders.DynamicVB
SpringEmbedders.Graph
SpringEmbedders.Graph.Edge
SpringEmbedders.Graph.Node
SpringEmbedders.OffscreenRT
System.MarshalByRefObject
System.ComponentModel.Component ---- System.ComponentModel.IComponent, System.IDisposable
System.Windows.Forms.Control ---- System.ComponentModel.ISynchronizeInvoke, System.Windows.Forms.IBindableComponent, System.Windows.Forms.IDropTarget, System.Windows.Forms.IWin32Window
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl ---- System.Windows.Forms.IContainerControl
System.Windows.Forms.Form
SpringEmbedders.GraphViewer
SpringEmbedders.NodeDlg
SpringEmbedders.SaveDlg
System.Windows.Forms.UserControl
SpringEmbedders.GraphEdit
SpringEmbedders.GraphInfo
SpringEmbedders.GroupBoxDrop
SpringEmbedders.GroupBoxDropContainer
SpringEmbedders.SimulationParameters
SpringEmbedders.VisualParameters
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
SpringEmbedders.Graph.LayoutType

See Also

SpringEmbedders Namespace